OSPF over Frame-Relay


Scenario:

After successfully configuring the previous frame-relay lab you feel it’s time to try and run OSPF over this frame-relay link. OSPF knows many different network types and every type has a different solution, up to you to try them all out!

Hint: this lab uses the same topology as the “Frame-Relay Basics” lab, make sure you configured this lab first, then continue with this one.

Goal:

  • Create loopbacks on all routers:
    Paris: 1.1.1.1 /24
    Berlin: 2.2.2.2 /24
    Stockholm: 3.3.3.3 /24
  • Configure OSPF on all routers using the point-to-multipoint interface (192.168.123.X subnet).
  • Advertise all loopbacks in OSPF.
  • Paris should be the OSPF designated router.
  • Configure the OSPF network type on all routers to “Broadcast”, ensure you have full connectivity to all subnets.
  • Configure the OSPF network type on all routers to “Non-Broadcast”, ensure you still have full connectivity.
  • Configure the OSPF network type on all routers to “Point-to-Multipoint”, ensure you still have full connectivity.
  • Configure the OSPF network type on all routers to “Point-to-Multipoint non-broadcast”, ensure you still have full connectivity.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about OSPF, network types, frame-relay and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

OSPF over Frame-Relay

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

22 Comments

  1. Hi Everyone, I m trying to add these configs on to GNS3 an I get this error message”206-unable to create UDP NIO” please help

  2. Is there a way to setup a dlci from stockholm to berlin. How would you connect the serial connection for it. It would be for redundancy in case Paris router went down then stockholm and berlin could still reach each other.

    thanks

  3. Hi Joe,

    This is no problem…just create another PVC on the Frame-Relay switch. You could use DLCI 203 on router Berlin and DLCI 302 on router Stockholm.

    On the frame-relay switch you need to configure this PVC:

    Serial 0/1
    Frame-relay route 203 S0/2 302

    Serial 0/2
    Frame-relay route 302 s0/1 203

    That takes care of the frame-relay switch.

    Of course on the Routers you need to configure this PVC as well…you can create a new sub-interface and put the DLCI there.

    1. Hi Rene
      My name is Jean Kelly
      and I’m from Namibia in Africa
      I want to say Big thanks to your effort to make some of us our lives easier in order to study Cisco
      Long story short so far I have CCNA and i have passed 2 CCNP Exams Routing and Switching
      and currently busy with T-shoot,you advice please at time i feel disappointed doing Cisco but working with VSAT,will this make my CV look useless should i one day apply for new a Position where they need a CISCO Person?
      Also what i would like to ask is i have been tasked to Designed a 2 Directed connected Cisco Routers
      To have a VPN,my Question is how do i make it possible,1.which configurations will i used?
      Looking forward to hear from you soon
      Regards,
      Jean Kelly
      E-mail:jeankelly11@ymail.com

  4. Hey Rene, did this get left out of the .zip file by chance? It’s not there and wanted to see if you could upload it please!

    Thank you so much!
    Binaryops

  5. Can somebody help me with this lab?? I configured it but, Unfortunately I can just see one ospf route on Paris, I got confused..

    [b]FRSW[/b]

    FRSW#sh frame-relay route
    Input Intf Input Dlci Output Intf Output Dlci Status
    Serial0/0 102 Serial0/1 201 active
    Serial0/0 103 Serial0/2 301 active
    Serial0/1 201 Serial0/0 102 active
    Serial0/2 301 Serial0/0 103 active

    [b]R1[/b]

    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.1 multipoint
    ip address 192.168.123.1 255.255.255.0
    ip ospf priority 100
    frame-relay map ip 192.168.123.2 102 broadcast
    frame-relay map ip 192.168.123.3 103 broadcast
    !
    router ospf 1
    log-adjacency-changes
    network 1.1.1.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0
    neighbor 192.168.123.2
    neighbor 192.168.123.3

    ——————–
    Paris#[b]sh ip route
    [/b]
    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.1
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    3.0.0.0/32 is subnetted, 1 subnets
    O 3.3.3.3 [110/65] via 192.168.123.3, 00:16:22, Serial0/0.1

    [b]R2[/b]

    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.2 multipoint
    ip address 192.168.123.2 255.255.255.0
    frame-relay map ip 192.168.123.1 201 broadcast
    frame-relay map ip 192.168.123.3 201 broadcast
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0

    ——————
    Berlin#[b]sh ip route[/b]

    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.2
    2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Loopback0

    [b]R3[/b]

    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.3 multipoint
    ip address 192.168.123.3 255.255.255.0
    frame-relay map ip 192.168.123.1 301 broadcast
    frame-relay map ip 192.168.123.2 301 broadcast

    router ospf 1
    log-adjacency-changes
    network 3.3.3.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0

    ———————–
    Stockholm#[b]sh ip route[/b]

    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.3
    1.0.0.0/32 is subnetted, 1 subnets
    O 1.1.1.1 [110/65] via 192.168.123.1, 00:04:22, Serial0/0.3
    3.0.0.0/24 is subnetted, 1 subnets
    C 3.3.3.0 is directly connected, Loopback0

    What did I miss? please!

    1. HI
      can somebody help me:
      To have a directed successful VPN ,my Question is ,1.which configurations will i used?
      Looking forward to hear from you soon
      Regards,
      Jean Kelly
      E-mail:jeankelly11@ymail.com

  6. enter your message here…[quote=sunyijanika]Can somebody help me with this lab?? I configured it but, Unfortunately I can just see one ospf route on Paris, I got confused..

    [b]FRSW[/b]

    FRSW#sh frame-relay route
    Input Intf Input Dlci Output Intf Output Dlci Status
    Serial0/0 102 Serial0/1 201 active
    Serial0/0 103 Serial0/2 301 active
    Serial0/1 201 Serial0/0 102 active
    Serial0/2 301 Serial0/0 103 active

    [b]R1[/b]

    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.1 multipoint
    ip address 192.168.123.1 255.255.255.0
    ip ospf priority 100
    frame-relay map ip 192.168.123.2 102 broadcast
    frame-relay map ip 192.168.123.3 103 broadcast
    !
    router ospf 1
    log-adjacency-changes
    network 1.1.1.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0
    neighbor 192.168.123.2
    neighbor 192.168.123.3

    ——————–
    Paris#[b]sh ip route
    [/b]
    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.1
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    3.0.0.0/32 is subnetted, 1 subnets
    O 3.3.3.3 [110/65] via 192.168.123.3, 00:16:22, Serial0/0.1

    [b]R2[/b]

    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.2 multipoint
    ip address 192.168.123.2 255.255.255.0
    frame-relay map ip 192.168.123.1 201 broadcast
    frame-relay map ip 192.168.123.3 201 broadcast
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0

    ——————
    Berlin#[b]sh ip route[/b]

    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.2
    2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Loopback0

    [b]R3[/b]

    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.3 multipoint
    ip address 192.168.123.3 255.255.255.0
    frame-relay map ip 192.168.123.1 301 broadcast
    frame-relay map ip 192.168.123.2 301 broadcast

    router ospf 1
    log-adjacency-changes
    network 3.3.3.0 0.0.0.255 area 0
    network 192.168.123.0 0.0.0.255 area 0

    ———————–
    Stockholm#[b]sh ip route[/b]

    Gateway of last resort is not set

    C 192.168.123.0/24 is directly connected, Serial0/0.3
    1.0.0.0/32 is subnetted, 1 subnets
    O 1.1.1.1 [110/65] via 192.168.123.1, 00:04:22, Serial0/0.3
    3.0.0.0/24 is subnetted, 1 subnets
    C 3.3.3.0 is directly connected, Loopback0

    What did I miss out? please![/quote]

    1. Check the OSPF network type for the serial interface. I believe by default it’s non-broadcast. You’ll have to change the network type or specify neighbors manually.

      1. Thanks! You’re right, default is non-broadcast. I just left a neighbor command on one of the spoke routers, but without that command the neighborship came up.

  7. Hi Rene, i’m trying to get the topology for this exercice and it does not appear… Greetings from Chile! 😀

  8. I am unable to download the topology for this one !

    Am I doing something wrong or it is just not there ?

    Thanks.

Comments are closed.