Scenario:
You are the owner of a small ISP company located in The Netherlands. Most of the equipment you have running is fairly old and you have multiple different serial links in use. Bandwidth is an issue and since you don’t have the budget to replace any links you are looking for a cheaper solution…think you can compress things?
Goal:
- All IP addresses have been preconfigured for you.
- Configure Frame Relay encapsulation between router Chop and Slice.
- Configure a loopback0 interface with IP address 1.1.1.1 /24 on router Frank.
- Configure OSPF on all routers, ensure you have full connectivity.
- Configure DE marking on router Chop. All IP packets from network 1.1.1.0 /24 should be marked as Discard Eligible when they are sent to router Slice.
IOS:
c3640-jk9s-mz.124-16.bin
Topology:
Configuration Files
You need to register to download the GNS3 topology file. (Registration is free!)Once you are logged in you will find the configuration files right here.
Do you want your CCNA or CCNP Certificate?
The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.
Written by René Molenaar - CCIE #41726
CHOP configuration. In my config it’s R1.
R1#show run
Building configuration…
Current configuration : 1894 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
!
frame-relay switching
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
ip ssh version 1
!
class-map match-all FRANK-IN
match access-group name FRANK-IN
!
!
policy-map SHAPE
class FRANK-IN
set fr-de
!
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
ip nbar protocol-discovery
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.23.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay map ip 192.168.23.1 103 broadcast
frame-relay interface-dlci 103
frame-relay intf-type dce
service-policy output SHAPE
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip access-list extended FRANK-IN
permit ip any any
ip access-list extended HTTP
permit tcp any any eq www
ip access-list extended ICMP
permit icmp any any
ip access-list extended RTP
permit udp any any range 16384 32767
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R1#show policy-map int s1/0
Serial1/0
Service-policy output: SHAPE
Class-map: FRANK-IN (match-all)
285 packets, 28640 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group name FRANK-IN
QoS Set
fr-de
Packets marked 285
Class-map: class-default (match-any)
23 packets, 331 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any