EIGRP over Frame-Relay with Sub-interfaces


Scenario:

A couple of stooge network engineers are trying to configure EIGRP over the frame-relay network. They read all about frame-relay, EIGRP and split-horizon and decided it sounded like a good idea to use sub-interface. Unfortunately things are not working as they should. Do you think you can help them out?

Goal:

  • All IP addresses have been preconfigured for you as specified in the topology picture except for router Moe.
  • Every router has a loopback0 interface:
    Moe: 1.1.1.1 /24
    Curly: 2.2.2.2 /24
    Larry: 3.3.3.3 /24
  • You are not allowed to make any changes to the frame-relay configurations.
  • Configure a sub-interface on router Moe for each PVC.
  • Configure EIGRP AS 123 on all routers and advertise the loopback interfaces.
  • Ensure router Curly and Larry can see each other’s loopback interfaces. Test this by sending a ping that is sourced from the loopback0 interfaces and destined for the other loopback0 interface.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about EIGRP, frame-relay configuration and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

EIGRP Frame-Relay Sub-interfaces

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by Renรฉ Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

Renรฉ - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

52 Comments

  1. These labs with your ROUTE book is the magic I’ve been waiting for! Thanks Rene! Knocked this lab out of the water without watching your video. ๐Ÿ™‚ On to the next one.

  2. Hi Daniel,

    Thanks for your comment,and thanks for buying my “How to Master CCNP ROUTE”book 8) Glad you like it!

    Rene

    1. You could but there’s no need to because these routers only have one PVC.

  3. paskoul
    you don’t need to configure sub interface on Larry and Curly, but frame relay map configuration.
    br

    1. not yet, seems i forgot this one ๐Ÿ˜› i’ll add it soon…the other frame-relay videos are helpful though

  4. Why does the ping fail if it is sourced from the S0/0 of Larry to the curly router?
    I tryed this lab with the Multipoint config and only a unique network regrouping all the three routers with a hub (Moe) and spokes topology.

    1. Hi Yosri,

      Do a "show frame-relay map" on router Larry and Curly that will give you the answer.

      Rene

  5. Hi Rene,
    Any idea when the video solution for this lab will be available ?

  6. hi I’m getting some errors….I can ping from larry to s0/0 of curly….but i cant ping vice verse…please see config

    Moe#sh run
    Building configuration…

    Current configuration : 1430 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Moe
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip subnet-zero
    !
    !
    ip cef
    no ip dhcp use vrf connected
    !
    !
    no ip ips deny-action ips-interface
    !
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no crypto isakmp ccm
    !
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    no frame-relay inverse-arp
    !
    interface Serial0/0.1 point-to-point
    ip address 192.168.12.1 255.255.255.0
    frame-relay interface-dlci 102
    !
    interface Serial0/0.2 point-to-point
    ip address 192.168.13.1 255.255.255.0
    frame-relay interface-dlci 103
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    router eigrp 123
    network 1.0.0.0 0.0.0.255
    network 192.168.12.0
    network 192.168.13.0
    auto-summary
    !
    ip http server
    no ip http secure-server
    ip classless
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Curly#sh run
    Building configuration…

    Current configuration : 1234 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Curly
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip subnet-zero
    !
    !
    ip cef
    no ip dhcp use vrf connected
    !
    !
    no ip ips deny-action ips-interface
    !
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no crypto isakmp ccm
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.12.2 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    frame-relay map ip 192.168.12.1 201 broadcast
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    router eigrp 123
    network 2.0.0.0 0.0.0.255
    network 192.168.12.0
    auto-summary
    !
    ip http server
    no ip http secure-server
    ip classless
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Larry#sh run
    Building configuration…

    Current configuration : 1254 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Larry
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip subnet-zero
    !
    !
    ip cef
    no ip domain lookup
    no ip dhcp use vrf connected
    !
    !
    no ip ips deny-action ips-interface
    !
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no crypto isakmp ccm
    !
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.13.3 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    frame-relay map ip 192.168.13.1 301 broadcast
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    router eigrp 123
    network 3.0.0.0 0.0.0.255
    network 192.168.13.0
    auto-summary
    !
    ip http server
    no ip http secure-server
    ip classless
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    help me please…

    1. I see a frame-relay map for the hub router on your two spoke routers. This will allow them to ping the hub router. This works right?

      The spoke routers are not in the same subnet so it has to be routed. Check your routing table for two things:

      A) Is the subnet of the other spoke router in the routing table?
      B) Is tne next hop IP address for this subnet reachable?

      Make sure the next hop is reachable by using the correct frame-relay map command.

      1. Can we use just this ?

        1) allow Inverse Arp
        frame-relay inverse-arp
        2) Configure DLCI
        frame relay interface-dlci X

  7. Rene you are doing an amazing thing helping people with these labs, thanks so much for taking the time to do all of this and help people to learn.
    you are doing a fantastic job, i am studying for my ccna and these labs are really an awesome way to learn.
    THANKS !!

  8. Hi Rene,

    I have already study Cisco Press book for CCNP Route and I still have "grey areas", but when I bought your "Master CCNP ROUTE" – I have to admit that you have had explained some of the topics much simpler and subjects are easier to assimilate. This LAB is great as well – cheers.

    Regards,
    Jarek

  9. When you say "โ€ขYou are not allowed to make any changes to the frame-relay configurations" I think you mean the configurations on the FRAME RELAY SWITCH. Whether its a multipoint or point to point, you have to add frame relay statements to Larry and Curly. I spent a long time trying to figure out some way to do this lab without changing ANY frame relay statements because I was under the impression that I couldn’t change anything in Frame Relay except on MOE.

    1. Maybe I should have been more specific. What I meant is that you are not allowed to make any changes to DLCI numbers, number of PVCs or add/remove interfaces.

      Inverse ARP is disabled so you’ll have to do a mapping for sure.

    2. agree to that40 min, lost on that, but hey i kept on reading to see whats this technique is, learned some other stuff, its good in all ways

      thanks rene

  10. Hi Rene,

    I am Brazilian and love your labs.

    I solved this lab making this:

    I created 2 sub-interfaces in router Moe and set the dlci in the interfaces:

    interface Serial0/0.12 point-to-point
    ip address 192.168.12.1 255.255.255.0
    frame-relay interface-dlci 102
    end

    interface Serial0/0.13 point-to-point
    ip address 192.168.13.1 255.255.255.0
    frame-relay interface-dlci 103

    In the routers Curly and Larry I created two frame relay maps:

    frame-relay map ip 192.168.12.1 201

    frame-relay map ip 192.168.13.1 301

    And set the neighbors int the eigrp processes:

    Moe#
    neighbor 192.168.12.2 Serial0/0.12
    neighbor 192.168.13.3 Serial0/0.13

    Curly#
    neighbor 192.168.12.1 Serial0/0

    Larry#
    neighbor 192.168.13.1 Serial0/0

    [b]These are the settings that were on your mind?[/b]

    1. this is the correct answer for full connectivity

      Moe#s
      !
      hostname Moe
      !
      !
      !
      interface Loopback0
      ip address 1.1.1.1 255.255.255.0
      !
      interface Serial0/0
      no ip address
      encapsulation frame-relay
      no ip split-horizon eigrp 1
      serial restart-delay 0
      !
      interface Serial0/0.102 point-to-point
      ip address 192.168.12.1 255.255.255.0
      no ip split-horizon eigrp 1
      frame-relay interface-dlci 102
      !
      interface Serial0/0.103 point-to-point
      ip address 192.168.13.1 255.255.255.0
      no ip split-horizon eigrp 1
      frame-relay interface-dlci 103
      !
      !
      router eigrp 1
      network 0.0.0.0
      no auto-summary
      !
      !
      alias exec s show runn
      !
      line con 0
      logging synchronous
      line aux 0
      line vty 0 4
      login
      !
      !
      End
      Curly#s
      !
      hostname Curly
      !
      !
      interface Loopback0
      ip address 2.2.2.2 255.255.255.0
      !
      interface Serial0/0
      ip address 192.168.12.2 255.255.255.0
      encapsulation frame-relay
      serial restart-delay 0
      frame-relay map ip 192.168.12.1 201 broadcast
      frame-relay interface-dlci 201
      !
      !
      router eigrp 1
      network 0.0.0.0
      no auto-summary
      !
      !
      alias exec s show runn
      !
      line con 0
      logging synchronous
      !
      !
      End

      Larry#s
      !
      hostname Larry
      !
      interface Loopback0
      ip address 3.3.3.3 255.255.255.0
      !
      interface Serial0/0
      ip address 192.168.13.3 255.255.255.0
      encapsulation frame-relay
      serial restart-delay 0
      frame-relay map ip 192.168.13.1 301 broadcast
      frame-relay interface-dlci 301
      !
      !
      router eigrp 1
      network 0.0.0.0
      no auto-summary
      !
      !
      alias exec s show runn
      !
      line con 0
      logging synchronous
      !
      end

      1. Are both of these statements needed when configuring frame relay point-to-point?

        [i]frame-relay map ip 192.168.13.1 301 broadcast
        frame-relay interface-dlci 301[/i][color=red][/color]

        We dont use the static frame map statement on the sub interfaces, are both of these statements needed if the int is not a subinterface?

        Also why do we need no ip split horizon on the sub and physical interface of “MOE” I thought the point of doing point to point configuration is to make as many sub interfaces as you need and not have to worry about the split horizon problem?

        I removed all the static mappins on the sub interfaces and i also removed the disabling of split horizon on all the interfaces for moe, everything still works i dont think is needed since were using sub interfaces instead.

        I still have one question how come my EIGRP advertisements are NOT working? this is what i have for MOE and similar on the rest of routers.

        router eigrp 1
        network 1.1.1.1 0.0.0.0
        network 192.168.12.0 0.0.0.0
        network 192.168.13.0 0.0.0.0

        But instead your config(below) does advertise all routes as it should, and it works properly any ideas why my advisements are not working. ?

        router eigrp 1
        network 0.0.0.0
        no auto-summary

        I appreciate everyone’s time and work here.

        Good luck everyone!

        – Angel

        1. hey even i have similar doubts

          the best i can come up with is that,

          the command for the sub interface( frame relay interface dlci) on Moe cause it has sub interfaces

          and for the physical interfaces(frame relay map ip) cause its a physical interface,

          but in the book, there is a similar lab, and the sub interface command works for hub and spoke,

          can some one explain, why dwelling into broadcast, multicast and such topics

      2. Hola Angel,

        Are both of these statements needed when configuring frame relay point-to-point?

        [i]frame-relay map ip 192.168.13.1 301 broadcast
        frame-relay interface-dlci 301[/i][color=red][/color]

        We dont use the static frame map statement on the sub interfaces, are both of these statements needed if the int is not a subinterface?

        — if i do understand well you question i would say you need

        frame-relay interface-dlci 301 on the ……………………….HUB
        frame-relay map ip 192.168.13.1 301 broadcast …. on the spokes

        ———————-

        Also why do we need no ip split horizon on the sub and physical interface of โ€œMOEโ€

        — Your are right, we do not need to disable split horizon

        ———————-

        I still have one question how come my EIGRP advertisements are NOT working? this is what i have for MOE and similar on the rest of routers.

        router eigrp 1
        network 1.1.1.1 0.0.0.0
        network 192.168.12.0 0.0.0.0
        network 192.168.13.0 0.0.0.0

        —- the problem here is that your wildcard masks, basically the last 0 s on your masks are telling eigrp to advertise the last octects of each address as it is written, so e.g you are advertising 192.168.12.0 and not the whole last octect 192.168.12.from 0 to 255.
        Try

        router eigrp 1
        network 1.1.1.1 0.0.0.0
        network 192.168.12.0 0.0.0.255
        network 192.168.13.0 0.0.0.255

        His works because he is not applying a wildcard is just putting lets say a deffault to all of his routes to be advertised with eigrp

        router eigrp 1
        network 0.0.0.0 >>>> lets say like if there would be a wildcard of 255.255.255.255

        Hope it helps after a year ๐Ÿ™‚

    2. I had about the same config as you had… I forgot to add the broadcast keyword behind my DLCI mappings, and only got the neighbour relationships to work with static neighbor commands.

      Once you add the broadcast keyword on Curly and Larry the neighborships pop up.

      Lessons learned ๐Ÿ™‚

  11. Hi,

    My lab work. I can ping everything, except the local interface 192.168.13.1 on MOE (but I can ping it from Curly and Larry). What could be the problem (I am sure it a stupid mistake but I can’t fix it :s) ? Thanks in advance ๐Ÿ™‚

    1. Ey Keithsistrunk,

      I think the final solution is allready pasted above within the replies.

      Anyway to give you a cleaner version, fire up the lab Rene provided us.

      Than do the following on MOE:

      [code]enable
      configure terminal
      interface serial0/0.12 point-to-point
      ip address 192.168.12.1 255.255.255.0
      frame-relay interface-dlci 102
      interface serial0/0.13 point-to-point
      ip address 192.168.13.1 255.255.255.0
      frame-relay interface-dlci 103[/code]

      on router LARRY:
      [code]enable
      show ip interface brief[/code] (this command shows you that serial 0/0 is allready configured with the right IP address)
      [code]show frame-relay map[/code] (this command shows you have no working mapping towards MOE, so you’ll have to create one)
      [code]configure terminal
      interface serial0/0
      frame-relay map ip 192.168.13.1 301 broadcast
      end[/code]

      on router CURLY you do the following:
      [code]enable[/code]
      [code]show ip interface brief [/code](this command shows you that serial 0/0 is allready configured with the right IP address)
      [code]show frame-relay map[/code] (this command shows you have no working mapping towards MOE, so you’ll have to create one)
      [code]configure terminal
      interface serial0/0
      frame-relay map ip 192.168.13.1 201 broadcast
      end[/code]

      then after this you have todo the following on ALL routers to enable eigrp with AS 123:

      [code]conf t
      router eigrp 123
      no auto-summary
      network 0.0.0.0[/code]

      ——————————————————

      This should make you able to ping the loopback interface from curly from the loopback interface of larry. To make sure you are able goto larry and do the following:
      [code]Larry#ping 2.2.2.2 source loopback 0[/code]
      form curly:
      [code]Curly#ping 3.3.3.3 source loopback 0[/code]

      Which will result in:
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
      Packet sent with a source address of 2.2.2.2
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 24/42/64 ms

      It might have confused you that the lab assignment said; “[b]You are not allowed to make any changes to the frame-relay configurations.[/b]”

      Correct me if i’m wrong but adding a frame-relay map is changing frame-relay settings…

      1. Thanks for this. it was a HUGE help

        as for changing frame relay settings, Rene admits on this page somewhere that he meant changing the Frame Relay Switch itself

  12. I am having problems setting up the neighbor adjacencies.
    Pings from MOE work and everything seems to be correct but still no eigrp.

    configs :-

    MOE :

    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    no frame-relay inverse-arp
    !
    interface Serial0/0.2 point-to-point
    ip address 192.168.12.1 255.255.255.0
    frame-relay interface-dlci 102
    !
    interface Serial0/0.3 point-to-point
    ip address 192.168.13.1 255.255.255.0
    frame-relay interface-dlci 103
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 123
    network 1.1.1.1 0.0.0.0
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Moe#sh frame map
    Serial0/0.3 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
    status defined, active
    Serial0/0.2 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
    status defined, active

    CURLY :

    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.12.2 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.12.1 201
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 123
    network 2.2.2.2 0.0.0.0
    no auto-summary
    !

    Curly#sh frame map
    Serial0/0 (up): ip 192.168.12.1 dlci 201(0xC9,0x3090), static,
    CISCO, status defined, active

    LARRY :

    !
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.13.3 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.13.1 301
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 123
    network 3.3.3.3 0.0.0.0
    no auto-summary
    !

    Larry#sh frame map
    Serial0/0 (up): ip 192.168.13.1 dlci 301(0x12D,0x48D0), static,
    CISCO, status defined, active

    I did debug on MOE and this is what i got ….

    Moe#debug eigrp packets
    EIGRP Packets debugging is on
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
    Moe#
    *Mar 1 00:12:48.415: EIGRP: Received UPDATE on Serial0/0.2 nbr 192.168.12.2
    *Mar 1 00:12:48.419: AS 123, Flags 0x1, Seq 3/0 idbQ 0/0
    *Mar 1 00:12:48.419: EIGRP: Neighbor(192.168.12.2) not yet found
    Moe#
    *Mar 1 00:12:49.699: EIGRP: Sending HELLO on Serial0/0.3
    *Mar 1 00:12:49.703: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 00:12:50.611: EIGRP: Sending HELLO on Loopback0
    *Mar 1 00:12:50.615: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 00:12:50.623: EIGRP: Received HELLO on Loopback0 nbr 1.1.1.1
    *Mar 1 00:12:50.623: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 00:12:50.627: EIGRP: Packet from ourselves ignored
    *Mar 1 00:12:50.683: EIGRP: Sending HELLO on Serial0/0.2
    *Mar 1 00:12:50.683: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    Moe#
    *Mar 1 00:12:53.403: EIGRP: Received UPDATE on Serial0/0.2 nbr 192.168.12.2
    *Mar 1 00:12:53.407: AS 123, Flags 0x1, Seq 3/0 idbQ 0/0
    *Mar 1 00:12:53.407: EIGRP: Neighbor(192.168.12.2) not yet found
    Moe#
    *Mar 1 00:12:54.519: EIGRP: Sending HELLO on Serial0/0.3
    *Mar 1 00:12:54.523: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 00:12:54.611: EIGRP: Received UPDATE on Serial0/0.3 nbr 192.168.13.3
    *Mar 1 00:12:54.615: AS 123, Flags 0x1, Seq 3/0 idbQ 0/0
    *Mar 1 00:12:54.615: EIGRP: Neighbor(192.168.13.3) not yet found
    *Mar 1 00:12:54.899: EIGRP: Sending HELLO on Loopback0
    *Mar 1 00:12:54.903: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 00:12:54.903: EIGRP: Received HELLO on Loopback0 nbr 1.1.1.1
    *Mar 1 00:12:54.903: AS 123, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 00:12:54.903: EIGRP: Packet from ourselves ignored

    And on CURLY and LARRY this is what happened :

    *Mar 1 00:12:02.971: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is down: retry limit exceeded
    Curly#
    *Mar 1 00:12:05.399: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is up: new adjacency
    Curly#
    *Mar 1 00:13:24.927: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is down: retry limit exceeded
    Curly#
    *Mar 1 00:13:29.519: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is up: new adjacency
    Curly#
    *Mar 1 00:14:49.047: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is down: retry limit exceeded
    Curly#
    *Mar 1 00:14:52.943: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is up: new adjacency
    *Mar 1 00:15:36.359: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.12.1 (Serial0/0) is down: holding time expired

    Same happened on Larry as well.

    Can you help me as i am not able to find the problem ????

  13. Solved it.
    Had to use the neighbor command on all routers. Achieved full connectivity.

    ๐Ÿ˜€ ๐Ÿ˜€ ๐Ÿ™‚

    1. Magic….you never needed the neighbor command….you could have just advertised the networks in eigrp and it would have given you full connectivity.

  14. does frame relay switch need to be configured for hub and spoke communication over frame relay??

  15. The only issue I see with the "frame map ip" solution of this lab is that one of the requirements are:
    "You are not allowed to make any changes to the frame-relay configurations."

    1. I noticed that as well. However, without the mappings it simply will not work. Perhaps Rene was referencing not changing the Frame Relay Switch DLCI configuration by adding another PVC?

  16. Curly#ping 1.1.1.1 source loopback 0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
    Packet sent with a source address of 2.2.2.2
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/50/84 ms
    Curly#ping 3.3.3.3 source loopback 0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
    Packet sent with a source address of 2.2.2.2
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/69/116 ms

  17. My lab was n’t full Connectivity ( no routing table had exchange)
    until I used to make subinterface on router Curly , larry
    Is that is normal !?

    thanks in advance

  18. This is what worked for me:

    [b]Moe#[/b]
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    no frame-relay inverse-arp
    !
    interface Serial0/0.12 point-to-point
    ip address 192.168.12.1 255.255.255.0
    frame-relay interface-dlci 102
    !
    interface Serial0/0.13 point-to-point
    ip address 192.168.13.1 255.255.255.0
    frame-relay interface-dlci 103
    !
    router eigrp 123
    network 0.0.0.0
    no auto-summary

    [b]Larry#[/b]
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.13.3 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    no frame-relay inverse-arp
    !
    interface Serial0/0.31 point-to-point
    ip address 192.168.13.2 255.255.255.0
    frame-relay interface-dlci 301
    !
    interface Serial0/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    router eigrp 123
    network 0.0.0.0
    auto-summary
    !

    [b]Curly#[/b]
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.12.2 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    no dce-terminal-timing-enable
    no frame-relay inverse-arp
    !
    interface Serial0/0.21 point-to-point
    ip address 192.168.12.2 255.255.255.0
    frame-relay interface-dlci 201
    !
    router eigrp 123
    network 0.0.0.0
    auto-summary

    Curly#ping 3.3.3.3 source 2.2.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
    Packet sent with a source address of 2.2.2.2
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms

    Larry#ping 2.2.2.2 source 3.3.3.3

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    Packet sent with a source address of 3.3.3.3
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms

  19. Just as a comment as well. It is best practice to create sub-interface/s, this allows for future expansion. Although a bit more config, but generally rule of thumb.. Just a side note….

  20. Hi Rene,
    When I’m trying to open the lab I’m receiving following error “cx_Freeze: Python error in main script “. Please let me know if you have any solution or advise to solve this up.

    best regards.

    1. Hi Stelian,

      Good question…I just tried to run it here in GNS3 1.1 and for me it’s working. I did see a lot of others who ran into this issue with GNS3 1.X though, maybe better to check GNS3.com to see how to solve it. If I find out, I’ll let you know.

      Rene

  21. How are you doing Renรฉ ?

    Look my friend, what is the difference when we configure the “no ip split-horizon eigrp ” directly in the physical interface and when we configure on subinterfaces ? Both of them configuration results the same solution ? Thanks …

    1. Hello Onildo ,,, i read in the book that physical interfaces which by default are multicast in behavior have split horizon disabled by default so no need to configure no ip split-horizon eigrp
      command but when i tried it on GNS3 i had to use no ip split-horizon eigrp on physical interface on clarify ?

      1. Split horizon is disabled on those interfaces by default for RIP only, I believe. You still have to do it manually for EIGRP.

        1. Nicolas I did not have to disable eigrp split horizon on the physical interface on Moe. I wonder why could you pls explain. I could pin all router.

          Cheers

          Refai

  22. Hello Rene,

    Reading your book master your ccnp route and really loving it….you nailed it in simple and precise words..Thanks

Comments are closed.