EIGRP Link Bundle


Scenario:

At your job, you’ve recently installed a new serial link to a neighboring site to perform equal-cost load balancing with EIGRP. However, your boss refuses to issue you another IP network for this link, and he forbids you to variably subnet the existing network. Can you make it work?

Goal:

  • Nothing has been preconfigured for you!
  • Make the proper physical connections as outlined in the diagram.
  • Configure 1.1.1.1/32 as a loopback on R1.
  • Configure 2.2.2.2/32 as a loopback on R2.
  • Using only the 192.168.12.0/24, assign an IP address to all (4) serial interfaces in use, establish an EIGRP neighborship on each link, and ensure traffic is load balanced between router loopback addresses. These tasks can be performed in any order.

IOS:

c3725-adventerprisek9-mz.124-7.image

Topology:

eigrp bundle

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

You May Also Like

About the Author: Nicholas Russo

54 Comments

    1. any one can tell us why there arent any error msg , note if you make configuration step by step you will find the error is appeared but after i configure the eigrp is working fine and the

      1.0.0.0/32 is subnetted, 1 subnets
      D 1.1.1.1 [90/2297856] via 192.168.12.3, 00:03:52, Serial0/1
      [90/2297856] via 192.168.12.1, 00:03:52, Serial0/0

      how is working ????????!!!

  1. Can someone explain why this is working, and not getting an overlap error when assigning 192.168.12.1/24 and 192.168.12.2/24 on the same router to 2 serial interfaces?

  2. You will need to bind the interfaces together using ppp multilink. Then, you will be able to assign the multilink interface the IP address.

  3. why the attached file which contain the topology on gns3 didn’t open although i have the ios to open this file
    the following message appears each time i am trying to open the file :
    ios can not be found for this hypervisor 170.0.0.1:7200
    so where is the problem

  4. [size=large][b]you should give one interface serial 0/0 an IP Address in the subnet 192.168.12.0/24 and make the other interface in the same router inherit the first interface ip through the command –(ip unnumbered serial 0/0) and make the same on the other router

    then make EIGRP and advertise the networks [/b][/size]

    1. You all have good ideas, but this is NOT a multilink problem, nor it is an unnumbered problem.

      The key is in the “order of operations”. Try configuring something else first … before you configure interface IP addresses.

      Each interface must have a different IP address. For example 12.1, 12.2, 12.3, and 12.4.

      That rules out IP unnumbered and MLPPP.

  5. I did this lab and used ppp multilink. To put two addresses from the same subnet on two different interfaces on the same router goes against everything I have learned thus far. Can anyone please explain how both serial interfaces can be assigned different addresses from the same subnet? Wow… just did it again:

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, Serial1/0
    is directly connected, Serial1/1

    Cisco never ceases to amaze…

  6. Solution to above Lab:
    =================
    on R1

    en
    conf t
    !
    int loopback 0
    ip address 1.1.1.1 255.255.255.255
    !
    ! create a virtual template and assign it an ip address that is to be assigned on s0/0 & s0/1

    int virtual-template 1
    ip address 192.168.12.1 255.255.255.0
    !
    int s0/0
    ip unnumbered virtual-template 1
    no shutdown
    !
    int s0/1
    ip unnumbered virtual-template 1
    no shutdown
    !
    router eigrp 1
    no auto-summary
    network 192.168.12.0
    network 1.1.1.1 0.0.0.0
    !
    ==================
    on R2

    en
    conf t
    !
    int loopback 0
    ip address 2.2.2.2 255.255.255.255
    !
    ! create a virtual template and assign it an ip address that is to be assigned on s0/0 & s0/1

    int virtual-template 1
    ip address 192.168.12.2 255.255.255.0
    !
    int s0/0
    ip unnumbered virtual-template 1
    no shutdown
    !
    int s0/1
    ip unnumbered virtual-template 1
    no shutdown
    !
    router eigrp 1
    no auto-summary
    network 192.168.12.0
    network 2.2.2.2 0.0.0.0
    !
    =====
    ! verify on both router R1 & R2 – for remote side loopback we have two path via s0/0 and s0/1

    show ip route

    Hope Nick this provides win-win solution to network admin & satisfy the boss.

  7. There is nothing in the final config? I guess I need to create the topology manually?

    1. i try to configure with gns3.
      it work fine with overlap ip address on serial link also.
      but i wonder is it applied on serial link only?

  8. I think its a starightforward config.Serial connection is point to point and will be accepted,If you try this with ethernet there will be an overlap.

    1. This guy has it right. From the Cisco IP routing Q&A:

      Q. Is it possible to have duplicate ip addresses for two serial interfaces that belong to the same router?

      A. Yes, duplicate ip addresses are allowed on serial interfaces. It is a more efficient way of bundling links together (ie. MLPPP) and also a better way to preserve address space. Change the encapsulation from the default HDLC to PPP in order to assign duplicate ip addresses.

      source: [url=]http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012d8f7.shtml#qa15a[/url]

      So in other words, Cisco allows different serial interfaces on a router to be configured in the same subnet.

      That’s the solution to the IP addressing problem. I’m not as clear on how to fulfill the load balancing requirement. I assumed that the IOS would automatically load balance across the two serial interfaces, but Wireshark captures don’t bear that out. When I source pings from the loopback interface, it always uses the same serial interface to forward the pings to the other router.

      [EDIT]
      Ok, I think I got it. After reading up on this a bit, I found out that when Cisco Express Forwarding is enabled (the default on recent IOS versions), load balancing is done on a per-destination rather than a per-packet basis. Process switching load balances on a per-packet basis, which is what this lab calls for.

      Sure enough, I issued the command “no ip cef” and my Wireshark captures showed that both links were being utilized when I did some test pings.

      That said, I don’t feel really comfortable tinkering with low-level algorithms, so if someone can do this without turning off CEF I’d love to know.

      [EDIT AGAIN]
      To answer my own question, I did more research and found out that you can still use CEF and do per-packet load balancing if you issue the command “ip load-sharing per-packet” on all the serial interfaces.

      In case anyone is wondering, these were my sources about CEF and load balancing:

      [url=]http://www.cisco.com/en/US/products/hw/modules/ps2033/prod_technical_reference09186a00800afeb7.html[/url]

      [url=]http://www.cisco.com/en/US/tech/tk827/tk831/technologies_tech_note09186a0080094806.shtml[/url]

      Wow, this lab took me on quite an unexpected ride.

  9. Proceed with simple steps.

    create the topology
    connect the two routers with serial interfaces as given
    give ip addresses as you want. but within the network mentioned.
    create loopbacks on each router.

    and traceroute from a source of one router to the second one will prove that it is already loadbalanced, since there FD are the same.
    for example on router 1

    traceroute 2.2.2.2 source 1.1.1.1

  10. The Config in this lab are incorrect assuming you want to ping the Loop back from each router.

    This does not work:
    router eigrp 1
    passive-interface Loopback0
    network 192.168.12.0
    no auto-summary
    you will not get an eigrp route

    This does work:
    router eigrp 1
    passive-interface Loopback0
    network 1.0.0.0
    network 192.168.12.0
    no auto-summary

    However this is very bad form and a multilink bundle should be created like this
    R1
    interface Multilink1
    Ip address 192.168.12.1
    ppp multilink
    ppp multilink group 1
    no shut

    interface Serial0/0
    bandwidth 1536
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1
    no shut

    interface Serial0/1
    bandwidth 1536
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1
    no shut

  11. the question asks to make sure each interface has an ip address. I take this to mean each interface needs its own ip address. This rules out multilink, unnumbered etc, etc.
    Just use per packet load sharing. To test, clear counters and send an extended ping. Then go and check the counters for each interface. There will never be an exact 50/50 split but as logn as you are within a few packets you will know it is working.

    1. All,

      The solution is to configure the EIGRP network statement BEFORE configuring the IP addresses. I realize now that the final configs still put the routing processes after the interfaces, so no one could see the sequence. As I said above, the trick was in the order of operations. This is a very obscure feature, and I don’t think it even works across a reload. Have never deployed it in production.

      router eigr p1
      no auto
      net 192.168.12.0

      int s0/1
      no sh
      ip add 192.168.12.4 255.255.255.0
      int s0/0
      no sh
      ip add 192.168.12.2 255.255.255.0

      R2#sh ip eig ne
      IP-EIGRP neighbors for process 1
      H Address Interface Hold Uptime SRTT RTO Q Seq
      (sec) (ms) Cnt Num
      1 192.168.12.3 Se0/1 12 00:00:16 15 200 0 6
      0 192.168.12.1 Se0/0 11 00:00:16 25 200 0 3
      R2#sh ip ro co
      C 192.168.12.0/24 is directly connected, Serial0/1
      is directly connected, Serial0/0

      1. Brilliantly done Nicholas Russo.
        I guess when Rene mentioned in the question “These tasks can be performed in any order”, that was quite intuitive.

        1. Brilliantly done Nicholas Russo.
          I guess when Rene mentioned in the question “These tasks can be performed in any order”, that could have killed it.

          1. Hi Nicholas,

            I tried simulating your solution on GNS3 but the loopbacks are not pingable from either routers.The transit interfaces are pingable from both the routers.
            Here is my config.

            R1#sh run
            Building configuration…

            Current configuration : 1224 bytes
            !
            version 12.4
            service timestamps debug datetime msec
            service timestamps log datetime msec
            no service password-encryption
            !
            hostname R1
            !
            boot-start-marker
            boot-end-marker
            !
            !
            no aaa new-model
            memory-size iomem 5
            no ip icmp rate-limit unreachable
            ip cef
            ip tcp synwait-time 5
            !
            !
            !
            !
            no ip domain lookup
            !
            multilink bundle-name authenticated
            !
            !
            !
            !
            !
            !
            !
            !
            !
            !
            !
            interface Loopback0
            ip address 1.1.1.1 255.255.255.255
            !
            interface FastEthernet0/0
            no ip address
            shutdown
            duplex auto
            speed auto
            !
            interface FastEthernet0/1
            no ip address
            shutdown
            duplex auto
            speed auto
            !
            interface Serial1/0
            ip address 192.168.12.1 255.255.255.0
            serial restart-delay 0
            !
            interface Serial1/1
            ip address 192.168.12.3 255.255.255.0
            serial restart-delay 0
            !
            interface Serial1/2
            no ip address
            shutdown
            serial restart-delay 0
            !
            interface Serial1/3
            no ip address
            shutdown
            serial restart-delay 0
            !
            router eigrp 100
            network 192.168.12.0
            no auto-summary
            !
            !
            !
            no ip http server
            no ip http secure-server
            !
            no cdp log mismatch duplex
            !
            !
            !
            !
            !
            control-plane
            !
            !
            !
            line con 0
            exec-timeout 0 0
            privilege level 15
            logging synchronous
            line aux 0
            exec-timeout 0 0
            privilege level 15
            logging synchronous
            line vty 0 4
            login
            !
            !
            end

            R2#sh run
            Building configuration…

            Current configuration : 1224 bytes
            !
            version 12.4
            service timestamps debug datetime msec
            service timestamps log datetime msec
            no service password-encryption
            !
            hostname R2
            !
            boot-start-marker
            boot-end-marker
            !
            !
            no aaa new-model
            memory-size iomem 5
            no ip icmp rate-limit unreachable
            ip cef
            ip tcp synwait-time 5
            !
            !
            !
            !
            no ip domain lookup
            !
            multilink bundle-name authenticated
            !
            !
            !
            !
            !
            !
            !
            !
            !
            !
            !
            interface Loopback0
            ip address 2.2.2.2 255.255.255.255
            !
            interface FastEthernet0/0
            no ip address
            shutdown
            duplex auto
            speed auto
            !
            interface FastEthernet0/1
            no ip address
            shutdown
            duplex auto
            speed auto
            !
            interface Serial1/0
            ip address 192.168.12.2 255.255.255.0
            serial restart-delay 0
            !
            interface Serial1/1
            ip address 192.168.12.4 255.255.255.0
            serial restart-delay 0
            !
            interface Serial1/2
            no ip address
            shutdown
            serial restart-delay 0
            !
            interface Serial1/3
            no ip address
            shutdown
            serial restart-delay 0
            !
            router eigrp 100
            network 192.168.12.0
            no auto-summary
            !
            !
            !
            no ip http server
            no ip http secure-server
            !
            no cdp log mismatch duplex
            !
            !
            !
            !
            !
            control-plane
            !
            !
            !
            line con 0
            exec-timeout 0 0
            privilege level 15
            logging synchronous
            line aux 0
            exec-timeout 0 0
            privilege level 15
            logging synchronous
            line vty 0 4
            login
            !
            !
            end

            R1#sh ip eigrp n
            IP-EIGRP neighbors for process 100
            H Address Interface Hold Uptime SRTT RTO Q Seq
            (sec) (ms) Cnt Num
            1 192.168.12.2 Se1/0 12 00:23:23 125 750 0 6
            0 192.168.12.4 Se1/1 10 00:23:28 93 558 0 3

            R1#sh ip route
            Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
            D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
            N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
            E1 – OSPF external type 1, E2 – OSPF external type 2
            i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
            ia – IS-IS inter area, * – candidate default, U – per-user static route
            o – ODR, P – periodic downloaded static route

            Gateway of last resort is not set

            C 192.168.12.0/24 is directly connected, Serial1/1
            is directly connected, Serial1/0
            1.0.0.0/32 is subnetted, 1 subnets
            C 1.1.1.1 is directly connected, Loopback0

            R2#sh ip eigrp n
            IP-EIGRP neighbors for process 100
            H Address Interface Hold Uptime SRTT RTO Q Seq
            (sec) (ms) Cnt Num
            1 192.168.12.1 Se1/0 11 00:24:29 118 708 0 6
            0 192.168.12.3 Se1/1 14 00:24:35 89 534 0 3

            R2#sh ip ro
            Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
            D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
            N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
            E1 – OSPF external type 1, E2 – OSPF external type 2
            i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
            ia – IS-IS inter area, * – candidate default, U – per-user static route
            o – ODR, P – periodic downloaded static route

            Gateway of last resort is not set

            C 192.168.12.0/24 is directly connected, Serial1/0
            is directly connected, Serial1/1
            2.0.0.0/32 is subnetted, 1 subnets
            C 2.2.2.2 is directly connected, Loopback0

            R1#ping 2.2.2.2

            Type escape sequence to abort.
            Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
            …..
            Success rate is 0 percent (0/5)

            Plz let me know the issue or if need any outputs.

            1. Sorry for my earlier post.I failed to enable eigrp on my loopbacks. Now both are reachable.

  12. what is the effect of making loop back interface passive?……………….how loop back helps to bundle links?

  13. In EIGRP, by making an interface passive you are suppressing hello packets from being sent to that interface. In addition, it also suppresses routing updates from being sent out that interface.

  14. passive-interface command will stop outgoing and incoming routing updates of loop back interface!!!! just clear that what is the role of loop back in this lab to create link bundling?

  15. I might have done the subnetting wrong, but saw the lab as a load balance lab across serial interfaces and not a multilink. I had to change the CEF load balance method on the interfaces. My config is as:

    R2#sho run
    Building configuration…

    Current configuration : 1263 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 20000 debugging
    logging console notifications
    !
    no aaa new-model
    memory-size iomem 5
    no ip icmp rate-limit unreachable
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip tcp synwait-time 5
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Serial1/0
    ip address 192.168.12.2 255.255.255.252
    ip load-sharing per-packet
    serial restart-delay 0
    !
    interface Serial1/1
    ip address 192.168.12.6 255.255.255.252
    ip load-sharing per-packet
    serial restart-delay 0
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 100
    network 2.0.0.0
    network 192.168.12.0
    maximum-paths 2
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    access-list 100 deny eigrp any any
    access-list 100 permit ip any any
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    !
    !
    end

    1. This is not correct. The idea is to have both links show as connected routes. I believe I answered this in some earlier comments, do you see it?

  16. !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Multilink1
    ip address 192.168.12.1 255.255.255.0
    ppp multilink
    ppp multilink interleave
    ppp multilink group 1
    ppp multilink multiclass
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    !
    interface Serial1/0
    no ip address
    encapsulation ppp
    serial restart-delay 0
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial1/1
    no ip address
    encapsulation ppp
    serial restart-delay 0
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/4
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/5
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/6
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/7
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    network 1.1.1.1
    network 192.168.12.0
    no auto-summary
    !

    1. This is not the correct solution, scroll up in the comment chain and you will see it. The key is in the order of operations.

  17. ANSWER:
    on R1

    interface Serial0/0
    ip address 192.168.12.1 255.255.255.0
    ip load-sharing per-packet
    !
    interface Serial0/1
    ip address 192.168.12.3 255.255.255.0
    ip load-sharing per-packet

    router eigrp 1
    network 0.0.0.0
    no auto-summary

    on R2

    interface Serial0/0
    ip address 192.168.12.2 255.255.255.0
    ip load-sharing per-packet
    !
    interface Serial0/1
    ip address 192.168.12.4 255.255.255.0
    ip load-sharing per-packet

    router eigrp 1
    network 0.0.0.0
    no auto-summary

    Note: either use: R2(config-if)#ip load-sharing per-packet or R2(config)#no ip cef

      1. @Nicholas : Your answer is correct but then packet will be load balanced per destination based.

        We need R2(config-if)#ip load-sharing per-packet or R2(config)#no ip cef but load balancing per packet based.

        1. OK, that is true. I wasn’t really aiming for that as an objective but if you read the instructions literally, you are correct.

  18. My Configuration –

    R1 :

    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
    ip address 1.1.1.1 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.12.1 255.255.255.252
    clock rate 2000000
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip address 192.168.12.5 255.255.255.252
    clock rate 2000000
    !
    router eigrp 90
    network 1.1.1.1 0.0.0.0
    network 192.168.12.1 0.0.0.0
    network 192.168.12.5 0.0.0.0
    auto-summary
    !
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end

    R2

    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback1
    ip address 2.2.2.2 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.12.2 255.255.255.252
    clock rate 2000000
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip address 192.168.12.6 255.255.255.252
    clock rate 2000000
    !
    router eigrp 90
    network 2.2.2.2 0.0.0.0
    network 192.168.12.2 0.0.0.0
    network 192.168.12.6 0.0.0.0
    auto-summary
    !
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end

    ———————————————————————–

    RESULTS:

    R1 – Routing table:

    192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
    C 192.168.12.4/30 is directly connected, Serial0/1
    C 192.168.12.0/30 is directly connected, Serial0/0
    D 192.168.12.0/24 is a summary, 00:12:02, Null0
    1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 1.1.1.1/32 is directly connected, Loopback1
    D 1.0.0.0/8 is a summary, 00:12:02, Null0
    D 2.0.0.0/8 [90/2297856] via 192.168.12.6, 00:11:49, Serial0/1
    [90/2297856] via 192.168.12.2, 00:11:49, Serial0/0

    R2 Routing table :

    192.168.12.0/24 is variably subnetted, 3 subnets, 2 masks
    C 192.168.12.4/30 is directly connected, Serial0/1
    C 192.168.12.0/30 is directly connected, Serial0/0
    D 192.168.12.0/24 is a summary, 00:12:19, Null0
    D 1.0.0.0/8 [90/2297856] via 192.168.12.5, 00:12:31, Serial0/1
    [90/2297856] via 192.168.12.1, 00:12:31, Serial0/0
    2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 2.2.2.2/32 is directly connected, Loopback1
    D 2.0.0.0/8 is a summary, 00:12:20, Null0

    ————————————————————————————————-

    Pls comment

  19. My Configuration :

    R1 :

    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip cef

    interface Loopback1
    ip address 1.1.1.1 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.12.1 255.255.255.252
    clock rate 2000000
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip address 192.168.12.5 255.255.255.252
    clock rate 2000000
    !
    router eigrp 90
    network 1.1.1.1 0.0.0.0
    network 192.168.12.1 0.0.0.0
    network 192.168.12.5 0.0.0.0
    no auto-summary
    !
    !
    !
    no ip http server
    no ip http secure-server

    control-plane

    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end

    ————————————————————————-

    R2 :

    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    ip cef
    !
    !
    !
    !
    no ip domain lookup

    !
    !
    interface Loopback1
    ip address 2.2.2.2 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.12.2 255.255.255.252
    clock rate 2000000
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip address 192.168.12.6 255.255.255.252
    clock rate 2000000
    !
    router eigrp 90
    network 2.2.2.2 0.0.0.0
    network 192.168.12.2 0.0.0.0
    network 192.168.12.6 0.0.0.0
    no auto-summary
    !
    !
    !
    no ip http server
    no ip http secure-server
    !

    !
    control-plane

    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    !
    !
    end

    ———————————————————————–

    OUTPUT :

    R1 routing table:

    192.168.12.0/30 is subnetted, 2 subnets
    C 192.168.12.4 is directly connected, Serial0/1
    C 192.168.12.0 is directly connected, Serial0/0
    1.0.0.0/32 is subnetted, 1 subnets
    C 1.1.1.1 is directly connected, Loopback1
    2.0.0.0/32 is subnetted, 1 subnets
    D 2.2.2.2 [90/2297856] via 192.168.12.6, 00:00:42, Serial0/1
    [90/2297856] via 192.168.12.2, 00:00:42, Serial0/0

    ————————————————————————–

    R2 routing table:

    192.168.12.0/30 is subnetted, 2 subnets
    C 192.168.12.4 is directly connected, Serial0/1
    C 192.168.12.0 is directly connected, Serial0/0
    1.0.0.0/32 is subnetted, 1 subnets
    D 1.1.1.1 [90/2297856] via 192.168.12.5, 00:00:13, Serial0/1
    [90/2297856] via 192.168.12.1, 00:00:13, Serial0/0
    2.0.0.0/32 is subnetted, 1 subnets
    C 2.2.2.2 is directly connected, Loopback1

    ———————————————————————–

    Pls comment 🙂

  20. Hello, I just simply did that. It is working properly.

    r1#Show ip ro

    C 192.168.12.0/24 is directly connected, Serial0/0
    is directly connected, Serial0/1
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    2.0.0.0/32 is subnetted, 1 subnets
    D 2.2.2.2 [90/2297856] via 192.168.12.4, 00:36:25, Serial0/1
    [90/2297856] via 192.168.12.3, 00:36:25, Serial0/0
    D 192.168.1.0/24 [90/2681856] via 192.168.12.4, 00:35:26, Serial0/1
    —————————————————————————————–

  21. Hi Nick,

    Is this right ?

    R1# sh ip eigrp neigh
    IP-EIGRP neighbors for process 1
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    1 192.168.12.4 Se0/1 12 00:01:25 106 636 0 12
    0 192.168.12.3 Se0/0 11 00:01:36 111 666 0 11
    R1#

    D 2.2.2.2 [90/2297856] via 192.168.12.4, 00:01:47, Serial0/1
    [90/2297856] via 192.168.12.3, 00:01:47, Serial0/0
    R1(config-router)#

  22. Now I have small query, not a query as such but more of a need of an analysis after the crime is solved.
    How we are able to put the ip addresses of the same subnet on different ports of the network?
    Does EIGRP does not detect the same?
    And what did it mean by “Order of Operations issue” needed to solve this lab.

    Could someone please clarify.

    1. I really don’t have a great answer, but you must configure the EIGRP network statement before configuring the IP addresses.

  23. Works perfectly for me.

    R1#sh ip eigrp topology
    EIGRP-IPv4 Topology Table for AS(100)/ID(1.1.1.1)
    Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
    r – reply Status, s – sia Status

    P 192.168.12.0/24, 1 successors, FD is 2169856
    via Connected, Serial1/0
    via Connected, Serial1/1
    P 2.2.2.2/32, 2 successors, FD is 2297856
    via 192.168.12.2 (2297856/128256), Serial1/1
    via 192.168.12.22 (2297856/128256), Serial1/0
    P 1.1.1.1/32, 1 successors, FD is 128256
    via Connected, Loopback1

Comments are closed.