EIGRP Hybrid Bandwidth Pacing


Scenario:

A large international ISP has hired you as one of their network engineers. The ISP still has a fairly large customer that is using an older frame-relay network. All of your colleagues are too busy working with MPLS and you are the only one who is capable of fixing frame-relay problems.  The ISP wants you to look at the frame-relay network because there have been some congestion problems with EIGRP. It’s up to you to configure the most optimal settings!

Goal:

  • The frame-relay switch has been preconfigured for you.
  • Router Tilburg is the Hub router and all other routers are the spoke routers.
  • Router NewDelhi, Berlin and Paris each have a PVC with a CIR of 256kbps.
  • Router NewYork has a PVC with a CIR of 128kbps.
  • Every router has a loopback0 interface:
    Tilburg: 1.1.1.1 /24
    NewDelhi: 2.2.2.2 /24
    Berlin: 3.3.3.3 /24
    Paris: 4.4.4.4 /24
    NewYork: 5.5.5.5 /24
  • Configure frame-relay and EIGRP AS 1 on all routers with the most optimal settings for this network.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about EIGRP, running EIGRP over frame-relay and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

EIGRP Hybrid Bandwidth Pacing Network Topology

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by RenΓ© Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

RenΓ© - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

21 Comments

  1. Hi Rene,

    I’m actually going to take my CCNP ROUTE in a couple of weeks, and I remember seeing this type of question in a practice test. So, just want to check that my belief if correct..aside from setting the obvious CIR bandwidth on the spokes, the hub Bw should be set on the physical interface, and the value is 512 ?

    Great labs by the way, really Cisco exam style.

  2. Hello Bogdan,

    Thanks for your comment, glad you like the labs! πŸ˜€

    About EIGRP and frame-relay bandwidth…it depends on your setup:

    1. Point-to-point sub-interfaces
    2. Point-to-multipoint interfaces
    3. A hybrid solution (this lab) where you mix point-to-point and point-to-multipoint.

    I would highly suggest taking a look at this Cisco article that describes all methods:

    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094063.shtml

    Let me know if that helps you ok?

    Rene

  3. Would it be possible to to come up with a video solution? I understand that we are using both point to multi-point and point to point configuration since we have a spoke with a different speed, however router Tillburg I assume has a dedicated T1. so what do we do with the left over bandwidth?

    1. Hoi Marco,

      Als het een beetje meezit neem ik ze deze week op πŸ™‚

      Groeten Rene

  4. [b]Enable EIGRP on all routers:[/b]
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary
    !
    [b]Tilburg[/b]
    interface Serial0/0
    ip address 192.168.1.1 255.255.255.0
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    frame-relay map ip 192.168.1.2 102 broadcast
    frame-relay map ip 192.168.1.3 103 broadcast
    frame-relay map ip 192.168.1.4 104 broadcast
    frame-relay map ip 192.168.1.5 105 broadcast
    !
    [b]Paris[/b]
    interface Serial0/0
    ip address 192.168.1.4 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.1.1 401 broadcast
    !

    [b]NewDelhi[/b]
    interface Serial0/0
    ip address 192.168.1.2 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.1.1 201 broadcast
    !
    etc….

    1. If we decide to go with point-to-multipoint, as I understand the bandwidth set on Tilburg will have to be 128*4 (where 128 is the lowest bandwidth).
      On each of the spoke routers we can set the correct bandwidth, given by the exercise, but we also have to limit the actual bandwidth used by eigrp. This value should be the same in both directions. The bandwidth used for eigrp on Tilburg is 128*0.50 = 64K ( 50% of bandwidth is used for eigrp, I always thought it was 75%, but never mind).
      So If we set the bandwidth on Paris to be 256, then in order to use 64K for eigrp we need to use the bandwidth-percent command set to 25 (64/256=25).

      Please correct me if I am wrong, because I always find these exercises confusing.

  5. Hi Rene,

    We could provide a hybrid solution for this lab by configuring a multipoint interface on Tilburg with a bw of 768k (256*3) for ND,Berlin and Paris, and a point to point interface with 128k for the NY pvc.
    The access line speed of Tilburg would be 896k (768+128).
    But in order to do that, wouldn’t we need two different subnets?
    Is this what you had in mind? πŸ™‚

    A second solution would be a pure multipoint configuration with a bw of 128*4=512k.

  6. Hey Rene,

    Could you pls confirm whether the below config is correct ?

    Solution :

    On all router
    =========
    router eigrp 1
    network 0.0.0.0
    no auto

    Tilburg
    =======

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.1 multipoint
    bandwidth 128
    ip address 192.168.1.1 255.255.255.0
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.1.2 102 broadcast
    frame-relay map ip 192.168.1.3 103 broadcast
    frame-relay map ip 192.168.1.4 104 broadcast
    no frame-relay inverse-arp
    !
    interface Serial0/0.2 point-to-point
    bandwidth 128
    ip address 192.168.2.1 255.255.255.0
    frame-relay interface-dlci 105

    NewDelhi
    ========

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.201 multipoint
    bandwidth 128
    ip address 192.168.1.2 255.255.255.0
    frame-relay map ip 192.168.1.1 201 broadcast
    no frame-relay inverse-arp

    Berlin
    =======

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.301 multipoint
    bandwidth 128
    ip address 192.168.1.3 255.255.255.0
    frame-relay map ip 192.168.1.1 301 broadcast
    no frame-relay inverse-arp

    Paris
    =====

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.401 multipoint
    bandwidth 128
    ip address 192.168.1.4 255.255.255.0
    frame-relay map ip 192.168.1.1 401 broadcast
    no frame-relay inverse-arp

    NewYork
    =======

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.501 point-to-point
    bandwidth 128
    ip address 192.168.2.2 255.255.255.0
    frame-relay interface-dlci 501

    [b]
    And many thanks for your effort, time and sharing your knowledge.
    [/b]

    Regards
    Druvakumar

  7. Hmm, my solution on this one largely agreed with Druvakumar’s above. I added a couple of extra bits for optimization’s sake, by skipping the [i]broadcast [/i]option on the [i]frame-relay map[/i] option, and instead hardwiring the neighborships in the[i] router eigrp[/i] config so that Tilburg unicasts to Paris Berlin and NewDelhi. For fun, I added [i]payload-compression[/i] to the maps on the Tilburg side, as well.

    Was unclear what BW could be on Tilburg, and therefore whether [i]bandwidth-percent[/i] would be useful. Apparantly not because of the existing congestion, except perhaps to reduce.

  8. hi rene
    my question is not about the configs but about the IOS that you are using. when i try to use c3640-jk9s-mz.124-16.bin in GNS3 i am unable to assign the Serial interfaces but how come you are able to configure the serial interfaces
    please let me know
    and i am loving these labs specially EIGRP with stupid frame relay
    thanks

  9. Rene,

    No resolution video for this? πŸ™‚

    Anyway, per the documentation, the bw on the subinterface of the hub needs to be set to 512 (128*4). At its default 50% utilization per VC, split 4 ways, EIGRP will use 64k on each of them.

    If setting the bandwidth to 256 at the remote spokes with the 256k PVCs, you’ll want to issue ip bandwidth-percent eigrp 1 25 (25% of 256k is 64k.) so you aren’t dropping EIGRP packets ingress to the hub in the event of a heavy convergence (not that there are many routes per site).

    However, it appears the best design would be to split NY into its own subinterface and control it differently that way.

  10. Hello everyone,

    Solution 1: Use in router HUB 768 K (minimum 128×4) of BW in interface S0/0.1, and regulate percent of traffic Eigrp in spoke routers to send just 64 K.

    Solution 2: Use in router HUB two interfaces, S0/0.1 for the 3 Routers wich CIR=256 y other interface S 0/0.2 for the router that has CIR=128.
    But in this case you have two subnets and not One subnet (192.168.1.0/24) that is in the figure of the Lab. So the solution one is the correct.

    Thanks for the lab Rene.

  11. interface Loopback0
    ip address 1.1.1.1 255.255.255.0

    interface Serial0/0
    no ip address
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0

    interface Serial0/0.1 multipoint
    ip address 192.168.1.1 255.255.255.0
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.1.2 102 broadcast
    frame-relay map ip 192.168.1.3 103 broadcast
    frame-relay map ip 192.168.1.4 104 broadcast
    !
    interface Serial0/0.5 point-to-point
    bandwidth 128
    ip address 192.168.1.1 255.255.255.0
    frame-relay interface-dlci 105

    router eigrp 1
    network 1.1.1.0 0.0.0.255
    network 192.168.1.0
    no auto-summary

    Mine works without creating another subnet. i use 192.168.1.1 both in point to point and multipoint connection.

  12. Hi Rene,

    I’m studying for CCNP Route and I’m using your book now. According to some examples in the book, I should solve this with a multipoint on routers that share the same CIR and a point-to-point between Tilburg and NewYork using a different subnet.

    But I’m a bit confused when I read the configuration notes from Cisco. In the last example on:

    http://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13672-12.html

    cisco uses a subtraction on the multipoint if. I don’t understand why cisco is doing this. They are talking about access lines, I guess what they mean is the maximum speed on these lines, but this is not the same as the CIR in your example am I correct?

    QUOTE Cisco:
    “Three of the four routers (routers A through C) have 256Kbps access lines, but one (router D) has only a 56Kbps access line.
    Another way, which would require less configuration, is to break up the network by putting routers A through C on a fully meshed multipoint subinterface, and use a point-to-point subinterface for connecting to router D, and making all of router D’s connections point-to-point subinterfaces instead, as shown in Figure 3.

    Router A-C
    interface Serial 0
    encapsulation frame-relay

    !— To enable Frame Relay encapsulation on this interface.

    interface Serial 0.1 multipoint

    !— The subinterface is configured to function as a point-to-point link
    using this command.

    bandwidth 238

    !— To set the bandwidth value for this interface.

    interface Serial 0.2 point-to-point
    bandwidth 18
    description PVC to Router D
    Router D’s configuration would look like the following.

    Router D
    interface Serial 0
    encapsulation frame-relay

    !— To enable Frame Relay encapsulation on this interface.

    interface Serial 0.1 point-to-point
    bandwidth 18

    !— To set the bandwidth value for this interface.

    description PVC to Router A
    interface Serial 0.2 point-to-point

    !— The subinterface is configured to function as a point-to-point link
    !— using this command.

    bandwidth 18
    description PVC to Router B

    interface Serial 0.3 point-to-point
    bandwidth 18
    description PVC to Router C
    Note that the multipoint subinterface is configured to 238 Kbps (256-18) and the point-to-point subinterfaces are configured to 18 Kbps (56/3).

  13. if BW s0/0 = 256 kbps, multipoint interface is configured to 192 kbps (256-64) and the point-to-point subinterface are configured to 64 kbps

    Tilbugr(BW=192/3=64 kbps, EIGRP bw=32 kbps) NewDelhi(BW=256 kbps, EIGRP percentage bw=(32/256)*100%=12%, EIGRP bw=256*0.12=30 kbps)
    Tilbugr(BW=192/3=64 kbps, EIGRP bw=32 kbps) Berlin (BW=256 kbps, EIGRP percentage bw=(32/256)*100%=12%, EIGRP bw=256*0.12=30 kbps)
    Tilbugr(BW=192/3=64 kbps, EIGRP bw=32 kbps) Paris (BW=256 kbps, EIGRP percentage bw=(32/256)*100%=12%, EIGRP bw=256*0.12=30 kbps)
    Tilbugr(BW=64 kbps, EIGRP bw=32 kbps) NewYork (BW=128 kbps, EIGRP percentage bw=(32/128)*100%=25%, EIGRP bw=128*0.25=32 kbps)

    !— Router Tilburg

    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface Serial0/0
    bandwidth 192
    ip address 192.168.1.1 255.255.255.0
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    !
    interface Serial0/0.105 point-to-point
    bandwidth 64
    ip address 192.168.15.1 255.255.255.0
    frame-relay interface-dlci 105
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary

    !— Router NewDelhi

    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface Serial0/0
    bandwidth 256
    ip address 192.168.1.2 255.255.255.0
    ip bandwidth-percent eigrp 1 12
    encapsulation frame-relay
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary

    !— Router Berlin

    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    bandwidth 256
    ip address 192.168.1.3 255.255.255.0
    ip bandwidth-percent eigrp 1 12
    encapsulation frame-relay
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary

    !— Router Paris

    interface Loopback0
    ip address 4.4.4.4 255.255.255.0
    !
    interface Serial0/0
    bandwidth 256
    ip address 192.168.1.4 255.255.255.0
    ip bandwidth-percent eigrp 1 12
    encapsulation frame-relay
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary

    !— Router NewYork
    interface Loopback0
    ip address 5.5.5.5 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    !
    interface Serial0/0.501 point-to-point
    bandwidth 128
    ip address 192.168.15.5 255.255.255.0
    ip bandwidth-percent eigrp 1 25
    frame-relay interface-dlci 501
    !
    router eigrp 1
    network 0.0.0.0
    no auto-summary

  14. I had configured the following:

    HUB line CIR should be:
    4 spokes (using least spoke BW 128) = 4 x 128 = 512 K

    HUB:

    Router#show run int s0/0.12345
    Building configuration…

    Current configuration : 346 bytes
    !
    interface Serial0/0.12345 multipoint
    bandwidth 512000
    ip address 192.168.1.1 255.255.255.0
    ip bandwidth-percent eigrp 1 25 !!!!set eigrp bandwidth to 25% of the bandwidth shown above.
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.1.2 102 broadcast
    frame-relay map ip 192.168.1.3 103 broadcast
    frame-relay map ip 192.168.1.4 104 broadcast
    frame-relay map ip 192.168.1.5 105 broadcast
    end

    NEW YORK:

    Router#sh run int s0/1
    Building configuration…

    Current configuration : 134 bytes
    !
    interface Serial0/1
    bandwidth 128000
    ip address 192.168.1.5 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    end

    NEW DEHLI and similar settings on other spokes.

    interface Serial0/1
    bandwidth 256000
    ip address 192.168.1.2 255.255.255.0
    ip bandwidth-percent eigrp 1 25
    encapsulation frame-relay
    serial restart-delay 0
    end

Comments are closed.