Scenario:
For this lab you need REAL hardware. You can’t use switches in GNS3!
You need at least a Cisco Catalyst 3550 switch for this lab.
The network agency corporation has hired you as a spanning tree specialist. One of their customers has issues with a switched network that only has fiber connections. Every now and then there’s a problem with the fiber and as a result layer 2 loops occur. It will take two months for the fiber company to check all cables/connectors so you want a temporary solution…
Goal:
- Configure all IP addresses as specified in the topology picture.
- Configure SW1 so it builds a routing table.
- Configure SW1 so router DNS1 and DNS2 are in VLAN 10.
- Configure the fa0/3 interface on SW1 as a routed port.
- Ensure all routers are able to communicate with each other.
It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the switch protocols for CCNP.
Would you like to be a master of switching too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?
I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of switching.
You will learn all the secrets about switching, SVI interfaces, switchports VS layer 3 interfaces and more.
Does this sound interesting to you? Take a look here and let me show you how to Master CCNP SWITCH
IOS:
Basic IOS for the switches should be sufficient. No special features needed.
Topology:
Video Solution:
Configuration Files
You need to register to download the GNS3 topology file. (Registration is free!)Once you are logged in you will find the configuration files right here.
The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.
Written by René Molenaar - CCIE #41726
Hello Rene,
This video has duration of only 3.10 minute. It is not playing complete configured topology.Would you please check it.
Thanks once again for sharing video.
I have to record it again, something went wrong…ugh
I really can’t understand why some people still use routing functions inside Lan and then avoid to use STP ?
Also, in access layer, should we always use layer 2 and let layer 3 for distribution/core ?
A lot of entreprises use 3750 for their access layer
Still can’t understand the best practice for these cases.
IGPs like OSPF or EIGRP have many advantages over STP. They are faster and can do load-balancing. I can highly recommend you to read this article:
http://www.cisco.com/en/US/docs/solutions/Enterprise/Campus/routed-ex.html
If you want to know the difference between L2/L3 at the distribution/core layer you should grab a CCDA (Design) book. They explain the different scenarios in detail. It will answer your question.
Hello Rene,
Would you explain the command Switchport autostate exclude command. I read it, but I don’t know in which scenario I need to use it. Is it on by default?.
Thank you.
Toral.
Hi Toral,
If you use a SVI (Switch Virtual Interface) on a switch than the SVI will be up if you have at least 1 access port in the VLAN of the SVI. It will go down if there are no access ports in the VLAN of the SVI.
With the autostate exclude you can change this behavior so it’s always up…no matter if ports are active in the VLAN or not. Does that make sense?
You can run routing protocols by using the IP address on the SVI interface. You can the autostate exclude command to ensure the SVI interface always stays up and doesn’t go down because no ports are active for a certain VLAN.
Rene
Thank you Rene.
you are welcome.
I cannot ping the .3 interface on the WWW1 router from DNS1 or DNS2. Take a look at my config
Switch#sho run
Building configuration…
Current configuration : 1322 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
no switchport
no ip address
duplex auto
speed auto
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.45 255.255.255.0
!
interface Vlan20
ip address 192.168.20.45 255.255.255.0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Edy,
You created two SVI on your switch. Interface F0/3 requires an ip address on the interface to router to WWW.
Rene, you should use this same topology for a router-on-a-stick lab.
Since the fa0/19 port on the Layer 3 switch was made into a routed port, how can we make sure that the WWW1 router is in VLAN 20?
Would the only way to do it be to make the SW1 -> WWW1 link a trunk link, and allow VLAN 20 over the link?