OSPF NSSA (Not so stubby area)


Scenario:

You are the network engineer for a new service provider called “Mythical Bits”. The routing protocol for the backbone of the network will be OSPF. To reduce the size of routing tables the company decided they want to create a design with different OSPF types like the “NSSA”.

Goal:

  • All IP addresses have been preconfigured for you, every router has a loopback interface:

    Router Wodan: L0: 1.1.1.1 /24
    Router Zeus: L0: 2.2.2.2 /24
    Router Thor: L0: 3.3.3.3 /24

  • Configure OSPF on all routers, configure the areas as specified in the topology picture.
  • Router Wodan: Loopback0 should be Area 0.
  • Router Zeus: Loopback0 should be Area 4.
  • Area 4 has no direct connection to Area 0, solve this by using OSPF commands.
  • Ensure you have full reachability.
  • Configure Area 3 into a NSSA (Not so stubby area).
  • Router Thor: add the following loopbacks:
    Loopback1: 172.16.0.3 /24
    Loopback2: 172.16.1.3 /24
  • Advertise these networks into OSPF, do not use the “network” command to achieve this!
  • Router Thor: configure a summary towards Area 0 for the 2 loopbacks you just created, make sure you do not advertise networks you do not have.
  • Router Zeus: add the following loopbacks:
    Loopback1: 172.16.2.2 /24
    Loopback2: 172.16.3.2 /24
  • Router Zeus: configure a summary towards Area 0 for the 2 loopbacks you just created, make sure you do not advertise networks you do not have.
  • When you look in the routing table of Router Wodan you see some of the loopbacks advertised as /32’s. Make sure you see the correct subnet mask that has been configured.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the protocols for CCNP.

Would you like to be a master of networking too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of CCNP.

You will learn all the secrets about OSPF, stub areas, not so stubby areas and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE!

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

OSPF NSSA Network Topology

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by Renรฉ Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

Renรฉ - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

27 Comments

  1. i visit every day this and do lab now admin might delete all lab config file pls share all lab solution config file again it really helps to learn the concept well hope you do this again for all lab i am waiting for that

  2. I’m doing the best i can to add final configs for all labs, it’s very time consuming so i’m not sure when i’ll be able to do so.

    I believe however that working yourself to the final solution will learn you more than just checking on the answer file ๐Ÿ™‚

    Good luck!

    Rene

  3. Hey, thanks a lot. Very nice work. Just some remarks ๐Ÿ™‚
    “Advertise these networks into OSPF, do not use the “network” command to achieve this!”
    Me personally – I did it using [b]ip ospf 1 area 3[/b] under interface lo1 and interface lo2 sub-menus ๐Ÿ™‚

    Therefore – that makes impossible completing the next task : “Router Thor: configure a summary towards Area 0 for the 2 loopbacks you just created,”
    by using [b]summary-address[/b] command, since those routes aren’t external. therefore – I did it on Router Wodan, which is an ABR, by using [b]area 3 range…[/b] command.

    Correct me if i’m wrong

  4. That’ll do the trick as well. I like to use tasks like “don’t use this or that command” so you have to think about other options. There are two ways of getting something into the OSPF Database and that’s advertising (using the network or interface) command OR redistribution.

    Both will do the trick but you have to be careful with other tasks, good job though! 8)

  5. [quote]Therefore – that makes impossible completing the next task : “Router Thor: configure a summary towards Area 0 for the 2 loopbacks you just created,”[/quote]
    Using “redistribute static” command you could make a summary on the router Thor for these external routes.

  6. With OSPF there are 2 ways to summarize:

    – Type 3 summary LSAs (inter-area) by using the summary command.
    – Type 5 external LSAs by using the area range command.

    1. Hi Rene

      I believe it is other way round:

      โ€“ Type 3 summary LSAs (inter-area) by using the area range command.
      โ€“ Type 5 external LSAs by using the summary command..

  7. i did this lab and i thought in use too the “ip ospf” command under interface config mode.So the problem is that once you use that command the loopback interfaces become advertised into internal ospf areas so to summarize properly i can use only “area range” command on router Wodan. So the lab was asking to summarize on router Thor so i dont think i did correct.

  8. Wow i am glad you posted up solutions for these labs. Makes it great for all of us to learn HOW to solve them, just not making scenarios.

  9. Hi mcox50,

    Thanks for your message. let me give you my answer on this:

    [quote]hi,
    the labs are good, but your main problem is language, the way you ask tasks to do is not clear, for exemple you said:

    Router Thor: configure a summary towards Area 0 for the 2 loopbacks you just created, make sure you do not advertise networks you do not have.

    Your solution shows that you used summary-address …command[/quote]

    The way I state the task/goal/questions is the way another network engineer or a customer could ask you a question. I’m not going to tell you “type in area X summary” command, which would be nothing more but copy/pasting. It’s up to you as a network engineer to find out what command you should use to summarize inter-area prefixes. If you don’t know the command you can look them up in my final configuration.

    [quote]Router Zeus: configure a summary towards Area 0 for the 2 loopbacks you just created, make sure you do not advertise networks you do not have.

    You used area range … command… [/quote]

    If you look at the task before the one where you have to summarize you can see it says [b]”Advertise these networks into OSPF, do not use the “network” command to achieve this!”[/b]

    If you are not allowed to use the “network” command you can only use the “redistribute” command. Once again i’m not going to tell you as a task “type in redistribute X” but I’m trying to make people think what other methods there are to put something into a routing protocol besides using a “network” command. I believe this makes the difference between learning something and [i]”monkey see monkey do”[/i].

    [quote]it’s somehow confusing, why you used the question format and you configured it as summary-address then you asked the same question for zeus router and you solved it with area range … i don’t understand..[/quote]

    When summarizing with OSPF you have to summarize [b]inter-area routes[/b] with the [b]summary-address[/b] command (LSA TYPE 3). [b]External routes[/b] (LSA TYPE 5) have to be configured using the [b]area range[/b] command. Two different things, two different commands.

    [quote]
    In addition, why you are using names like thor, godzila, zeus … this is not professional, it makes me feel like if i’m playing with toys and kids…. Sorry but i suggest to change the names for normal Routers names R1 R2 R3 etc so people do not get confused. [/quote]

    When I started the site I took the idea of using funky router names from the book “Routing TCP/IP Vol1″…which is about the best and most complete routing book you could get. It would have been much easier to use R1,R2,R3 and such and if I had to redo everything I probably would…now i’m going to stick with it.

    Networking isn’t a toy but things don’t have to look professional/serious to [i]be[/i] professional all the time…We are learning here which should be fun. No need to sit in a suit and tie behind the computer configuring routers here.

    Good luck with the labs and thanks for your comment!

  10. “When summarizing with OSPF you have to summarize inter-area routes with the summary-address command (LSA TYPE 3). External routes (LSA TYPE 5) have to be configured using the area range command. Two different things, two different commands.”

    I think its the other way around.

    Anything that is local to the OSPF domain is summarized by using the [b]area range[/b] command and anything that is from a outside source with the [b]summary-address[/b] command.

    In our case Wodan sees the 172.16.0.0 and 172.16.1.0 subnets as N2 – OSPF NSSA external type 2(type 7 LSAs) and Zeus sees them as E2(type 5 since they passed through Wodan and it converted them).

    Using area range will not work since this came from a outside source(redistribution on Thor) so Wodan does not create summary route and Zeus still sees E2 routes.

    The correct way to do it in this case is summary-address on either Thor or Wodan.

    As a rule of thumb:
    ABR – area range command to summarize
    ASBR – summary-address to summarize

  11. Hi Alexandru,

    Thanks for your comment on the area range vs summary-address. You are totally right…I always mix those up ;D Just edited my comment.

    Rene

  12. Interesting video but could you tell about when advertising 172.16.2.0 and 172.16.3.0 network of๏ปฟ zeus why did you use ‘network 172.16.0.0 255.255.0.0 area 4’ instead of 172.16.0.0 0.0.255.255 area๏ปฟ 4 command under ospf? I’m confused in this bit.

    cheers

    1. [quote]why did you use ‘network 172.16.0.0 255.255.0.0 area 4’ instead of 172.16.0.0 0.0.255.255 area๏ปฟ 4 command under ospf? [/quote]

      Did I type 172.16.0.0 255.255.0.0 area 4? If so I’ve been sleeping ๐Ÿ˜‰ OSPF requires wildcards but if you accidently type in a subnet mask it will convert it to a wildcard…try it and you’ll see.

  13. Hi,
    First of all I want to congratulate you. You’re doing an amazing job. I bought your route book and it’s really nice:).
    One question regarding this lab:
    I used on Zeus redistribute connected in order to generate LSA type 5.
    If I use on Wodan area 3 nssa, on router Thor there’s no default route to Wodan. Is this because router Wodan is not advertising LSA type 5 towards Thor and it’s not replacing it with a default route?
    Anyway, using area 3 nssa default-information originate makes the trick and there’s an O N2 route on Thor.

    Thanks again for your work!

    1. Off top of my head the NSSA ABR doesn’t create a default route and you’ll need the "default-information originate" command. I always forget which of the "stub" types doesn’t generate the default route by default but I think this is the one.

  14. hi rene,

    great lab!!!

    i just have one question.

    i understand i don’t need it, as i am able to ping throughout the network. but, why didn’t you append on the nssa command with "default-information originate" on Wodan’s router? thanks.

    adrian

  15. ha,

    nevermind. you just answered my question. see above.

    awesome job on the route book and labs!!!

    thanks, again

  16. Great lab Rene.
    Knocked this out pretty easily. ๐Ÿ™‚ ๐Ÿ™‚

    OSPF stubs really scared me but after going through your labs i am getting comfortable with them.

    Just the "Totally NSSA" one is left.

    Hail ROUTING. ๐Ÿ˜€ ๐Ÿ˜€ ๐Ÿ™‚

  17. hello Rene i watch your labs and i have one question . There are other way that router wodan , find out of loopback in area 4 (zeus) , without "virtual link " ?

    Thanks a lot of reply ๐Ÿ™‚

  18. Any observation Rene,

    This lab is on page 141 of "How to Master CCNP ROUTE" in the section "12. OSPF Special Area Types".

    Virtual links which is part of the solution for this lab is not discussed until page 146, "14. OSPF Virtual Links".

  19. Lab is good and helpful.But I have one problem.
    When I do summary-address on Thor router, in Wodan’s routing table exist two routes with mark N2
    172.16.0.0/24…
    172.16.0.0/23…
    What is the problem?

    1. Strange, i guess something to do how did you summarization at Zeus and Thor. My 2 cents.

      Here is mine:

      WOODAN:

      Router#sh ip route
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      Gateway of last resort is not set

      C 192.168.12.0/24 is directly connected, Serial0/0
      1.0.0.0/24 is subnetted, 1 subnets
      C 1.1.1.0 is directly connected, Loopback0
      C 192.168.13.0/24 is directly connected, Serial0/1
      2.0.0.0/24 is subnetted, 1 subnets
      O IA 2.2.2.0 [110/65] via 192.168.12.2, 00:10:14, Serial0/0
      3.0.0.0/24 is subnetted, 1 subnets
      O 3.3.3.0 [110/65] via 192.168.13.3, 00:10:14, Serial0/1
      172.16.0.0/23 is subnetted, 2 subnets
      O N2 172.16.0.0 [110/20] via 192.168.13.3, 00:10:14, Serial0/1
      O E2 172.16.2.0 [110/20] via 192.168.12.2, 00:10:15, Serial0/0
      Router#

      ZEUS:

      Router#sh run | se os
      hostname Router
      ip ospf network point-to-point
      router ospf 1
      log-adjacency-changes
      area 2 virtual-link 1.1.1.1
      summary-address 172.16.2.0 255.255.254.0
      redistribute connected subnets tag 2222
      network 2.2.2.0 0.0.0.255 area 4
      network 192.168.12.0 0.0.0.255 area 2
      Router#

      THOR:

      Router#show run | se os
      hostname Router
      ip ospf network point-to-point
      router ospf 1
      log-adjacency-changes
      area 3 nssa
      summary-address 172.16.0.0 255.255.254.0 tag 3333
      redistribute connected subnets tag 3333
      network 3.3.3.0 0.0.0.255 area 3
      network 192.168.13.0 0.0.0.255 area 3
      Router#

Comments are closed.