EIGRP Stub


Scenario:

A major soccer team in the UK is running EIGRP on their internal network. One of your colleague network engineers noticed that there are quite some EIGRP routers sending query packets and sometimes routers get stuck-in-active. Since you are an expert on EIGRP you’ll have to configure the network using the EIGRP stub feature to make sure things work smoother…good luck!

Goal:

  • All IP addresses have been preconfigured as specified in the topology picture.
  • Each router has a loopback0 interface.
  • Use EIGRP AS 1 to configure on your routers.
  • Configure router Thomas so it receives EIGRP routes but doesn’t advertise anything.
  • Configure router Harry so it only receives EIGRP routes and only advertises directly connected networks in EIGRP.
  • Configure router Alfie so it only receives EIGRP routes and only advertises summary route 4.4.0.0 /16 in EIGRP.
  • Configure router Jack so it only receives EIGRP routes and only advertises static routes.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about EIGRP, queries, replies, stubs and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

EIGRP Stub

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by RenΓ© Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

RenΓ© - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

39 Comments

  1. Hi Breland,

    I will create the video solution for this lab this week so you can check my configuration.

    If you still have questions after that just leave a comment ok? πŸ™‚

    Rene

  2. Hello,

    Im not quite sure on which router’s to place static routes. Also when using eigrp stub static, router harry will not advertise static routes unless the redistribute static command in used correct?

    Thanks

  3. Great labs and they’re FREE
    Cool of you to take the time making video’s to see correct config sequence.
    This will help greatly in taking the Cisco IP Route exam.
    if people doesn’t like these labs they should either study harder or make their own.

  4. Keep up the good work bro πŸ™‚
    Your labs are really helpful in understanding the concepts completely
    I appreciate all your effort
    Thanks for everything πŸ™‚

  5. Just wanted to mention that if you advertise the router jack lo0 as 3.3.3.0 255.255.255.0 and use the EIGRP stub static feature…in order for this to work you will need to redistribute static. However when advertising network as 0.0.0.0, the lo0 interface advertises just fine internally…..LOL just an FYI if you didn’t already know.

  6. Looks like someone mentioned already. Solved.
    I experimented with it a little.

    If the network is advertised with one of these examples….
    network 3.3.3.0
    or network 0.0.0.0

    ….then the redistribute static command is NOT needed. But if the network command does not include the route, the “redistribute static” command is needed.

    I love these labs. They force me to think deeper into the situations. Thanks Rene.

  7. I had a funny occurrence today. Background: I have been changing careers from working in non-profit into becoming a network engineer!! Big turn. Well, I have recently passed CCNA, working on CCNP because I think that is where the “meat” is, and all the while doing job interviews. Today at an interview at a NOC (I still am quite entry level), I did so well at the tech part of the interview, that they told me I was OVERQUALIFIED for the position!!!!!!

    In a funny way, I credit EXACTLY these hard labs as to why I know something….that is beyond the reading that I do 24/7!

    Thank you, and please: MORE, I’m addicted!

  8. Just wanted to say thanks for all the hard work and time you have put into these labs. I currently have my CCNA and passed the CCNP Switching test. I also have the actual hardware for the CCIE topology from INE. But using these labs has really broaden my knowledge and hands on experience. While I do plan to go back to the hands on with the actual hardware, I find using these labs accelerate my learning in the CCNP routing area. As you mentioned many times, I am sure some of this material is CCIE level.

    It’s much easier to use GNS3 and these labs than it is to try and reset your actual hardware and place new configs on them all. I have done it already in several different manners but GNS3 is by far the fastest and easiest. To bad switching is the way it is in GNS3.

    All in all thank you!

    Tbear

  9. Thanks for all your comments people, it’s great to hear that my material is appreciated! 8)

    1. I hope you found them by now πŸ™‚ Once you login they’ll appear at the end of the article in the attachments.

  10. Hello,
    Firstly, I would like to thank you for your great labs. I think the function “EIGRP stub static” supports only classful networks that’s why 3.0.0.0/8 network works fine but 123.0.0.0/24 doesn’t.

    Edit: If you add the “redistribute static” command you’ll also redistribute classless networks

    1. Hmm not sure if it has to be classful or not. "EIGRP stub static" is a funny one. You still need to use "network" or "redistribute" command go get the static route into EIGRP before it will be advertised.

  11. Hello Rene,

    I too would like to join with stunt4711 to thank you for these labs; I am using them as practice as I prepare for CCIP…

    As for the 123.0.0.0/24, I think it does not show up in the other router’s routing table because it isn’t tied to a specific interface or loopback so EIGRP does not advertise it…For example if the statement was:

    ip route 123.0.0.0 255.255.0.0 null 0

    [b]and there was a loopback say 12[/b]

    interface loopback 12
    ip add 123.0.0.1 255.255.255.0

    it would be advertised automatically to the other routers.

    Otherwise (as you rightfully said), redistribute static works – it just gives the route an external tag and an AD of 170 – which may be ok based on the situation for having a static in the first place
    or
    The network command as per usual.

    Finally – your material is greatly greatly greatly appreciated – thank you

  12. hello, thanks for your value able ccnp route book.
    it is absolutely for me matches my needs. Even though I have just finished reading eigrp chapters. but my question is that, is this only topolgy so that we can make our topology following how you put this one out and using same ip addresses?

    1. Hi,

      Thanks for your kind words! For the route book I’ve used a couple of different topologies. I did however refer to all the labs at the end of each chapter so instead of re-creating them yourself you can just download the lab and start working on it πŸ™‚

      Rene

  13. Love the Labs Renee, thanks for everything.

    Really don’t understand the Eigrp Stub Static on Jack. Getting very inconsistent results, just like what you saw in your lab.

    I created about 10 different statics, some work some don’t. For example..

    On Jack:

    ip route 3.0.0.0 255.0.0.0 null 0 -> Appears on Oliver
    ip route 32.0.0.0 255.0.0.0 null 0 -> Will not appear on Oliver
    ip route 123.0.0.0 255.0.0.0 null -> Will not appear
    ip route 10.0.0.0 255.0.0.0 null 0 -> Will apper
    ip route 192.168.0.0 255.255.252.0 -> Will appear

    Whats with that? It doesnt seem to be classful like someone on this thread mentioned, i was able to get classless routes to appear on Oliver.

    I tried making loopbacks, but that did not work either.

    Why do some work and some don’t? Its not making sense.

    1. Not sure. It’s been a while since I recorded this video but it doesn’t make much sense that some work and others not.

  14. I think if the Next-hop is reachable, it will appear.
    If not, it will appear.

    I tried it and worked well.

    1. Routes that have an unreachable next-hop won’t be in the routing table but creating a static and pointing it to null0 works, it always shows up in the routing table.

  15. Nice lab!!

    At 4:54, the 3.3.3.0 network is already on Oliver, because of the network command. If the IP exists on the router, and you create a static route to null for that IP (3.0.0.0), this will create a summary route to it’s neighbor. This is possibly without the redistribution and eigrp stub static command.

    I was able to test this lab by create a default route to 0.0.0.0 0.0.0.0 192.168.23.2 with the below commands. The route will appear on all routers as an external route EX.

    redistribution static
    eigrp stub static
    ip route 0.0.0.0 0.0.0.0 192.168.23.2

  16. When I create this static route on Jack router
    [b]ip route 3.3.3.0 255.255.255.0 Null0[/b]

    It doesn’t show in the show ip route output

    but if I create this one it does[b] ‘ip route 3.0.0.0 255.0.0.0 Null0′[/b]
    and redistribute through EIGRP it shows up in the next router as ‘DX’ which I expected.

    Why doesn’t the first static route work?

    The subnet mask of the loopback interface is a /24 so why use a /8 as a static route

    Thanks,

    [b]Simone[/b]

  17. > .Ok if you start a packet capture on Olivers Fa2/0 interface (The link to Thomas)
    >.Now examine the Hello packets from neighbour 192.168.12.1 (Thomas)
    >.Expand Cisco EIGRP
    >.Peer Stub Information
    >.Stub Options
    0 – Connected – not set
    0 – Static – not set
    0 – Summary – not set
    1 – Redistributed – set
    0 – Leak-Map – not set
    0 – Receive-only not set

    Why is receive only not set ??????????????????????
    I have specified that Thomas is a stub router
    router eigrp 1
    eigrp stub receive-only

    Has anyone else got the same output from WireShark ?
    Or am I missing something here?

    Regards
    T

  18. Hi Rene, First of all excellent job, it really gives a deep knowledge, about this lab, I suppose the best way to check whether you have set it up properly or not is to check the ip route on oliver, go through the requirements and check whether the routes are showing according to what is required.

  19. Hi Rene and all others

    First of all many thanks to RENE and to all others who share their knowledge and experience

    I did the same as RENE did and the result was same [ ping to 3.3.3.3 was successful ] , then I remove the static route
    ip route 3.0.0.0 255.0.0.0 null 0

    and placed another static route at Jack

    ip route 10.0.0.0 255.255.255.0 null 0

    after that the above static router appeared in Oliver’s routing Table , while 3.3.3.0/24 disappeared and the ping to 3.3.3.3, from Oliver failed

    I did not advertise everything in eigrp on Jack and the remaining routers , instead used the following commands on Jack

    network 3.3.3.0 0.0.0.255
    network 10.0.0.0 0.0.0.255
    network 192.168.0.0 0.0.255.255
    no auto-summary
    eigrp stub static

    Any thoughts why I achieve the lab objective ……

  20. this is weird

    Jack(config)#ip route 3.3.0.0 255.255.0.0 192.168.23.2 – this work.
    Jack(config)#ip route 3.3.3.0 255.255.255.0 192.168.23.2 – this doesn’t work.

    i mean the only difference is other is class B while the other is class c which is really doesnt matter in this particular instance right?

    fyi below is router jack config.

    interface Loopback0
    ip address 3.3.3.3 255.255.255.0

    interface FastEthernet0/0
    ip address 192.168.23.3 255.255.255.0

    router eigrp 1
    redistribute static
    network 3.3.3.0 0.0.0.255
    network 192.168.23.0
    no auto-summary
    eigrp stub static

    ip route 3.3.0.0 255.255.0.0 192.168.23.2

    1. You already have a connected route for 3.3.3.0/24 on your loopback. Adding a matching static route doesn’t make sense. IOS is probably complaining about that.

      If you really wanted to redistribute the loopback, remove the EIGRP network statement for it and use redistribute connected instead.

  21. Hi Rene,

    I tried the last step in a different method, I didnt try to create a static route for 3.0.0.0 and point to null, But I created a default route like below.

    ip route 0.0.0.0 0.0.0.0 192.168.23.2

    and enabled redistribution, it works..

  22. Hi all,

    i have to put “redistribute static” in the eigrp configuration of jack, otherwise oliver won’t see any of the static routes.

    Like someone else already mentioned all the redistributed static routes will be visible in the routing table as EIGRP External D EX. see below:

    without redistribute static:

    Jack#sh r
    *Mar 1 00:39:11.591: %SYS-5-CONFIG_I: Configured from console by consoleun | begin router eigrp 1
    router eigrp 1
    network 3.3.3.0 0.0.0.255
    network 192.168.23.0
    no auto-summary
    eigrp stub static

    Oliver#sh ip route eigrp
    4.0.0.0/16 is subnetted, 1 subnets
    D 4.4.0.0 [90/156160] via 192.168.24.4, 00:22:42, FastEthernet3/0
    5.0.0.0/24 is subnetted, 1 subnets
    D 5.5.5.0 [90/156160] via 192.168.25.5, 00:22:51, FastEthernet1/0
    D 192.168.56.0/24 [90/30720] via 192.168.25.5, 00:22:51, FastEthernet1/0

    with redistribute static:

    Jack#
    Jack#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Jack(config)#router eigrp 1
    Jack(config-router)#red
    Jack(config-router)#redistribute static

    Oliver#sh ip route eigrp
    D EX 3.0.0.0/8 [170/28160] via 192.168.23.3, 00:00:14, FastEthernet0/0
    4.0.0.0/16 is subnetted, 1 subnets
    D 4.4.0.0 [90/156160] via 192.168.24.4, 00:25:12, FastEthernet3/0
    5.0.0.0/24 is subnetted, 1 subnets
    D 5.5.5.0 [90/156160] via 192.168.25.5, 00:25:21, FastEthernet1/0
    D 192.168.56.0/24 [90/30720] via 192.168.25.5, 00:25:21, FastEthernet1/0
    123.0.0.0/24 is subnetted, 1 subnets
    D EX 123.123.123.0 [170/28160] via 192.168.23.3, 00:00:14, FastEthernet0/0

  23. Hi, i have a question about using stub routers that, i have seen similar question on a lab i found in the Internet. For example one of the edge routers in this topology, let’s say Alfie has a LAN connected to it. I want Alfie to advertise its LAN to its neighbor and have only default route in it’s routing table, no eigrp routes at all. I can do “eigrp stub connected” to advertise the LAN, but how can i make so Alfie does not have any EIGRP routes in its routing table and uses default instead.

    1. @Alex,

      When you configure “eigrp stub receive-only” on Oliver, it will stop sending EIGRP updates to Alfie. Hellos will still be exchanged and EIGRP neighbor relationship will be maintained. Alfie can have a static default route as desired.

      HTH!

  24. In my lab, i noticed that on Jack, i had to shut int lo0 to enable static route get into routing table (as static route), otherwise it won’t enter in the routing table. I think it’s because of distance metric that is preferred over the static route distrance metric of 1.

    R3#show ip route 3.3.3.3
    Routing entry for 3.3.3.0/24
    Known via “static”, distance 1, metric 0 (connected)
    Redistributing via eigrp 1
    Advertised by eigrp 1
    Routing Descriptor Blocks:
    * directly connected, via Null0
    Route metric is 0, traffic share count is 1

    R3#show ip route 3.3.3.0
    Routing entry for 3.3.3.0/24
    Known via “connected”, distance 0, metric 0 (connected, via interface)
    Redistributing via eigrp 1
    Routing Descriptor Blocks:
    * directly connected, via Loopback0
    Route metric is 0, traffic share count is 1

Comments are closed.