Scenario:
You are the junior network engineer for the biggest company in the world selling Arcade Games. You need to establish a BGP link with the service provider, in the future they will add another physical link for redundancy and so the provider wants you to setup the EBGP link between the loopback adapters for logical redundancy…time for some practice!
Goal:
- All IP addresses have been preconfigured for you as specified in the topology picture.
- Both routers have a loopback interface:
Router Ping: L0: 1.1.1.1 /32
Router Pong: L0: 2.2.2.2 /32 - Configure static routes on both sides pointing to each others loopback.
- Ensure you have full reachability and can ping both loopbacks.
- Router Ping: configure BGP AS 100
- Router Pong: configure BGP AS 200
- Establish a BGP neighbor relationship between the 2 routers. You need to source the BGP updates from the loopback interfaces.
- Ensure you have a BGP neighbor relationship, use the “show ip bgp summary” command to confirm this.
It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.
Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?
I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.
You will learn all the secrets about BGP, external BGP, TTL, multihop and more.
Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE
IOS:
c3640-jk9s-mz.124-16.bin
Topology:
Video Solution:
Configuration Files
You need to register to download the GNS3 topology file. (Registration is free!)Once you are logged in you will find the configuration files right here.
The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.
Written by René Molenaar - CCIE #41726
Hi very nice basic lab. Without spoaling the fun but i’m i correct when i say that bgp doesn’t see loopback as directly connected?
Cheers,
good site 😉
That’s correct…directly connected means the same interface in this case.
Hi, My config is: router bgp 100
no synchronization
neighbor 192.168.12.2 remote-as 200
neighbor 192.168.12.2 ebgp-multihop 3
neighbor 192.168.12.2 update-source Loopback0
with a similar one on the other router.
After doing a clear ip bgp * the adj went down but never got up. Am I missing something here? All the other configs are done ok. The adj should have come up in my opinion.
Thanks
Hi, no configs added to the .zip file.
It worked, nice lab!
**PING Router**
router bgp 100
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ebgp-multihop 3
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 200 8 9 4 0 0 00:02:27 0
Very nice that’s the trick…now I have another challenge if you like 😉
Try to solve this one without the “ebgp multihop” command and make sure updates are sourced from the loopback interfaces.
I got the startup and final configs on my pc here, will upload them this weekend.
challange accepted.
neighbor 1.1.1.1 ttl-security hops 2
Regards
Shoeb
Great lab. Thanks!
hello rene can this be donw without using the comand update-source loopback what i think this can be done without this command to reach the network 2.2.2.2
enter your message here…[quote=stemrikar]challange accepted.
neighbor 1.1.1.1 ttl-security hops 2
Regards
Shoeb[/quote]
Nice one.
"The neighbor ebgp-multihop command is not needed when this feature is configured for a multihop peering session and should be disabled before configuring this feature."
http://www.cisco.com/en/US/docs/ios/12_3t/12_3t7/feature/guide/gt_btsh.html
Excellent!!
Nice basic lab.
I understand that lab’s name "BGP EBGP MULTIHOP" means use command neighbor x.x.x.x ebgp-multihop. But if you want to make BGP neignbors from 2 adjacent router using their loopbacks you can just use neighbor x.x.x.x disable-connected-check.
No need to use neither ebgp-multihop nor ttl-security.
There is a good post about it http://lostintransit.se/tag/disable-connected-check/
Could you maybe handle a scenario where you have:
* 3 routers via frame-relay
* R1 connects to R2
* R1 connects to R3
All interfaces in a single IP range: 172.16.4.0/24
Then handle the different methods to manage the hop/ttl.
on R2 “neighbor 172.16.4.x ebgp-multihop 2”
&
on R3 “neighbor 172.16.4.x ttl-security hop 2”
I’m able to get the two routers to establish a BGP relationship when using either TTL-Security, or EBGP-MULTIHOP on both routers, but not when I mix them as with the scenario above.
Please let me know if this sounds like a good lab, and I’ll email you the complete layout I have tested.
The two are different. eBGP-multihop simply sets the TTL of the eBGP packet and, if the value is greater than 1, allows the router to use protocol-learned routes for BGP peers, versus just connected.
TTL-security sets the TTL to 255. The value you specify is the difference from 255. A value greater than 1 allows the router to use protocol-learned routes for BGP peers, versus just connected.
Thanks for the lab. I will have to look up all this TTL security to understand better