RIP Beginner


Scenario:

You are working for a company located in the Netherlands. Your manager is the nostalgic kind of guy and wants you to configure the RIP Routing protocol on all of their routers. You try to convince him to run OSPF or EIGRP because of faster convergence, but to no avail….time to get the job done.

Goal:

  • All IP addresses have been preconfigured for you.
  • All routers have a loopback interface as following:
    Amsterdam: 1.1.1.1/24
    Rotterdam: 2.2.2.2/24
    Utrecht: 3.3.3.3/24
  • Configure RIP version 1 on all routers, achieve full connectivity for all networks (including the loopbacks)
  • Utrecht: configure RIP version2
  • Utrecht: make sure you accept version 1 and 2 routing updates.
  • All Routers: make sure you are only running version2
  • Change the configuration on all routers so the subnetmask is sent along with the routing updates.
  • Amsterdam: make sure no routing updates are sent to the loopback interface.
  • All routers: Change the RIP timers so routing updates happen every 10 seconds.
  • Utrecht: Advertise a default route into RIP.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the protocols for CCNA.

Would you like to be a master of networking too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of CCNA.

You will learn all the secrets about switching, routing, subnetting and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNA!

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

RIP Beginner

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

24 Comments

  1. Bonjour Rene

    i am using a different IOS [c3660-telcoentk9-mz.124-13b.bin] and i came to the point where i need to get it to advertise a Default route and got quite stuck !

    the way i found a solution to show myself a proof of concept was to add a default route [on a stub router] ; then activated RIP and added network 0.0.0.0

    and what do you know ! it worked ; rip started advertising about my stub network [that was not included in its configuration for RIP networks]

    this is really cool BUT i still cannot get the theory behind it
    so i thought to ask you if you may tell me about some document or concept that clarifies this behavior

    thank you for everything

    Cordialement

  2. Bonjour Shareef,

    Be careful with other IOS warnings, some of them might give you a hard time…crashing Dynamips and such, or features that don’t work.

    Every routing protocol has a different method of creating a default route, keep the following in mind when configuring RIP:

    1) The “Network” command tells the router on which interface to start talking RIP, it will also advertise the network that you configured on the interface. If you use the command ‘network 0.0.0.0’ it will activate RIP on every interface that falls under the 0.0.0.0 range…of course that is every interface with an IP address. If you have for example 192.168.12.0/24 on an interface, then this is what the router will advertise to it’s neighbors.

    Now about creating a default route….

    2) There are 2 ways to configure a default route:

    a) By creating a summary, you need to do this on an interface level by using the “ip summary-address rip” command.

    For example:

    enable
    configure terminal
    interface f0/0
    ip summary-address rip 0.0.0.0 0.0.0.0

    b) By using the “default-information originate” command, for example:

    enable
    configure terminal
    router rip
    default-information originate

    Does this make sense to you? Let me know if you have any questions…

    Bonne chance!

  3. Hi team, Really informative website, good job guyz, i need help in getting IOS , how & from where can i find it in your website

  4. Welcome aboard!

    We can’t share the IOS images on the website since it’s not allowed 🙂 The filename(s) I specify at every lab should help you though…Google is your friend 8)

  5. Hello,
    I don’t know how to do this part: Amsterdam: make sure no routing updates are sent to the loopback interface.
    I was thinking about to use passive-interface. But I found out that only ensure the interface will not forward information. But it will still receive. So what should I do to meet this requirement.
    Thank you.

  6. For some reason the default route would not take on the Utrecht router even with the following forementioned commands:

    Utrecht#sho run | beg int
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    ip rip advertise 10
    !
    interface FastEthernet0/0
    ip address 192.168.23.3 255.255.255.0
    ip rip advertise 10
    ip rip send version 1 2
    ip rip receive version 1 2
    ip summary-address rip 0.0.0.0 0.0.0.0
    duplex auto
    speed auto
    !
    router rip
    version 2
    timers basic 10 180 180 240
    passive-interface Loopback0
    network 3.0.0.0
    network 192.168.23.0
    no auto-summary
    !
    Utrecht#sho ip route
    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:01, FastEthernet0/0
    1.0.0.0/32 is subnetted, 1 subnets
    R 1.1.1.1 [120/2] via 192.168.23.2, 00:00:01, FastEthernet0/0
    2.0.0.0/32 is subnetted, 1 subnets
    R 2.2.2.2 [120/1] via 192.168.23.2, 00:00:01, FastEthernet0/0
    3.0.0.0/32 is subnetted, 1 subnets
    C 3.3.3.3 is directly connected, Loopback0
    C 192.168.23.0/24 is directly connected, FastEthernet0/0

    So, I ended up invoking the following static route command for the default route:

    Utrecht#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Utrecht(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2
    Utrecht(config)#end
    Utrecht#
    *Mar 1 00:29:11.695: &#xSY;S-5-CONFIG_I: Configured from console by console
    Utrecht#sho ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is 192.168.23.2 to network 0.0.0.0

    R 192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:08, FastEthernet0/0
    1.0.0.0/32 is subnetted, 1 subnets
    R 1.1.1.1 [120/2] via 192.168.23.2, 00:00:08, FastEthernet0/0
    2.0.0.0/32 is subnetted, 1 subnets
    R 2.2.2.2 [120/1] via 192.168.23.2, 00:00:08, FastEthernet0/0
    3.0.0.0/32 is subnetted, 1 subnets
    C 3.3.3.3 is directly connected, Loopback0
    C 192.168.23.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 [1/0] via 192.168.23.2

    The static default route appears to work, perhaps GNS3 went quirky. The other routers worked fine with the “default-information originate” command.

    Thanks so much for this lab and I will definitely continue on with the others.

    8)

    1. add to interface FastEthernet0/0
      no ip split-horizon
      to achieve your task.

      Njoi,
      Shoeb

  7. Hi Rene,

    About the default network on Utrecht. I have solved it another way. It is with another command but I am worndering what your take on this one is?

    I’ve created an default network on Utrecht:
    ip default-network 192.168.23.0

    In the routing table of Amsterdam shows a:
    R* 0.0.0.0/0 [120/2] via 192.168.12.2, 00:00:06, FastEthernet0/0

    And on Rotterdam:
    R* 0.0.0.0/0 [120/1] via 192.168.23.3, 00:00:01, FastEthernet1/0

    Is this a case of "multiple roads to Rome"? 🙂

    Thanks for your time.
    Lino

    1. Hi Lino,

      It sure is…this is another method of doing it. There are multiple methods of getting "the job done" 🙂

      Rene

  8. Hey Rene how I have a Mac and when I tried to open the Rip Beginner lab it does not open. How can I do this?

    1. What error do you see? If you post this in the forum i’ll answer it there ok?

  9. Hey in this question..

    All routers: Change the RIP timers so routing updates happen every 10 seconds..

    we can change it by this command..
    router rip
    version 2
    timers basic 10 180 180 240

    Or by This command..
    interface FastEthernet0/0
    ip address 192.168.12.1 255.255.255.0
    ip rip advertise 10

    But when i downloaded the final config from website then i saw that we have configured both the commands on all the routers.

    i am not sure whether it is compulsory to type both the commands or we can use any one command to accomplish the task.
    Please help me out in this..

    Thanks..

    1. Not sure what I did when I recorded this video (been a while ago). The difference between those commands is that the first one is global, the other one is for the interface level.

  10. HI Rene,

    Please find my rip debug outputs from Amsterdam,
    I have 2 qusteen our of those

    1) I coudint able to see my loopback’s subnet as /24 after enabling V2

    2) I dont know why my Amsterdam router is showing i hops to reach Utrecht

    I tried to find by my self but no idea…

    Thanks in advance:

    *Mar 1 00:45:11.563: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.1)
    *Mar 1 00:45:11.567: RIP: build update entries
    *Mar 1 00:45:11.567: [b]1.0.0.0/8[/b] via 0.0.0.0, metric 1, tag 0
    *Mar 1 00:45:12.595: RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
    *Mar 1 00:45:12.599: [b]2.0.0.0/8[/b] via 0.0.0.0 in 1 hops
    *Mar 1 00:45:12.603: [b]3.0.0.0/8[/b] via 0.0.0.0 in [b]1 hops[/b]
    *Mar 1 00:45:12.603: 192.168.23.0/24 via 0.0.0.0 in 1 hops

  11. Hello,
    May I have a queston? I am just wondering what if we have 2 links between R1 and R2? How does RIP choose which one is beeing used during the routing pocess when each link has the same admin distance?
    Thanks!

  12. Thanks for another great lab Renee!

    Regarding the requirement for all routers to send the subnet mask in their advertisements, it is the "version 2" command, and not the "no auto-summary" that does this.

    RIPv1 does not send subnet masks in updates, this is what makes it a classful routing protocol. Since it doesn’t know what the real mask of an incoming route is, it makes an assumption based on the network class of the route. However, if the router has an interface with an IP address in the same major network as the incoming route, it can assume that the subnet mask of the incoming route is the same as the one on the interface.

    RIPv2 does not have these problems, since it always sends the subnet mask with all updates, whether they are summarized or not.

    The "no auto-summary" command simply disables the default behavior of RIP that summarizes networks at classful boundaries to their classful subnet mask.

  13. Hi,

    Did this Lab using 7200 routers on a previous version of GNS3 (0.8.4), as the latest version was giving me some errors setting the Idle Pc time…..and all steps\commands completed successfully per the video! Great Lab!

    Many Thanks!!

Comments are closed.