Multipoint One-Way Redistribution

Your local neighborhood pet shop has asked you to help them solve some network problems. The pet shop is running OSPF and recently bought another shop that is running EIGRP. To achieve connectivity they use redistribution but now some users are complaining about unreachable networks and the slowness of the network. Someone at the pet shop tried one-way redistribution but had trouble with non-optimal paths. They decided to configure multipoint one-way redistribution but this also introduced the problem of flapping networks…think you can solve it?

Goal:

  • All IP addresses have been preconfigured for you.
  • Configure OSPF on router Ace and Aggie and only advertise network 192.168.12.0 /24.
  • Configure EIGRP AS 1 on router Ace, Aggie and Abu. Only advertise network 192.168.13.0 /24 and 192.168.23.0 /24.
  • Redistribute the loopback0 interface in EIGRP AS 1 on router Abu.
  • Redistribute EIGRP information into OSPF on router Ace and Aggie.
  • Check router Ace and Aggie for possible redistribution problems and solve the problem.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about redistribution between OSPF and EIGRP.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

Multipoint One Way Redistribution

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by Renรฉ Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

Renรฉ - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

33 Comments

  1. Hey Rene,
    I couldn’t remember if i could tamper with the redistributed EIGRP admin distance so all i did was configure a distribute list on each of the fa1/0 interfaces inbound to deny 1.1.1.1 from being accepted.

  2. Hi Thomas,

    The problem in this lab is that router Ace and Aggie will have 3.3.3.0 /24 in their routing table with an AD of 170 (EIGRP External). Once they redistribute this network into OSPF they will learn about this network from each other and the AD will be 110 (OSPF External). Things will work but we will have sub-optimal routing.

    There are a couple of methods to fix this, for example:

    – Distribute list to deny this network (like you did)
    – Route tagging
    – Change the Administrative distance of OSPF external to something higher than 170.

    Does this help?

    Rene

    1. First of all I wanted to thank you for all the GREAT labs!!

      I just finsied this lab and thought it was good practice in seting the AD. I just had one comment about the 3 options you gave to solve the issue..

      "-Distribute list to deny this network (like you did)"
      Wouldn’t denying the network with a distribute list be a bad thing? I mean if a link to ABU went down you wouldn’t have another route to get to 3.3.3.0/24 network.

      What I did was set the AD in OSPF on that specific network using an ACL. The other methods are also good ones. ๐Ÿ™‚

      Keep up the great work!!

      Steve

  3. Hi Rene,

    I am a little confused with this lab, says to redistribute EIGRP into OSPF not sure why, shouldn’t it be OSPF into EIGRP so that Abu can get the 192.168.120 route?

    Am I missing something?

    1. Hi Matt,

      Most of the times you will use "two way redistribution" and so you will redistribute OSPF into EIGRP and vice versa. This lab however is called "one way redistribution" for a reason ๐Ÿ˜‰

      Router Abu won’t know about network 192.168.12.0 /24 in this scenario but that’s ok…it’s not the goal of this lab ๐Ÿ™‚

      I see I haven’t recorded the video yet for this lab, I’ll try to do this soon so you can see how I fix it.

      Rene

  4. A good lab which helps with practicing amending the admin distance in order to prevent sub optimal routing

  5. First off, nice lab. Thank you.

    It does seem that the YouTube video cuts off early though – hadn’t gotten to the resolution yet.

    I ended up having to change the AD of OSPF external routes to something over 170 and that solves the problem, but my question is why the routing tables on Ace and Aggie differ. If we are redistributing the EIGRP External route into OSPF on both Ace and Aggie, aren’t we supposed to see an OSPF E2 route on both Ace and Aggie pointing at each other with AD 110? Instead, we only see 1 of them at a time (depending on the last router to enter the redistribution command). The other router still shows the EIGRP External route with AD 170, even though it should be receiving the OSPF E2 route with AD 110 from Aggie/Ace (depending on which router you’re consoled into). I’m probably just overlooking something easy..

    1. Thanks for your comment, I’ll check the video to see what is wrong. The reason you see a difference between the routers is kinda like the "chicken and egg" problem.

      Aggie or Ace will learn about the network, redistribute it and advertise it to the other router. This router will install the network in the routing table and throws away the old information from the routing table. You cannot advertise what you don’t have anymore…

      Does that make sense?

          1. Would this also be due to the fact that one of them will be the DR and the other the BDR? The DR will have the EX route while the BDR will get its primary database from the DR thus handing it an E2 route?

            This is the way it worked out in my original scenario before changing the external AD to 180 on both routers. I played around with it a bit allowing the other router to become DR and then it too had the EX and again gave the BDR the E2 route.

            1. I don’t think so, doesn’t it depend on which router (Ace/Aggie) receives the external EIGRP route first from Abu?
              That router then generates a Type 5.
              I forget – if we have two points of redistribution as above, I think only one router will generate the Type 5 – not both.

              What do you think the DR/BDR has to do with this?

              Thanks.

      1. Rene Why router Ace doesnot have 0 E2 route… why it still had DEx route. DEX had 170 AD while OE2 has 110 . I am asking this question when we do redetribution on both Ace and Aggie in one way…..
        Regarding Multipoint One-Way Redistribution
        LAB

        My another question is that When Ace HAS NOT OE2 in routing table how Ace can resdiribute OE2 to Aggie

        Video Problem is still … 1 year passed sir.

    1. On the right side you can find a link to "Solve GNS3 Errors". This fixes 90% of the problems, take a look at it.

  6. nice Lab Thank you Renee
    on both redistribution routers:

    "distance ospf external 180 "

    this resolve suboptimal routing

    1. Yes it does, this "simulates" the same behavior as EIGRP external routes. You can make it more specific by using an access-list, right now it will change the AD for all OSPF external routes.

  7. Excellent lab Rene.

    I spent few hours fiddling with it but it was quite fun to see you can manipulate routes.

    I fixed the issue by changing the AD of OSFP only for external routes in both routers, Aggie and Ace.

    [code]router ospf 1
    distance ospft external 200[/code]

  8. below is my solution:
    didn’t want to change the AD as that is a global change ๐Ÿ™‚ and also wanted to use the route-tagging for my sake.. hehe

    R2#sh run | s route-map
    route-map DENY deny 10
    match tag 10
    route-map DENY permit 20
    route-map TAG permit 10
    set tag 20

    R2#sh run | s router ospf
    router ospf 23
    log-adjacency-changes
    redistribute eigrp 23 subnets route-map TAG
    passive-interface default
    no passive-interface FastEthernet0/0
    network 192.168.12.0 0.0.0.255 area 0
    distribute-list route-map DENY in

    R1#sh run | s route-map
    route-map DENY deny 10
    match tag 20
    route-map DENY permit 20
    route-map TAG permit 10
    set tag 10

    R1#sh run | s router ospf
    router ospf 1
    log-adjacency-changes
    redistribute eigrp 23 subnets route-map TAG
    passive-interface default
    no passive-interface FastEthernet0/0
    network 192.168.12.0 0.0.0.255 area 0
    distribute-list route-map DENY in

    hostname R1 is Ace
    hostname R2 is Aggie

    1. Thanks evolution. This is something that I definitely need to work on is route tagging.

      I do have a question though, you state that changing the AD is a global change, yet I was under the impression that using the ‘distance ospf’ command was local to that device only. Or do you mean ‘global’ in the sense that it will make that change for ALL external routes on this device versus specific external routes?

  9. Excellent Lab!

    Looks like the Router installing the External OSFP route for 3.3.3.0/24 will depend on which of the two routers will redistribute the EIGRP route first..Right?

    1. Yes that is correct. You can’t redistribute what you don’t have in your routing table.

      1. Rene Why router Ace doesnot have 0 E2 route… why it still had DEx route.

        DEX had 170 AD while OE2 has 110 .

        I am asking this question when we do redetribution on both Ace and Aggie in one way…

  10. Hi Rene,

    Really appreciate your time & efforts in putting those materials. It’s just awesome & makes me to recall all the concepts very quickly.

    I did this lab & it worked really great. Can you please share the commands for the other 2 methods.

    I worked on distribute list & route-map. Let’s see if i can pull this up before i get a reply from you…

    I’ll share it with to cross check, if it works…

    Thanks for all your help…

  11. Hi Rene,

    Could pull this up… I was able to do the other 2 methods. Let me know if there is any other better way to achieve this…

    Here are my configs:

    Method 1: Through Distribute-list

    On Aggie
    ——–

    access-list 10 deny 3.3.3.0
    access-list 10 permit any

    router ospf 1
    distribute-list 10 in

    _____________________________________________________________________

    Method 2: Through Route-map

    On Abu
    ——
    route-map eigrp-abu permit 10
    set tag 1111

    router eigrp 1
    redistribute connected route-map eigrp-abu

    On Ace & Aggie
    ————–
    route-map EIGRP_AS deny 10
    match tag 1111

    router ospf 1
    redistribute eigrp 1 subnets route-map EIGRP_AS

  12. Rene Why router Ace doesnot have 0 E2 route… why it still had DEx route.

    DEX had 170 AD while OE2 has 110 .

    I am asking this question when we do redetribution on both Ace and Aggie in one way…..

  13. Ace
    router eigrp 1
    network 192.168.13.0
    no auto-summary

    router ospf 1
    redistribute eigrp 1 subnets
    (This will effect Neighbor Routing table only Not Local routers)
    network 192.168.12.0 0.0.0.255 area 0
    distance ospf inter-area 110 external 190
    OR
    distance ospf external 190
    (This above one command will only and only applied on local router
    Routing table. It never changes neighbour router ospf external
    routes)

    Aggie
    router eigrp 1
    network 192.168.23.0
    no auto-summary

    router ospf 1
    redistribute eigrp 1 subnets
    (This will effect Neighbor Routing table only Not Local routers)

    network 192.168.12.0 0.0.0.255 area 0
    distance ospf inter-area 110 external 190
    (This above one command will only and only applied on local router
    Routing table. It never changes neighbour router OSPF external
    routes)

    Abu
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0

    router eigrp 1
    redistribute connected metric 1500 1 255 1 1500
    network 192.168.13.0
    network 192.168.23.0
    auto-summary

    Rene comments :
    Aggie or Ace will learn about the network, redistribute it and advertise it to the other router. This router will install the network in the routing table and throws away the old information from the routing table. You cannot advertise what you don’t have anymore…

  14. Hi Rene, i have lowered the Admin. distance of the external eigrp to 100 (lower than the OSPF admin distance 110) and it works fine for me.
    Also since the lab says we should redistribute the loopback 0 interface into eigrp ; I created i route-map to permit only the loopback int and denied the other connected interfaces which have been already advertised in eigrp using the network cmd.See below my configs

    Abou:
    !
    router eigrp 1
    redistribute connected metric 500 200 255 1 1500 route-map REDIS.LooPBACK
    network 192.168.13.0
    network 192.168.23.0
    no auto-summary
    !
    access-list 1 permit 3.3.3.0 0.0.0.255
    !
    route-map REDIS.LooPBACK permit 10
    match ip address 1

    —–
    Ace:
    !
    router eigrp 1
    network 192.168.13.0
    distance eigrp 90 100
    no auto-summary
    !
    router ospf 1
    redistribute eigrp 1 subnets
    network 192.168.12.0 0.0.0.255 area 0

    —-
    Aggie:
    !
    router eigrp 1
    network 192.168.23.0
    distance eigrp 90 100
    no auto-summary
    !
    router ospf 1
    redistribute eigrp 1 subnets
    network 192.168.12.0 0.0.0.255 area 0

  15. Hi Rene,

    Just a quick question regarding on this lab.

    Why is it that Ace and Aggie has a right topology table but when you try it to view it on the routing table it reflects the sub-optimal route, topology table of Ace reflects 3.3.3.0 was learned via 192.168.13.0 and topology table of Aggie states 3.3.3.0 was learned via 192.168.23.0.

    Before configuring ospf administrative distance why is that only one router has a sub-optimal route for instance Aggie has a routing table using route via externel eigrp whereas ace uses the external ospf???

    Thanks and regards,

  16. QUESTION
    ==============================================================
    when it was one way, one side redistribution i wasnt able to get ping
    ============================================================

    As i was progressing with the lab,
    i had initally fullly completed the ace side, but then aggie couldnt get any ping 3.3.3.3, i played around with it for a while, but i couldnt get any positive result, even before or after i gave the distance command in ace, (at this point there is redistribute conf done in aggie).

    i dont understand, why after only giving every last line of code only,i was able to get ping,
    when it was one way, one side redistribution i wasnt able to get ping

    any ideas?????????

    rene great lab by the way,

  17. here is my config…

    Ace(config-route-map)#do sh run | sec router
    router eigrp 1
    network 192.168.13.1 0.0.0.0
    no auto-summary
    router ospf 1
    log-adjacency-changes
    redistribute eigrp 1 subnets route-map EIGRP-TO-OSPF
    network 192.168.12.1 0.0.0.0 area 0
    distribute-list route-map OSPF-DIST-IN in

    Ace(config-route-map)#do sh run | sec route-map
    redistribute eigrp 1 subnets route-map EIGRP-TO-OSPF
    distribute-list route-map OSPF-DIST-IN in
    route-map OSPF-DIST-IN deny 10
    match tag 90
    route-map EIGRP-TO-OSPF permit 10
    set tag 90

    Aggie(config-router)#do sh run | sec router
    router eigrp 1
    network 192.168.23.2 0.0.0.0
    no auto-summary
    router ospf 1
    log-adjacency-changes
    redistribute eigrp 1 subnets route-map EIGRP-TO-OSPF
    network 192.168.12.2 0.0.0.0 area 0
    distribute-list route-map OSPF-DIST-IN in

    Aggie(config-router)#do sh run | sec route-map
    redistribute eigrp 1 subnets route-map EIGRP-TO-OSPF
    distribute-list route-map OSPF-DIST-IN in
    route-map OSPF-DIST-IN deny 10
    match tag 90
    route-map EIGRP-TO-OSPF permit 10
    set tag 90

    please see my config is it correct?

    Rene sir your website is awesome. your site help me alot in my studies.

  18. Perfect lab ! rene , i ‘d like to ask one thing ,when we redistributed into ospf of Ace & Aggie ,but only D EX show up in routing table of Ace ,why does Ace receive external eigrp route and why doesn’t in Aggie routing table instead of O E2 ?

Comments are closed.