EIGRP CCNP 1


Scenario:

Woods ‘r’ Us is looking for network engineers that are CCNP certified. You apply for a job as an EIGRP network engineer and instead of a job interview they ask you to configure a network so you can show them your EIGRP skills. If you succesfully configure this network you are certain to get the job!

Goal:

  • All IPv4 addresses have been preconfigured for you.
  • Each router has a loopback0 interface.
  • Configure EIGRP AS 1 on all routers. Disable auto-summary.
  • Configure EIGRP so reliability is also used as a metric.
  • Make sure router Alder will use the serial 1/0 interface as the primary link.
  • Make sure the FastEthernet0/0 interface on router Alder is a feasible successor and visible in the routing table for unequal load-balancing.
  • Router Walnut should send a summary route towards router Lyptus which only includes the loopback0 interfaces of router Alder, Cherry, Maple and Walnut. The summary route has to be as specific as possible.
  • The summary route you just created should show up with an administrative distance of 51 on router Walnut.
  • Ensure router Alder does not send EIGRP packets towards its loopback0 interface.
  • Configure router Walnut so the loopback0 interface of router Lyptus will not be advertised towards router Cherry and Maple.
  • Create a default route on router Cherry and advertise it in EIGRP.
  • Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.
  • Configure the serial interface of router Alder so EIGRP is allowed only 25% the available physical bandwidth.
  • Configure authentication between router Cherry and Walnut. The key-chain should be called “GNS3VAULT” and the password is “WOOD”.
  • Router Lyptus shouldn’t receive any query packets for lost networks.
  • The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect.
  • Configure EIGRP on the frame relay network between router Maple, Pine and Oak. You have to configure EIGRP using the multipoint sub-interfaces. Advertise the loopback0 interfaces and ensure you have full reachability between the three routers.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about EIGRP, successors, feasible successors, stub routers and more.

Does this sound interesting to you? Let me show you how to do this…

Master CCNP ROUTE Today

IOS:

c3640-jk9o3s-mz.124-16.bin

Topology:

EIGRP for CCNP Network Topology

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

131 Comments

  1. Hey,

    Great lab and most of the part where doable for me 😉
    But i have no clue how to do this:
    Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    any inputs?
    Regards

  2. Hi Rene,
    I am fond of this site, I have learnt many things from your Labs, i really appreciate your all Efforts.

    Is there any possibility to get the Video or Final Configs or this Lab, Pls.

    I will be great full to you.

    Aqeel Ahmad.

  3. Hello Aqeel,

    I’m glad you like it here. This video is still on my to-do list, I’ll see if i can do it this week.

    Meanwhile you can drop your questions here and I’ll help you OK?

    Rene

    1. Hello Rene,

      I’m to fond of this site and have learn so much.
      I am also waiting on the video solution for this lab that you said you would put up about 2 years ago.
      Thanks .

      1. Darnell, I apologize for the lack of video updates. They are very time consuming, and Rene and I have been very busy. Do you have a specific question?

        1. Hi there! 🙂

          Great site, and very helpful as well.

          One quick question.

          How important is it to use the IOS version specified in each lab?

          Can I just use for example the c3725-adventerprisek9-mz.124-15.T14.bin for all/most labs without config incompatibility problems?

          Thanks in advanced

    2. When I try to configure or login to any router I get the below error.

      Last login: Sat Apr 18 22:33:34 on ttys002
      Jasons-MacBook-Pro:~ jason$ telnet 127.0.0.1 2015 ; exit
      Trying 127.0.0.1…
      Connected to localhost.
      Escape character is ‘^]’.
      Connected to Dynamips VM “Cherry” (ID 3, type c3600) – Console port
      Press ENTER to get the prompt.
      ROMMON emulation microcode.

      Launching IOS image at 0x80008000…

      Error : compressed image checksum is incorrect 0xC871C386
      Expected a checksum of 0x694FD684

      !!! WARNING – VM is not running, will be unresponsive (status=1) !!!

  4. Hey Rene I have a couple questions… Check my understanding on these few things.. Did I do them right?

    “Make sure router Alder will use the serial 1/0 interface as the primary link.”

    I changed the delay on the fastethernet interface to accomplish this

    “The summary route you just created should show up with an administrative distance of 51 on router Walnut.”

    I ran the command “#IP summary-route EIGRP 1 0.0.0.0 248.0.0.0 51” on walnuts fastethernet 3/0 and 2/0 interfaces

    That’s the correct command. It installed the route but I feel like I’m missing one step.

    “Configure router Walnut so the loopback0 interface of router Lyptus will not be advertised towards router Cherry and Maple.
    Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.”

    I used distribution lists to accomplish these two… Was that the best method??

  5. Hello,

    great lab! I haven’t had the time to complete it yet, but I finished at the point were we set the AD of the summary route.

    As Matthew stated, I was also curious about the fact that although I changed the AD on the summary and the summary did get installed in the routing table, the AD on the routing table of the neighbor router stayed the same. And then I remembered that Rene had a similar task in the CCNA topics, where he explained that the AD has only local significance, so if it is changed in a router, it won’t get propagated to the neighbors.

    Anyway, today I hope I finish the lab.

    By the way, great work Rene! It motivates us to dive deeper into things and also see things that won’t come easily around in our working environment!

    Thank you for the effort!

  6. Hello Matthew & Katerina,

    Let me answer some of your questions:

    [quote]”Make sure router Alder will use the serial 1/0 interface as the primary link.”

    I changed the delay on the fastethernet interface to accomplish this [/quote]

    EIGRP uses bandwidth and delay by default, optionally you can enable load and reliability. If you used delay to influence the metric you can make it use the serial link so this is perfectly fine! 🙂

    [quote]”The summary route you just created should show up with an administrative distance of 51 on router Walnut.”

    I ran the command “#IP summary-route EIGRP 1 0.0.0.0 248.0.0.0 51″ on walnuts fastethernet 3/0 and 2/0 interfaces [/quote]

    This is how you configure a summary and also how you can change the administrative distance. For EIGRP you need to configure the summary on the interface level. Keep in mind that AD is always [b]local[/b].

    [quote]”Configure router Walnut so the loopback0 interface of router Lyptus will not be advertised towards router Cherry and Maple.
    Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.”

    I used distribution lists to accomplish these two… Was that the best method?? [/quote]

    Using the distribute list is a good idea. This will influence which prefixes you advertise/receive from/to neighbors without breaking the EIGRP neighbor adjacencies.

    [quote]As Matthew stated, I was also curious about the fact that although I changed the AD on the summary and the summary did get installed in the routing table, the AD on the routing table of the neighbor router stayed the same. And then I remembered that Rene had a similar task in the CCNA topics, where he explained that the AD has only local significance, so if it is changed in a router, it won’t get propagated to the neighbors. [/quote]

    Your memory serves you well 🙂 the AD is always local on a router.

    Glad you enjoyed the lab!

    Rene

    1. Hello Rene,

      I’m reviving a very old thread but I had a question: how can you use distribute lists to “Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.”

      I’m maybe getting something wrong here, but to me, a route can be filtered before being advertised to a neighbor. How do you filter it if it’s a connected route on the other router?

      On the other hand, apart from using distribute lists, are there other methods for achieving this?

      Thanks for your time in advance.

      Adam.

      1. 1. Distribute-list is cleanest
        2. Distance command with an ACL to set AD to 255 for the route you don’t want from a specific source
        3. Maybe EIGRP stub? Be creative…

  7. • Router Walnut should send a summary route towards router Lyptus which only includes the loopback0 interfaces of router Alder, Cherry, Maple and Walnut. The summary route has to be as specific as possible.

    I read in above post that the correct way to complete this is
    –ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51

    I have two question regarding this. According to the step listed in lab the summary route should only include loopback address of first four routers. However the summary address listed in command above summarizes loopback addresses of all 7 routers. So is it correct?

    Second how to check the AD on this summary route on router Walnut. Agreed that the AD set is locally significant. But what command output shows the that it is set as AD 51.

  8. Am I missing something or is there a mistake in the diagram regarding Lyptus and Walnut.

    Lyptus Walnut
    Fa 0/0 54.5 Fa 3/0 54.4
    Fa 1/0 45.5 Fa 2/0 45.4

    I’m assuming one of WalnutsLyptus’s subnets should be labeled 192.168.54.0/24 and this exercise doesn’t use etherchannels.

  9. @Sohaib Atta

    [quote]
    I read in above post that the correct way to complete this is
    –ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51

    I have two question regarding this. According to the step listed in lab the summary route should only include loopback address of first four routers. However the summary address listed in command above summarizes loopback addresses of all 7 routers. So is it correct? [/quote]

    These routers have the following networks configured on their loopback interfaces:

    1.1.1.0 /24
    2.2.2.0 /24
    3.3.3.0 /24
    4.4.4.0 /24

    We need to summarize in the first octet and I need to summarize on a bit boundary, so what are my options?

    0.0.0.0 /7 will cover 0.0.0.0 and 1.0.0.0.

    0.0.0.0 /6 will cover 0.0.0.0, 1.0.0.0, 2.0.0.0 and 3.0.0.0 but i’ll miss 4.0.0.0.

    0.0.0.0 /5 will cover 0.0.0.0, 1.0.0.0, 2.0.0.0, 3.0.0.0, 4.0.0.0, 5.0.0.0, 6.0.0.0 and 7.0.0.0.

    That’s why we need the 0.0.0.0 /5. /5 in decimal will be 248.0.0.0.

    [quote]
    Second how to check the AD on this summary route on router Walnut. Agreed that the AD set is locally significant. But what command output shows the that it is set as AD 51.[/quote]

    You can find the AD in your routing table, just do a “show ip route” and it will show up behind the summary route.

    1. I don’t see the AD in my routing table on router Walnut for some reason.

      [quote]D 0.0.0.0/5 is a summary, 01:09:23, Null0
      [/quote]

      Above is what I see. For the locally connected it is still displaying AD 90 as well. Is this a GNS3 bug?

      1. Hi,
        You should type show ip route with exact route specified. Than you’ll got more info, like AD 🙂

        Walnut#[b]show ip route 0.0.0.0 248.0.0.0[/b]
        Routing entry for 0.0.0.0/5, supernet
        Known via "eigrp 1", distance 51, metric 501, type internal
        Redistributing via eigrp 1
        Routing Descriptor Blocks:
        * directly connected, via Null0
        Route metric is 501, traffic share count is 1
        Total delay is 5000 microseconds, minimum bandwidth is 10000000 Kbit
        Reliability 255/255, minimum MTU 1514 bytes
        Loading 1/255, Hops 0

  10. @Dennis

    [quote]Am I missing something or is there a mistake in the diagram regarding Lyptus and Walnut.

    Lyptus Walnut
    Fa 0/0 54.5 Fa 3/0 54.4
    Fa 1/0 45.5 Fa 2/0 45.4

    I’m assuming one of WalnutsLyptus’s subnets should be labeled 192.168.54.0/24 and this exercise doesn’t use etherchannels. [/quote]

    You are right this is a typo. The configuration is correct however.

  11. Hey guys this lab is not working for me.
    I get error that nothing is connected to Port 7.

    I have the correct IOS, is there anything else I need to change?

  12. [i]"•Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity."[/i]
    I need help with this bullet point.
    How can this be achieved? Enabeling Lyptus as a stub area breaks the coonection.

    thanks for your time, these labs are great!

  13. Ensure router Alder does not send EIGRP packets towards its loopback0 interface.
    i made loopback 0 passive interface..is that the correct way?

    – Configure router Walnut so the loopback0 interface of router Lyptus will not be advertised towards router Cherry and Maple.????????? Help me plz..

    1. Yes. I believe this is right.

      Alder(config-router)#passive-interface loopback 0

    2. Use a dist-lists

      for example access-list 1 deny 5.5.5.0 255.255.255.0
      router eig 1
      dist-list 1 out

      🙂

  14. Configure router Walnut so the loopback0 interface of router Lyptus will not be advertised towards router Cherry and Maple.

    I tried by rout-map and PBR…but I lost EIGRP routing table on Lyptus…what is the solution?PLZ tell me..

    Thank u about this Lab….Strong effort…I love it

  15. nsure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    I used access list and rout-map the Ip policy on fa0/0 and fa1/0

    Could you add the solution of this lab?

    1. Using an access-list and PBR could be one way of dealing with this issue. I’ll record the video this week and upload it…that’ll answer all your questions 🙂

  16. enter your message here…[quote=mohammadsaeed01]nsure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    I used access list and rout-map the Ip policy on fa0/0 and fa1/0

    Could you add the solution of this lab?[/quote]

    On Walnut:
    Create a route map that sets the next-hop Ip address to one of the fastethernet links on Lyptus.

    Create an access -list to match all traffic and add a permit statement to your route map referencing this access-list

    Apply the route map to the interfaces on Walnut that connect to cherry and maple:

    i.e:

    ip access-list extended TEST
    permit ip any any

    route-map TEST permit 10
    match ip address TEST
    set ip next-hop 192.168.45.5

    interface FastEthernet0/0
    ip address 192.168.24.4 255.255.255.0
    ip policy route-map TEST

    Thinks this is a correct way of doing this but rene will put us right!

    1. This is a good method of doing it. I hope to do some video recording this + next week, i’ll do this one for sure so you can see my solution.

  17. Hi all,
    New guy on deck here. What do I need in order to participate and view the labs?

    1. Hi,

      Just register, login and you can get started. At the bottom of each lab you’ll find the attachments with the GNS3 startup configuration files.

      Most of the labs have the final config + video solution as well.

      Rene

  18. Rene

    Help me

    I don´t have idea how to do this.

    [b]•Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity.[/b]

    thanks

  19. In regard to including reliability in the EIGRP metric calculation, is this right?

    (config)#router eigrp 1
    (config-rtr)#metric weights 0 1 0 1 1 0

    If so, I have a further question. I understand what the K values mean, and how the fit into the metric equation….but….

    What you don’t hear discussed often is the actual weighting method. Each of these values can be set on a scale of 0 to 255. What does that even mean? Usually when something is weighted, it is weighed as part of whole (i.e. bandwith is 50%, delay is 50%). But with the weight command we usually just see a 0 or 1 (on or off).

    For example, consider this:

    is the command[i] (config-rtr)#metric weights 0 75 0 75 0 0[/i] the same as [i]metric weights 0 1 0 1 0 0[/i] ?

    What about [i]metric weights 0 1 0 2 0 0[/i]?

    Am I making sense?

    Just thought I would ask.

    1. Maybe I should clarify this. There are lots of discussion that talk about the default K values. But I can’t find a single discussion or example where they are set to anything other than 1 or 0, even though they may be any number from 0 to 255. What I want to know is what IS a "1". Is it half as much as a "2" or does its value depend on ANOTHER K value?

  20. Rene ppl are still waiting for the final configs and lab video !!!
    I have completed the lab but want to compare it with the final configs..Maybe there is better solution for some question than the ones I have implemented.

    1. I’m trying to do it ASAP, keep in mind I work on this website when i’m not teaching/consulting/sleeping or eating so sometimes I don’t have as much time as I’d like…for now, please drop your questions here and I’ll answer them.

  21. Was performing some self created scenarios on this when i remembered about leak-maps. Agreed as Rene has explained that we cannot create a summary address which excludes loopback interface of Oak and Pine. The summary address has to be 0.0.0.0 248.0.0.0 . But I guess to achieve what is exactly required in the lab, one can define a leak-map in which one can exclude loopback addresses 6.6.6.6 and 7.7.7.7
    Rene your comments ???

    1. If you create a summary for EIGRP then it will only advertise the summary out of the interface and not anything else. We can use the "leak map" to remove a couple of prefixes from the summary and advertise them separately. This will work in this scenario for those loopback addresses.

  22. Hi Rene

    Great lab, I was wondering if you have had a chance to record the answer video?

    Andrew

    1. Hi Andrew,

      Not yet but I’ll try to do it asap. If you have any questions please drop them here for now.

      Rene

      1. Hi Rene!

        Hats off for your efforts in creating such labs….

        You are kindly requested to add ccnp tshoot labs also , please

        1. You are welcome. I’ll upload more tshoot related material once i’m done with the "How to Master CCNP TSHOOT" book.

  23. Hi Rene,
    I’m doing a refresh of CCNP and I must say that the labs here are excellent. Can you tell me if the graceful restart of EIGRP counts as breaking the adjacency?

    Thanks!

    1. Hi Zawisza,

      I’m glad you like it. For this lab let’s agree that "graceful restart" doesn’t count as breaking the adjacency. You’ll probably see this message when you configure the stub feature.

      Rene

  24. Indeed the best EIGRP lab i have ever seen. I have completed all lab except this point

    [quote]The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect.[/quote]

    I know you can disable multicast on a specific link by defining EIGRP neighbours using "neighbour" command. However, everytime i define the neighbour statically, current EIGRP neighbourship flaps.

    Anyone have solution for this issue?

  25. Ok, I’m running into something that no one else seems to have mentioned but I don’t think is quite right.
    Walnut f3/0 (192.168.54.4) is connected to Lyptus f1/0 (192.168.45.5)
    Walnut f2/0 (192.168.45.4) is connected to Lyptus f0/0 (192.168.54.5)
    This is in the actual configuration that I have, but the instructions say that all IPv4 addresses have been configured for me. Are we allowed to reconfigure in the instance that the subnets do not match or am I supposed to be working around this somehow that I’m just not aware of? For the purpose of moving on, I’ve reconfigured to:
    Walnut f3/0 (192.168.54.4) to Lyptus f1/0 (192.168.54.5)
    Walnut f2/0 (192.168.45.4) to Lyptus f0/0 (192.168.45.5)
    but if this is not the way it was intended, I will reconfigure and do my best to figure it out.

    Also, thanks for these GREAT labs!!

  26. Hey,
    What about “•The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect.
    “?

    Should it be done with ACLs denying class D?
    Best Regards,
    mrcl87

    1. Basically it just means you have to make sure EIGRP will use unicast 🙂 That’s it. No need to really filter out multicast traffic.

      1. Ok, so it is meant as a, "Make sure that the adjacency doesn’t drop when the link stops accepting multicast" rather than a "Make sure the link doesn’t drop when you make the configuration change" type of goal?

  27. Hallo Mr Rene

    I think there is missconfigured ip in Lyptus

    We must change the configuration between fa0/0 and fa1/0
    I don’t know if this is just a test but in topology that i already download, int se0/0 on Alder still on shut state 😀

      1. Hello Rene,
        You seem to have all the answers here so I hope you can help me. I cannot even get the lab to open in GNS3.

        Could not find local server /Volumes/GNS3/GNS3.app/Contents/MacOS/server/Contents/MacOS/gns3server

        Can you tell me what I’m missing or where I can look for a solution?

        Jason Procell
        CCNA, CCNA Voice, ITILv3

  28. “Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity.”

    How can we resolve it without breaking adjacency ?

    If i configure eigrp stub on Lyptus ajacencies will result in drop.

  29. "Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity."

    Can someone please help me with this one?

  30. Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    I think using maximum-paths 1 to accomplish this task is the better choice than using distribute-list, since for example, if one of the two links fail, then Walnut cannot use the other link to reach Lyptus’s loopback, while using maximum-paths 1 makes this possible

  31. Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.
    i configured maximum path as 1 but dont think that is the solution cos firstly max-path is a router subcommand and both routes are directly connected routes and not eigrp routes, thus to alter how they appear on the routing table one would have to alter say the administrative distance, which dont seem doable, pleas any ideas , they would be welcome

    1. Since we want the adjacency to remain between the two on the unused link, think about using route filtering methods to approach this.

  32. looking for the ios…….tried cisco cant find exact match also i dont have the required entitlement. Any ideas

  33. I have trouble with two objectives:

    1. Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity.

    I used the ‘eigrp stub connected’ command, but that broke the neighbor adjacency…

    2. The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect.

    I used the ‘neighbor 192.168.13.1 s1/0’ on Alder and ‘neighbor 192.168.13.3 s0/0’ on Maple, but that also broke the neighbor adjacency…

    Can anyone point me in the right direction ?

    Thanks,
    Luke

  34. Hi,

    Please advise regarding point:

    – Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    Please see setup below:

    !
    ip sla monitor 11
    type echo protocol ipIcmpEcho 192.168.45.5
    frequency 5
    ip sla monitor schedule 11 life forever start-time now
    ip sla monitor 12
    type echo protocol ipIcmpEcho 192.168.54.5
    frequency 5
    ip sla monitor schedule 12 life forever start-time now
    !
    track 1 rtr 11
    delay down 5 up 1
    !
    track 2 rtr 12
    delay down 5 up 1
    !
    interface FastEthernet0/0
    ip address 192.168.24.4 255.255.255.0
    ip policy route-map IP_SLA
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.34.4 255.255.255.0
    ip policy route-map IP_SLA
    duplex auto
    speed auto
    !
    route-map IP_SLA permit 10
    set ip next-hop verify-availability 192.168.45.5 10 track 1
    set ip next-hop verify-availability 192.168.54.5 20 track 2
    !
    ip route 0.0.0.0 0.0.0.0 FastEthernet3/0
    ip route 0.0.0.0 0.0.0.0 FastEthernet2/0
    !

    Therefore default route trough FastEthernet3/0 will be chosen first, in the case of failure route trough FastEthernet2/0 will be used – based on the factor:

    Sequence to insert into next-hop list

    route-map IP_SLA has been inserted into FastEthernet3/0 and FastEthernet2/0.

    Please let me know if you agree on the configuration, or maybe better solution can be use in order to get resiliency as well.

    Regards,
    Jarek

  35. – Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    Using PBR is definitely one solution.
    Also i think simple summary route on one of Lyptus interfaces will do, because router Walnut will use more specific route in its routing table to get to 5.5.5.5

    Lyptus(config-if)#ip summary-address eigrp 1 5.0.0.0 255.0.0.0

    Walnut(config)#do sh ip route
    D 5.5.5.0/24 [90/156160] via 192.168.45.5, 00:00:28, FastEthernet2/0
    D 5.0.0.0/8 [90/156160] via 192.168.54.5, 00:00:28, FastEthernet3/0

    I super curious about Rene’s solution to this.

    P.

  36. Next solution could be using maximum-paths 1 on router Walnut.
    Perhaps even better.

    [quote=jpajicek]- Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics.

    Using PBR is definitely one solution.
    Also i think simple summary route on one of Lyptus interfaces will do, because router Walnut will use more specific route in its routing table to get to 5.5.5.5

    Lyptus(config-if)#ip summary-address eigrp 1 5.0.0.0 255.0.0.0

    Walnut(config)#do sh ip route
    D 5.5.5.0/24 [90/156160] via 192.168.45.5, 00:00:28, FastEthernet2/0
    D 5.0.0.0/8 [90/156160] via 192.168.54.5, 00:00:28, FastEthernet3/0

    I super curious about Rene’s solution to this.

    P.[/quote]

    1. Hi jpajicek,

      Actually your solution is much simpler and we are getting requiment needed in the lab.
      If you set the maximum-path to 1, you disable load balancing and when I shuted down 192.168.45.5 (FastEthernet2/0) on Lyptus:

      Walnut(config-router)#do sh ip ro
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      [color=green] 5.0.0.0/24 is subnetted, 1 subnets
      D 5.5.5.0 [90/612] via 192.168.45.5, 00 : 01 :38, FastEthernet2/0[/color]

      Walnut(config-router)#
      [color=blue]*Mar 1 01:32:59.159: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.45.5 (FastEthernet2/0) is down: holding time expired[/color]
      Walnut(config-router)#do sh ip ro
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      [color=green] 5.0.0.0/24 is subnetted, 1 subnets
      D 5.5.5.0 [90/612] via 192.168.54.5, 00: 00 : 06, FastEthernet3/0[/color]

      We can see that 5.5.5.5 is reachable trough FastEthernet3/0.

      Thx for sharing the solution 🙂
      My way was much more complex and time consuming.

      Regards,
      Jarek

  37. dear rene

    still waiting for the final solution and video for this lab ,, you are kindly requested to take out time from your busy schedule ,,,
    looking forward to your kind favor

    kind regards

  38. Hi GUys,

    What is the best solution for this task and how to verify that this router shouldn’t received query packets?

    Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity.

    Thanks and Regards,

    Ben

    1. i believe if u made Walnut as a EIGRP Stub Receive only ill not send queries to lyptus, and in that case lyptus will recieve no query, but still i think it will break the network

  39. Finally I finished this, it took me like 2 hours but done except one question

    [color=red]Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not
    to break connectivity.[/color]

    Here is the configuration for all routers
    __________________________________________________
    [b]Alder#s[/b]
    Building configuration…
    Current configuration : 1313 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Alder
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
    bandwidth 775
    ip address 192.168.12.1 255.255.255.0
    ip bandwidth-percent eigrp 1 25
    duplex auto
    speed auto
    !
    interface Serial1/0
    ip address 192.168.13.1 255.255.255.0
    ip bandwidth-percent eigrp 1 25
    serial restart-delay 0
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    variance 2
    passive-interface Loopback0
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    neighbor 192.168.13.3 Serial1/0
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    __________________________________________________
    [b]Cherry#s[/b]
    Building configuration…

    Current configuration : 1167 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Cherry
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    key chain GNS3VAULT
    key 1
    key-string WOOD
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface FastEthernet0/0
    bandwidth 775
    ip address 192.168.12.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.24.2 255.255.255.0
    ip authentication mode eigrp 1 md5
    ip authentication key-chain eigrp 1 GNS3VAULT
    duplex auto
    speed auto
    !
    router eigrp 1
    redistribute static
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    !
    ip http server
    no ip http secure-server
    ip route 100.100.100.100 255.255.255.255 Null0
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec sir show ip route
    alias exec n show cdp ne
    alias exec sri show runn inter
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    __________________________________________________
    [b]Maple#s[/b]
    Building configuration…

    Current configuration : 1296 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Maple
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.13.3 255.255.255.0
    serial restart-delay 0
    !
    interface Serial0/1
    ip address 192.168.33.3 255.255.255.0
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface FastEthernet1/0
    ip address 192.168.34.3 255.255.255.0
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    neighbor 192.168.13.1 Serial0/0
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    __________________________________________________
    [b]Walnut#s[/b]
    Building configuration…

    Current configuration : 1579 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Walnut
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    key chain GNS3VAULT
    key 1
    key-string WOOD
    !
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.24.4 255.255.255.0
    ip authentication mode eigrp 1 md5
    ip authentication key-chain eigrp 1 GNS3VAULT
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.34.4 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet2/0
    ip address 192.168.54.4 255.255.255.0
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51
    duplex auto
    speed auto
    !
    interface FastEthernet3/0
    ip address 192.168.45.4 255.255.255.0
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    maximum-paths 1
    no auto-summary
    eigrp stub connected static summary redistributed leak-map DENY_L0_LYPTUS
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    access-list 1 deny 5.5.5.0 0.0.0.255
    access-list 1 permit any
    !
    route-map DENY_L0_LYPTUS permit 10
    match ip address 1
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    __________________________________________________
    [b]Lyptus(config)#do s[/b]
    Building configuration…

    Current configuration : 983 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Lyptus
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    interface Loopback0
    ip address 5.5.5.5 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.54.5 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.45.5 255.255.255.0
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    eigrp stub connected summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    _________________________________________________
    [b]Pine(config)#do s[/b]
    Building configuration…

    Current configuration : 1119 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Pine
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    interface Loopback0
    ip address 6.6.6.6 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.33.6 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.33.7 603
    !
    interface Serial0/1
    no ip address
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    _________________________________________________
    [b]Oak(config)#do s[/b]
    Building configuration…

    Current configuration : 1118 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Oak
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    interface Loopback0
    ip address 7.7.7.7 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.33.7 255.255.255.0
    encapsulation frame-relay
    serial restart-delay 0
    frame-relay map ip 192.168.33.6 703
    !
    interface Serial0/1
    no ip address
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 1 0
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show runn
    alias exec si show int
    alias exec siib show ip int bri
    alias exec n show cdp ne
    alias exec sri show runn inter
    alias exec sir show ip route
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    !
    End
    __________________________________________________
    Hopefully if this can help someone
    __________________________________________________
    BEKO

    1. the Frame relay Config is bad on Oak, maple & pine,

      Here the Request :
      Configure EIGRP on the frame relay network between router Maple, Pine and Oak. You have to configure EIGRP using the multipoint sub-interfaces.
      ** ( has to be Sub-interface multipoint)

  40. Hi!

    The summary route you just created should show up with an administrative distance of 51 on router Walnut.

    If i set ip summ eigrp 1 0.0.0.0 248.0.0.0 51 on walnut’s f2/0 and f3/0 then lyptus routung table will be empty (except conencted interfaces)

    The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect.

    Please! I need some ideas or advice!

    1. [b] Maple:[/b]
      router eigrp 1
      neighbor 192.168.33.7 Serial0/1
      neighbor 192.168.33.6 Serial0/1

      [b]Oak:[/b]
      router eigrp 1
      neighbor 192.168.33.3 Serial0/0

      [b]Pine[/b]:
      router eigrp 1
      neighbor 192.168.33.3 Serial0/0

  41. Rene, thank you for the labs, great stuff.

    Maybe someone will be able to answer my two questions.

    1. metric weights 0 1 0 1 1 0 (from beko’s confs) is this correct? Looking at metric = [K1 * bandwidth + (K2 * bandwidth) / (256 – load) + K3 * delay] * [K5 / (reliability + K4)] you need K5=1 to have reliability included in the calculation.
    2. How to distribute default route via EIGRP? Eigrp command network 0.0.0.0 will include all interfaces, all networks What if requirements do not allow this? passive-int, distribute-list… lot of work to filter it out. Is the any other way to redistribute default? Redistribute static or maybe default-network?

    1. Found a solution for default route distribution
      ip summary address 0.0.0.0 0.0.0.0
      Well, you got to set it on all the interfaces…

    2. ip route 0.0.0.0 0.0.0.0 null 0 254

      router eigrp 1
      redistribute static metric 100000 100 255 1 1500

  42. good lab. try to solve it, i hope we can find video solution for this LAB. Thanks for your effort

  43. * Make sure router Alder will use the serial 1/0 interface as the primary link. – [b]manipulate with bandiwdth and delay on s1/0[/b]

    * Make sure the FastEthernet0/0 interface on router Alder is a feasible successor and visible in the routing table for unequal load-balancing. – [b]variance[/b]

    * uter Walnut should send a summary route towards router Lyptus which only includes the loopback0 interfaces of router Alder, Cherry, Maple and Walnut. The summary route has to be as specific as possible – [b]summ adr 0.0.0.0 248.0.0.0 with LEAK-MAP to advertise specific routes to Oak and Pine loopbacks[/b]

    * Ensure only one path is used between router Walnut and Lyptus without breaking the EIGRP neighbor adjacency. You are not allowed to change the metrics. – [b]route-map DENYALL in in Lyptus on f0/0 or f1/0[/b]

    * The summary route you just created should show up with an administrative distance of 51 on router Walnut. – [b]create summary address with AD 51. [/b]
    or…

    Walnut#show running-config interface fastEthernet 3/0 | include summary
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 52 leak-map LEAKMAP

    Walnut#show ip route | include FastEthernet3/0
    C 192.168.45.0/24 is directly connected, FastEthernet3/0
    D 5.5.5.0 [51/130816] via 192.168.45.5, 00:05:43, FastEthernet3/0
    D 0.0.0.0/5 [51/131072] via 192.168.45.5, 00:00:00, FastEthernet3/0

    AD 51 )

    Also great lab, Rene.

  44. Hi Rene,

    The lab is awe some!!

    I am posting the final configs, please give your feedback on it.

    ALder:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Alder
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.12.1 255.255.255.0
    delay 10000
    duplex auto
    speed auto
    !
    interface Serial1/0
    ip address 192.168.13.1 255.255.255.0
    ip bandwidth-percent eigrp 1 25
    serial restart-delay 0
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    variance 2
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    neighbor 192.168.13.3 Serial1/0
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    CHERRY:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Cherry
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    key chain GNS3VAULT
    key 1
    key-string WOOD
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.12.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.24.2 255.255.255.0
    ip authentication key-chain eigrp 1 GNSVAULT
    duplex auto
    speed auto
    !
    router eigrp 1
    redistribute static
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    !
    ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 Null0
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    MAPLE:

    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Maple
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface Serial0/0
    ip address 192.168.13.3 255.255.255.0
    serial restart-delay 0
    !
    interface Serial0/1
    no ip address
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    no frame-relay inverse-arp
    !
    interface Serial0/1.1 multipoint
    ip address 192.168.33.3 255.255.255.0
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.33.6 306
    frame-relay map ip 192.168.33.7 307
    no frame-relay inverse-arp
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface FastEthernet1/0
    ip address 192.168.34.3 255.255.255.0
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    neighbor 192.168.13.1 Serial0/0
    neighbor 192.168.33.7 Serial0/1.1
    neighbor 192.168.33.6 Serial0/1.1
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    WALNUT:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Walnut
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    key chain GNS3VAULT
    key 1
    key-string WOOD
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.24.4 255.255.255.0
    ip authentication key-chain eigrp 1 GNSVAULT
    ip policy route-map TEST
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.34.4 255.255.255.0
    ip policy route-map TEST
    duplex auto
    speed auto
    !
    interface FastEthernet2/0
    ip address 192.168.45.4 255.255.255.0
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 52
    duplex auto
    speed auto
    !
    interface FastEthernet3/0
    ip address 192.168.54.4 255.255.255.0
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 52
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    distribute-list 10 out FastEthernet0/0
    distribute-list 10 out FastEthernet1/0
    no auto-summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    ip access-list extended TEST
    permit ip any any
    access-list 10 deny 5.0.0.0 0.255.255.255 log
    access-list 10 permit any
    access-list 11 permit any log
    access-list 101 permit ip 1.0.0.0 0.0.0.5 any
    !
    route-map TEST permit 10
    set ip next-hop 192.168.54.5
    !
    route-map eigrp permit 10
    match ip address 101
    set metric -39
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    LYPTUS:

    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Lyptus
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 5.5.5.5 255.255.255.0
    !
    interface Loopback1
    ip address 8.8.8.8 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.45.5 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 192.168.54.5 255.255.255.0
    duplex auto
    speed auto
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    eigrp stub connected summary
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    access-list 11 permit any log
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    Pine:

    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Pine
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 6.6.6.6 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    no frame-relay inverse-arp
    !
    interface Serial0/0.1 multipoint
    ip address 192.168.33.6 255.255.255.0
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.33.3 603
    frame-relay map ip 192.168.33.7 607
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    neighbor 192.168.33.7 Serial0/0.1
    neighbor 192.168.33.3 Serial0/0.1
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    OAK:

    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Oak
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 7.7.7.7 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    no ip split-horizon eigrp 1
    serial restart-delay 0
    no frame-relay inverse-arp
    !
    interface Serial0/0.1 multipoint
    ip address 192.168.33.7 255.255.255.0
    no ip split-horizon eigrp 1
    frame-relay map ip 192.168.33.3 703
    no frame-relay inverse-arp
    !
    interface Serial0/1
    no ip address
    serial restart-delay 0
    !
    interface Serial0/2
    no ip address
    shutdown
    serial restart-delay 0
    !
    interface Serial0/3
    no ip address
    shutdown
    serial restart-delay 0
    !
    router eigrp 1
    network 0.0.0.0
    metric weights 0 1 0 1 0 1
    no auto-summary
    neighbor 192.168.33.6 Serial0/0.1
    neighbor 192.168.33.3 Serial0/0.1
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end

    thank yo for the labs 🙂 🙂 🙂

  45. Looks, how i resolved the problem with AD:

    [code]access-list 20 permit 0.0.0.0 7.255.255.255

    router eigrp 1
    distance 51 192.168.0.0 0.0.255.255 20[/code]

    And The Resoult:

    Gateway of last resort is not set

    [code]D 192.168.12.0/24 [90/130] via 192.168.54.4, 00:01:16, FastEthernet0/0
    [90/130] via 192.168.45.4, 00:01:16, FastEthernet1/0
    D 192.168.13.0/24 [90/8496] via 192.168.54.4, 00:01:16, FastEthernet0/0
    [90/8496] via 192.168.45.4, 00:01:16, FastEthernet1/0
    C 192.168.45.0/24 is directly connected, FastEthernet1/0
    D 192.168.24.0/24 [90/120] via 192.168.54.4, 00:01:16, FastEthernet0/0
    [90/120] via 192.168.45.4, 00:01:16, FastEthernet1/0
    5.0.0.0/24 is subnetted, 1 subnets
    C 5.5.5.0 is directly connected, Loopback0
    C 192.168.54.0/24 is directly connected, FastEthernet0/0
    D 192.168.34.0/24 [90/120] via 192.168.54.4, 00:01:18, FastEthernet0/0
    [90/120] via 192.168.45.4, 00:01:18, FastEthernet1/0
    D 0.0.0.0/5 [51/610] via 192.168.54.4, 00:01:18, FastEthernet0/0
    [51/610] via 192.168.45.4, 00:01:18, FastEthernet1/0
    Lyptus#[/code]

    1. 1. There is problem with link between Walut – Lyptus.
      You will have IP looping on both interfaces, so you can change the interface type or change the network.

      You can accomplish the second using serial interfaces bundled together. Just create multilink, group that two interfaces together and give them common IP address.

      2. Somebody above asked about setting distance for loopback 5.5.5.0 network:

      -if)#ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51

      you can verify it using:
      #show ip route 5.5.5.0 248.0.0.0
      – there will be mentioned about summary distance 51.

      3. Cheers, thanks for lab, it was great fun doing it! 🙂

  46. There is a problem between router Walnut and router Lyptus links. When you configure EIGRP 1 no auto-summary you get messages like this on the routers

    *Mar 1 00:08:40.043: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.54.5 not on common subnet for FastEthernet2/0
    *Mar 1 00:08:54.107: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.45.5 not on common subnet for FastEthernet3/0
    *Mar 1 00:09:07.279: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.45.5 not on common subnet for FastEthernet3/0
    *Mar 1 00:09:17.711: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.54.5 not on common subnet for FastEthernet2/0
    *Mar 1 00:09:30.651: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.45.5 not on common subnet for FastEthernet3/0
    *Mar 1 00:09:44.839: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.54.5 not on common subnet for FastEthernet2/0
    *Mar 1 00:09:58.683: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.54.5 not on common subnet for FastEthernet2/0
    *Mar 1 00:10:12.591: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.54.5 not on common subnet for FastEthernet2/0
    *Mar 1 00:10:22.783: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.45.5 not on common subnet for FastEthernet3/0

    It’s because the interfaces on router walnut and lyptus are assigned wrong. Correct your ip addresses on router lyptus like below and you will be able to configure the lab. You basically just switch the ip address on the interfaces on router lyptus

    Lyptus#show ip int brief
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 192.168.45.5 YES manual up up
    FastEthernet1/0 192.168.54.5 YES manual up up
    Loopback0 5.5.5.5 YES NVRAM up up
    Lyptus#

    Once this is completed you should be good

    Lyptus#show ip int br
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 192.168.45.5 YES manual administratively down down
    FastEthernet1/0 192.168.54.5 YES manual administratively down down
    Loopback0 5.5.5.5 YES NVRAM up up
    Lyptus#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Lyptus(config)#int f0/0
    Lyptus(config-if)#no shut
    Lyptus(config-if)#
    *Mar 1 00:26:10.391: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.45.4 (FastEthernet0/0) is up: new adjacency
    *Mar 1 00:26:11.475: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
    *Mar 1 00:26:12.475: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    Lyptus(config-if)#int f1/0
    Lyptus(config-if)#no shut
    Lyptus(config-if)#
    *Mar 1 00:26:28.359: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
    *Mar 1 00:26:29.359: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
    *Mar 1 00:26:30.339: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.54.4 (FastEthernet1/0) is up: new adjacency
    Lyptus(config-if)#ping 192.168.12.2
    ^

    1. I’m working on this lab but want to clarify a few of the requirements.
      [i]
      Make sure router Alder will use the serial 1/0 interface as the primary link.

      Make sure the FastEthernet0/0 interface on router Alder is a feasible successor and visible in the routing table for unequal load-balancing.[/i]

      Is this asking for s0/1 to be the successor for all routes and for f0/0 to be the feasible successor for all routes? (Other than directly connected)

  47. Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity.

    How do we do this?

    if i config Lyptus as stub, it will break connectivity.

  48. Great lab. There is only 1 thing I can’t do completely, "Configure EIGRP on the frame relay network between router Maple, Pine and Oak. You have to configure EIGRP using the multipoint sub-interfaces. Advertise the loopback0 interfaces and ensure you have full reachability between the three routers."

    I configured frame realy and Maple, Oak, Pines have all connections. But the problem is I can’t access other router (i.e. Alder) from Pines and Oak, i also configured eigrp and metric weights the same as for all routers,. What must be done to solve this? Thank you!

    1. Hi, I think you have an issue with Split-horizon, a loop prevention mechanism enabled by default in Distance vector routing protocols. You would need to disable it on the link connecting Maple to the frame-relay switch using the command “no IP split-horizon”.

  49. hello everyone,
    i’m having trouble with changing the AD to 51.

    Walnut#show run | s eigrp
    **************************************************************
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51
    ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51
    **************************************************************
    But it still shows up as 90 in the routing table.
    **************************************************************
    D 192.168.12.0/24 [90/30720] via 192.168.24.2, 00:02:01, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    D 1.1.1.0 [90/158720] via 192.168.24.2, 00:31:16, FastEthernet0/0
    D 192.168.13.0/24 [90/2172416] via 192.168.34.3, 00:02:01, FastEthernet1/0
    2.0.0.0/24 is subnetted, 1 subnets
    D 2.2.2.0 [90/156160] via 192.168.24.2, 00:31:16, FastEthernet0/0
    3.0.0.0/24 is subnetted, 1 subnets
    D 3.3.3.0 [90/156160] via 192.168.34.3, 00:31:17, FastEthernet1/0
    C 192.168.45.0/24 is directly connected, FastEthernet3/0
    4.0.0.0/24 is subnetted, 1 subnets
    C 4.4.4.0 is directly connected, Loopback0
    C 192.168.24.0/24 is directly connected, FastEthernet0/0
    5.0.0.0/24 is subnetted, 1 subnets
    D 5.5.5.0 [90/156160] via 192.168.54.5, 00:02:08, FastEthernet2/0
    C 192.168.54.0/24 is directly connected, FastEthernet2/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0
    D 0.0.0.0/5 is a summary, 00:02:08, Null0
    I’m stumped someone please help.
    thanks Phil M.

  50. AWESOME LAB! This really tests your knowledge of EIGRP exactly like you need to know for CCNP. Thanks for coming up with all the little specifics like can’t modify certain values, or without dropping the adjacencies. It makes things interesting!

  51. Router Lyptus shouldn’t receive any query packets for lost networks. Configure this but make sure not to break connectivity ?

    how to configure
    anybody know
    thanks in advance 🙂
    My regards

    1. Enable stub connected on router Lyptus..in this way u will stay connected with lyptus and don’t get any query msg if any of network lost..

  52. enter your message here…[quote=mind_hunter]Enable stub connected on router Lyptus..in this way u will stay connected with lyptus and don’t get any query msg if any of network lost..[/quote]

    I don’t think that is the case :
    Lyptus(config-router)#eigrp stub connected summ
    Lyptus(config-router)#eigrp stub connected summary
    Lyptus(config-router)#
    *Mar 1 01:12:30.703: %DUAL-5-NBRCHANGE: IP-EIGRP0 1: Neighbor 192.168.45.4 (FastEthernet0/0 is down: peer info changed
    *Mar 1 01:12:30.723: %DUAL-5-NBRCHANGE: IP-EIGRP0 1: Neighbor 192.168.54.4 (FastEthernet1/0 is down: peer info changed
    *Mar 1 01:12:33.495: %DUAL-5-NBRCHANGE: IP-EIGRP0 1: Neighbor 192.168.54.4 (FastEthernet1/0 is up: new adjacency
    *Mar 1 01:12:33.743: %DUAL-5-NBRCHANGE: IP-EIGRP0 1: Neighbor 192.168.45.4 (FastEthernet0/0 ) is up: new adjacency

    I am yet to see how its done as every config posted shows setting lyptus as a stub so i am confused. Same as the multicast issue between Alder & Maple, each solution i have seen involves manualy configuring the peering which again breaks the neighbors when implemented.

  53. Did any one completed the lab and has a clear instructions on how to achieve this lab ?

    Your help is much appreciated

  54. Great Lab, i really enjoyed doing this 🙂
    but kinda confuse on this!!

    The serial link between router Alder and Maple will not allow multicast traffic in the future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this change takes effect ??

    any ideas Pals ?

    1. This is a late reply, but I’m just getting into this lab.

      Use neighbor commands to manually establish neighbor relationships for Alder and Maple.

      For Alder:

      neighbor 192.168.13.3 Serial 1/0

      For Maple:

      neighbor 192.168.13.1 Serial 0/0

      After that you can use access lists / distribution lists to block 224.0.0.10 traffic out of the serial interfaces, and the neighborships should stay up.

  55. Rene, i can do the video-solution for this, if it’s going to be ok, you will post it here:))))

  56. Hi,

    I tried to download the Configuration Lab which include the gns3 file and save it on my project, Opening the file has no problem, however, I am unable to console the devices, do I still need to modify something on the gns3 file to work it properly?

    Thanks and Regards

  57. Hi Rene,

    You r doing a wonderful job. I watched ur almost all lab video.But i didn’t find any video of EIGRP with DMVPN. m running with this error “retry limit exceeded “. I searched everywhere but didn’t get any solution, could u upload a lab on this.

  58. hello Rene ..

    I am preparing for my CCNP now and I am new here. Is there a place where I can find all CCNP labs and only? This lab is the only lab that is available under the CCNP category. Or do I need to do All that is available?

    Thank you

  59. Hi Rene,

    Thank you very much for being such an inspiration, I really enjoyed doing the lab, 99% complete except for one bullet.:
    The serial link between router Alder and Maple will not allow multicast traffic in the
    future. Make the changes so the EIGRP neighbor adjacency doesn’t drop when this
    change takes effect.
    How should i achieve this? I tried creating an ACL, a standard one, blocking the ip 224.0.0.10 and then I applied it in the inbound and outbound direction at s1/0 interface on router Alder. I also thought about using the said ACL in a distribution_list in my Eigrp process but to no avail.

    Thanks .

  60. Hello Mrs Rene Molenaar
    Thanks for The Labs Really Help
    Would You Please Give me a List which LABs is Appropriate in CCNP level?
    I Try Hard for be Mastered in Configuration But its Ambiguous about the Appropriate Labs .
    best Regard

  61. April 04,2015

    Mister Rene Molenaar,

    I tried to run the console in all the devices with the latest GNS3 1.3.0

    and I have this problem:

    Connected to Dynamips V
    Press ENTER to get the

    I have pressed Enter in each of the routers, since I am running superputty, I have the 7 tabs (routers):
    Alder,
    Cherry,
    Lyptus,
    Maple ,
    Oak,
    Pine,
    Walnut;

    and the same behavior ( the consoles do not run).

    Please provide a solution.

    Thank you very much in advance for your help!

    Regards,

    Adolfo

Comments are closed.