Static Routing Beginners Lab


Scenario:

You are working as a networking specialist at a company called “Networks4All”. One of their customers has 2 dedicated links to connect their New York site to the Washington site. You are not allowed to use routing protocols because they are paying for every single bit that’s sent on these links. You need to do use static routing to get the job done and keep the customer happy.

Goal:

  • All IP addresses are preconfigured as shown in the topology picture.
  • There is a Loopback0 interface on the Washington router: IP Address 2.2.2.2/30.
  • There is a Loopback0 interface on the New York router: IP Address 1.1.1.1/30.
  • New York: create a static route pointing to the Loopback0 network on Washington, traffic should pass the 192.168.1.0 network.
  • Washington: create a default route pointing to the Loopback0 network on New York, traffic should pass the 192.168.2.0 network. In the routing table you should see a 0.0.0.0 entry.
  • New York: create a backup static route pointing to the Loopback0 network on Washington, administrative distance should be 100.
  • Washington: change the default route so it stays in the routing table even when the interface goes down.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the protocols for CCNA.

Would you like to be a master of networking too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of CCNA.

You will learn all the secrets about switching, routing, subnetting and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNA!

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

Static Routing Network Topology

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

34 Comments

  1. Hi I just wanted some feed back on my config since I can’t find solution to this lab:

    [b]New York:[/b]
    interface Loopback2
    ip address 1.1.1.1 255.255.255.252

    interface Serial0/0
    ip address 192.168.1.1 255.255.255.252
    !
    interface Serial0/1
    ip address 192.168.2.1 255.255.255.252
    !
    ip route 2.2.2.0 255.255.255.252 Serial0/0
    ip route 2.2.2.0 255.255.255.252 Serial0/1 100

    routing table

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback2
    2.0.0.0/30 is subnetted, 1 subnets
    S 2.2.2.0 is directly connected, Serial0/0
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.0 is directly connected, Serial0/0
    192.168.2.0/30 is subnetted, 1 subnets
    C 192.168.2.0 is directly connected, Serial0/1

    [b]Washington:[/b]
    interface Loopback1
    ip address 2.2.2.2 255.255.255.252
    interface Serial0/0
    ip address 192.168.1.2 255.255.255.252
    !
    interface Serial0/1
    ip address 192.168.2.2 255.255.255.252
    !
    ip route 0.0.0.0 0.0.0.0 Serial0/1

    routing table:

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    2.0.0.0/30 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Loopback1
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.0 is directly connected, Serial0/0
    192.168.2.0/30 is subnetted, 1 subnets
    C 192.168.2.0 is directly connected, Serial0/1
    S* 0.0.0.0/0 is directly connected, Serial0/1

  2. The config looks fine. There’s one thing left you could try:

    When the interface goes down the entry will be removed from the routing tabe. If you add the “permanent” command after the static route it will stay there even if the interface goes down.

  3. Good Site: I will try to configure labs by my style and need your comments.

    [b][u]Washington[/u][/b]

    interface Loopback0
    ip address 2.2.2.2 255.255.255.252

    !
    interface Serial0/0
    ip address 192.168.1.2 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/1
    ip address 192.168.2.2 255.255.255.252
    clock rate 2000000
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.2.1 permanent
    !

    [u][b]NewYork[/b][/u]

    interface Loopback0
    ip address 1.1.1.1 255.255.255.252
    !
    interface Serial0/0
    ip address 192.168.1.1 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/1
    ip address 192.168.2.1 255.255.255.252
    clock rate 2000000
    !
    ip forward-protocol nd
    ip route 2.2.2.0 255.255.255.252 192.168.1.2
    ip route 2.2.2.0 255.255.255.252 192.168.2.2 100
    !
    !

    NEWYORK(config)#do sh ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    2.0.0.0/30 is subnetted, 1 subnets
    S 2.2.2.0 [1/0] via 192.168.1.2
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.0 is directly connected, Serial0/0
    192.168.2.0/30 is subnetted, 1 subnets
    C 192.168.2.0 is directly connected, Serial0/1

    NEWYORK(config)#do ping 2.2.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/28 ms
    NEWYORK(config)#

  4. [b][color=red]Washington[/color][/b][u][/u]

    interface Loopback2
    ip address 2.2.2.2 255.255.255.252
    !
    interface Serial0/0
    ip address 192.168.1.2 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/1
    ip address 192.168.2.2 255.255.255.252
    clock rate 2000000
    !
    ip route 0.0.0.0 0.0.0.0 Serial0/1
    ip route 0.0.0.0 0.0.0.0 192.168.1.1 permanent
    !
    Gateway of last resort is 192.168.1.1 to network 0.0.0.0

    2.0.0.0/30 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, Loopback2
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.0 is directly connected, Serial0/0
    192.168.2.0/30 is subnetted, 1 subnets
    C 192.168.2.0 is directly connected, Serial0/1
    S* 0.0.0.0/0 [1/0] via 192.168.1.1
    is directly connected, Serial0/1

    [b][color=blue]NewYork[/color][/b][u][/u]

    interface Loopback1
    ip address 1.1.1.1 255.255.255.252
    !
    interface Serial0/0
    ip address 192.168.1.1 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/1
    ip address 192.168.2.1 255.255.255.252
    clock rate 2000000
    !
    ip route 2.2.2.0 255.255.255.252 Serial0/0
    ip route 2.2.2.0 255.255.255.252 Serial0/1 100 permanent
    !

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback1
    2.0.0.0/30 is subnetted, 1 subnets
    S 2.2.2.0 is directly connected, Serial0/0
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.0 is directly connected, Serial0/0
    192.168.2.0/30 is subnetted, 1 subnets
    C 192.168.2.0 is directly connected, Serial0/1

  5. Hi,
    Would you please tell me which IOS have to use for this LAB, because i have downloaded the mentioned IOS c3640-jk9s-mz.124-16.bin, its not woring with any of LAB

    So please give me solution

  6. Hello Rene,

    Can you please clarify this doubt.?

    Let’s say we add a word "Permanent" at the end of ip route. I agree, that entry will be there in routing table even if interface down.

    But the question here is that, when interface is down, what’s the point in having an entry in the table which is anyway not going to push the traffic.

    Is this concept used for someother purpose?

    1. When the route is not available, it fails over to the secondary route even with the permanent entry. Once the link is restored, the route is reestablished automatically because it was set as a perm route.

      I hope that makes sense.

  7. Great Site!
    I notice that in the loopback assignment you used a subnet mask of 255.255.255.252 (/30). Isn’t best practice to use a classful address?

    Thanks,

    Carlos

  8. I like the concept of the site and I appreciate all the hard work you have put into it, but it’s obvious that in this lab that there was some pre-configuration done before the video begins. If a person just follows the steps in the video, the same results are not possible (at least not in the order they were presented). This really is not for beginners.

    Additionally, when explaining how to add the backup route (with administrative distance of 100) at 3: 00, there is never any explanation of how to verify that it actually exists. In fact, at 3:54 it is stated, [i]”If you do ‘show ip route’ you won’t see it…”[/i]

    Thanks!

    1. Hi !… you can check the backup static route if turn-off the interface 192.168.1.2 in Washington and verify the static routes in NewYork.

      NewYork#sh ip ro
      Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
      D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
      N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
      E1 – OSPF external type 1, E2 – OSPF external type 2
      i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
      ia – IS-IS inter area, * – candidate default, U – per-user static route
      o – ODR, P – periodic downloaded static route

      Gateway of last resort is not set

      1.0.0.0/30 is subnetted, 1 subnets
      C 1.1.1.0 is directly connected, Loopback0
      2.0.0.0/30 is subnetted, 1 subnets
      S 2.2.2.0 [100/0] via 192.168.2.2
      C 192.168.2.0/24 is directly connected, Serial0/1
      NewYork#

  9. Random question.

    When watching the video the mask put in was 255.255.255.0 (/24) for all of the routes. In the instructions it showed the mask as /30. On routes does it matter? I think it would because of the broadcast address, but just wanted to get a second opinion.

  10. Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    2.0.0.0/24 is subnetted, 1 subnets
    S 2.2.2.0 [[b]1[/b]/0] via 192.168.1.2, Serial0/0
    C 192.168.1.0/24 is directly connected, Serial0/0
    C 192.168.2.0/24 is directly connected, Serial0/1

    NewYork#sh run | s ip route

    ip route 2.2.2.0 255.255.255.0 Serial0/0 192.168.1.2
    ip route 2.2.2.0 255.255.255.0 Serial0/1 192.168.2.2 100

    when interface Serial0/0 is shutdown:::
    the routing table looks like::::

    *Mar 1 00:10:10.235: %LINK-5-CHANGED: Interface Serial0/0, changed state to administratively down
    *Mar 1 00:10:11.235: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to downdo
    % Incomplete command.

    NewYork(config-if)#do sh ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    1.0.0.0/30 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    2.0.0.0/24 is subnetted, 1 subnets
    S 2.2.2.0 [[b]100[/b]/0] via 192.168.2.2, Serial0/1
    C 192.168.2.0/24 is directly connected, Serial0/1
    NewYork(config-if)#

    [b]Washington[/b](config)#do sh run | s ip route
    ip route 0.0.0.0 0.0.0.0 Serial0/1 192.168.2.1 [b]permanent[/b]
    Washington(config)#

    Any suggestions

  11. I started my Lab practice here on GNS3.

    Thanks Rene for sharing the LAB

    …….. & all other friends in the discussion…it is informative

    —-Pravin

  12. First off, I wanted to say that I love these labs. They are challenging enough to make you think outside of the ordinary box. Great job on making these and thanks for making them available!

    I have two questions:

    (1) The way that I understand your solution is that there is no need for a routing protocol because the two subinterfaces are sharing the same MAC address, so the router gets two separate ARP entries for its same MAC. This allows it to translate between two Layer 3 IPs without having to change the source Layer 2 address, because changing the source Layer 2 address (on a router) for packets it transmits means putting it in a different broadcast domain. Is this a correct understanding?

    (2) I don’t understand why you can specify the encapsulation type on the subinterface and not on the physical interface. I unsuccessfully attempted to do this lab by creating a secondary IP address on the physical interface instead of creating a subinterface. On the physical interface I have either the option of enabling switchport mode trunk (which disables adding an IP address) or I can disable switchport to enable adding an IP. I don’t have the option of doing both as on the subinterface. Is there a logical reason behind why I can’t specify the encapsulation type on the physical interface itself so I can trunk in both VLANs?

    Thanks!

  13. I’m upgraded to the latest version of GNS3, why won’t the labs download to mines.

    1. You can’t download or can’t open them? I just checked and this file is working for me.

  14. I’ve noticed in my test even with the permanent keyword, if the interface is shut the default route is no longer in the routing table. Can someone confirm this for me pls.

  15. Why are most the labs pre-configured already? What is the point of understand these labs if almost everything is already pre-configured?

    1. never mind I will just use show startup-config and show running-config and copy each code and try to do this lab without the pre-config files. I can understand it can be time consuming to keep showing the first steps.

    2. You nailed it. Rene likes to get to straight to the point. I, on the other hand, like to start from ground zero always. It builds speed in setting up the basics.

  16. Cheers Rene,
    running my first lab on a fresh installed GNS3 1.2.3 windows XP machine with a web downloaded IOS image, it went like a train, thanks for your work.
    Just decided to go for the CCNP route exam even I noticed the CCNA knowledge I had one year ago is far away lost in space ( I do not work in networking, I’m more in optical and legacy transmission domain).

    Maybe it sounds like mission impossible 5 ( 4 was the last one?) but with your quality work and thanks god the new GNS3 that seems to be wonderfull and stable enough, I hope that I will be able somehow in september ( or maybe june?) to have the gut and pass the exam

    My gratitude and regards from Zoetermeer NL

Comments are closed.