RIP EIGRP Redistribution Route Tagging

Scenario:

The Australia Zoo has hired you as a crocodile hunter network engineer responsible for all bits & bytes in the zoo. As an experiment the zoo decided to have the kangaroos and dolphins around the same lake to study the interaction between the animals. Both departments need to have access to each other’s data which means you’ll have to exchange routing information. To make sure there is no single point of failure you will use router Lassie and Willy to configure two-way redistribution. This however will also introduce new problems like routing loops or sub-optimal routing, it’s up to you to enable redistribution and solve any problems along the way…

Goal:

  • All IP addresses have been preconfigured for you.
  • RIP and EIGRP have been preconfigred for you on the corresponding routers.
  • Enable two-way redistribution between RIP and EIGRP on router Lassie and Willy.
  • You notice that router Willy or Lassie are sending traffic to 4.4.4.4 towards router Flipper, make sure you get rid of this sub-optimal routing.
  • Use route tagging to accomplish this.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the routing protocols for CCNP.

Would you like to be a master of routing too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of routing.

You will learn all the secrets about redisitribution between RIP and EIGRP, sub-optimal routing, route tags and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP ROUTE

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

Redistribution Route Tagging

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

72 Comments

  1. Hi Rene
    I got stuck in doing this. Can some one let me know the configuration for this

    Thanks
    Peter

  2. I got stuck in doing this as well. Can some one let the final configuration.

    Thanks in advance.

    Mehdi.

  3. Hi Guys,

    I assume you know how to do redistribution so i’ll keep it short to the route tagging part.

    In this scenario we have “two-way redistribution” and we want to make sure prefixes from one routing protocol are not advertised again into the same routing protocol.

    [u][b]Example[/b][/u]: network 4.4.4.0 will be redistributed INTO RIP at router Lassie. The redistributed network 4.4.4.0 will be redistributed AGAIN into EIGRP at router Willy.

    If we put a tag on the redistributed prefixes than we can make sure they won’t be redistributed again.8)

    Here we go:

    [b]When you configure redistribution you specify a route-map.[/b]

    router rip
    redistribute eigrp 234 metric 2 route-map EIGRP2RIP

    router eigrp 234
    redistribute rip route-map RIP2EIGRP metric 1 1 1 1 1

    [b]When we find a prefix that is tagged with “88” we don’t redistribute it[/b]

    route-map EIGRP2RIP deny 10
    match tag 88

    [b]When we redistribute we tag the prefix with “77”. [/b]

    route-map EIGRP2RIP permit 20
    set tag 77

    route-map RIP2EIGRP deny 10
    match tag 77

    route-map RIP2EIGRP permit 20
    set tag 88

    [b]So if we see something that is tagged we don’t redistribute it, otherwise we tag it and redistribute it.[/b]

    Does this make sense? good luck!

    Rene

    1. this is correct , but we have another problem , route 4.4.4.4 will be redistributed to rip with AD of 120 and routers willys and lassie will prefer that over the AD of 170 of eigrp, so we need to fix that also

        1. Applying on TAGS got me the correct route…Both Routers Lassie and Willey going towards router Skippy for loopback 4 and yes that loopback is redistributed into EIGRP.
          Following is my config

          TAG Set for RIP Routes: 100
          TAG Set for EIGRP Routes: 50

          Skippy:
          ———
          show run | sec eigrp|route-map|access-list
          router eigrp 234
          redistribute connected metric 10000 10 255 1 1500 route-map REDIST_CONN
          network 192.168.24.4 0.0.0.0
          network 192.168.34.4 0.0.0.0
          no auto-summary
          access-list 1 permit 4.4.4.4
          route-map REDIST_CONN permit 10
          match ip address 1

          Lassie:
          ———
          R2#show run | sec eigrp|route-map|rip
          router eigrp 234
          redistribute rip metric 10000 10 255 1 1500 route-map RIP->EIGRP
          network 192.168.24.2 0.0.0.0
          no auto-summary
          router rip
          version 2
          redistribute eigrp 234 metric 5 route-map EIGRP->RIP
          network 192.168.12.0
          no auto-summary
          route-map RIP->EIGRP deny 10
          match tag 50
          route-map RIP->EIGRP permit 20
          set tag 100
          route-map EIGRP->RIP deny 10
          match tag 100
          route-map EIGRP->RIP permit 20
          set tag 50

          Willey:
          ———
          R3#show run | sec eigrp|route-map|rip
          router eigrp 234
          redistribute rip metric 10000 10 255 1 1500 route-map RIP->EIGRP
          network 192.168.34.3 0.0.0.0
          no auto-summary
          redistribute eigrp 234 metric 5 route-map EIGRP->RIP
          route-map RIP->EIGRP deny 10
          match tag 50
          route-map RIP->EIGRP permit 20
          set tag 100
          route-map EIGRP->RIP deny 10
          match tag 100
          route-map EIGRP->RIP permit 20
          set tag 50
          ————-
          Verification that correct tag is received for route 4.4.4.4 at router Flipper
          R1#show ip route 4.4.4.4
          Routing entry for 4.4.4.4/32
          Known via “rip”, distance 120, metric 5
          Tag 50
          Redistributing via rip
          Last update from 192.168.12.2 on FastEthernet0/0, 00:00:05 ago
          Routing Descriptor Blocks:
          * 192.168.12.2, from 192.168.12.2, 00:00:05 ago, via FastEthernet0/0
          Route metric is 5, traffic share count is 1
          Route tag 50

          Verification that correct tag is received for route 1.1.1.1 at router Skippy

          R4#show ip route 1.1.1.1
          Routing entry for 1.1.1.1/32
          Known via “eigrp 234”, distance 170, metric 284160
          Tag 100, type external
          Redistributing via eigrp 234
          Last update from 192.168.24.2 on FastEthernet0/0, 00:02:56 ago
          Routing Descriptor Blocks:
          * 192.168.24.2, from 192.168.24.2, 00:02:56 ago, via FastEthernet0/0
          Route metric is 284160, traffic share count is 1
          Total delay is 1100 microseconds, minimum bandwidth is 10000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1
          Route tag 100

          R4#
          R4#
          R4#show ip eigrp topolo
          R4#show ip eigrp topology 1.1.1.1 255.255.255.255
          IP-EIGRP (AS 234): Topology entry for 1.1.1.1/32
          State is Passive, Query origin flag is 1, 1 Successor(s), FD is 284160
          Routing Descriptor Blocks:
          192.168.24.2 (FastEthernet0/0), from 192.168.24.2, Send flag is 0x0
          Composite metric is (284160/258560), Route is External
          Vector metric:
          Minimum bandwidth is 10000 Kbit
          Total delay is 1100 microseconds
          Reliability is 255/255
          Load is 1/255
          Minimum MTU is 1500
          Hop count is 1
          External data:
          Originating router is 192.168.24.2
          AS number of route is 0
          External protocol is RIP, external metric is 1
          Administrator tag is 100 (0x00000064)

          TRACES from both Routers as desired:
          Lassie:
          R2#trace 4.4.4.4

          Type escape sequence to abort.
          Tracing the route to 4.4.4.4

          1 192.168.24.4 320 msec 176 msec 248 msec

          Willy:

          R3#trace 4.4.4.4

          Type escape sequence to abort.
          Tracing the route to 4.4.4.4

          1 192.168.34.4 380 msec 156 msec 584 msec

          1. People.

            In reference to Khizer’s configurations, it’s really interesting that you achieve the solution. We have a route tag set 50 to EIGRP->RIP configured on router LASSIE. So, the same route gets on the Willy and then the tag 50 will match and block it just to redistribution, but will be included in the routing table of Willy router.

            In my opinion, not makes sense.

  4. I have configured 2-way redistribution without route maps but I don’t see the routing loops (all my pings are successful from skippy to flipper and from flipper to skippy).

    My config on Lassie (same redistribution commands on Willie):
    router eigrp 234
    redistribute rip metric 1 1 1 1 1
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 2
    network 192.168.12.0
    no auto-summary

    And routing tables:
    Skippy#sh ip route | b Gate
    Gateway of last resort is not set

    D EX 192.168.12.0/24
    [170/2560002816] via 192.168.34.3, 00:02:10, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:02:10, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    D EX 1.1.1.0 [170/2560002816] via 192.168.34.3, 00:02:10, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:02:10, FastEthernet0/0
    D EX 192.168.13.0/24
    [170/2560002816] via 192.168.34.3, 00:02:10, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:02:10, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    C 4.4.4.0 is directly connected, Loopback0
    C 192.168.24.0/24 is directly connected, FastEthernet0/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    Flipper#sh ip route | b Gate
    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    C 192.168.13.0/24 is directly connected, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    R 4.4.4.0 [120/2] via 192.168.13.3, 00:00:20, FastEthernet1/0
    [120/2] via 192.168.12.2, 00:00:02, FastEthernet0/0
    R 192.168.24.0/24 [120/2] via 192.168.13.3, 00:00:20, FastEthernet1/0
    [120/2] via 192.168.12.2, 00:00:02, FastEthernet0/0
    R 192.168.34.0/24 [120/2] via 192.168.13.3, 00:00:20, FastEthernet1/0
    [120/2] via 192.168.12.2, 00:00:02, FastEther

    Willy#sh ip route | b Gate
    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:02, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.13.1, 00:00:02, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D 4.4.4.0 [90/156160] via 192.168.34.4, 00:02:40, FastEthernet1/0
    D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:02:40, FastEthernet1/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    Lassie#sh ip route | b Gate
    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:10, FastEthernet0/0
    R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:10, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D 4.4.4.0 [90/156160] via 192.168.24.4, 01:18:04, FastEthernet1/0
    C 192.168.24.0/24 is directly connected, FastEthernet1/0
    D 192.168.34.0/24 [90/30720] via 192.168.24.4, 01:18:04, FastEthernet1/0

    Beside suboptimal paths for the 192.168.X.Y (load-balanced equal cost paths), I don’t see very bad things in my routing tables. Am I missing something?

  5. Hy tulum

    Ping is irelevant for loops , you should do a traceroute ,if you will see more than 2 hops .. is a loop 😉
    skippi#traceroute 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.34.3 52 msec
    192.168.24.2 28 msec
    192.168.34.3 36 msec
    2 192.168.12.1 68 msec
    192.168.13.1 76 msec
    192.168.12.1 52 msec
    this is a loop.

    Generic LOOP PREVENTION solution by tagging routes without using ACL. This is a more scalable approach than ACL based one. It is a one-for-all solution regardless of the numbers of non-distinctive routes.

    First Mutual Redistribution Point:

    router A #
    router X
    redistribute Y route-map Y_to_X metric x…

    router Y
    redistribute X route-map X_to_Y metric x…

    route-map Y_to_X deny 10
    match tag AD_X

    route-map Y_to_X permit 20
    set tag AD_Y

    route-map X_to_Y deny 10
    match tag AD_Y

    route-map X_to_Y permit 20
    set tag AD_X

    Example
    router rip
    redistribute eigrp 1 route-map eigrp_to_rip metric 2

    router eigrp 1
    redistribute rip route-map rip_to_eigrp metric 10000 100 255 1 1500

    route-map eigrp_to_rip deny 10
    match tag 120

  6. [b]For some reason previous post was not complete [/b].
    This should be the solution NOT found by me i was using access list 🙁

    First Mutual Redistribution Point:

    router A #
    router X
    redistribute Y route-map Y_to_X metric x…

    router Y
    redistribute X route-map X_to_Y metric x…

    route-map Y_to_X deny 10
    match tag AD_X

    route-map Y_to_X permit 20
    set tag AD_Y

    route-map X_to_Y deny 10
    match tag AD_Y

    route-map X_to_Y permit 20
    set tag AD_X

    Example
    router rip
    redistribute eigrp 1 route-map eigrp_to_rip metric 2

    router eigrp 1
    redistribute rip route-map rip_to_eigrp metric 10000 100 255 1 1500

    route-map eigrp_to_rip deny 10
    match tag 120

  7. Thanks Ano. I had noticed the extra hops with traceroute too but I assumed it was okay since pings were successful. Now I know that routing loops doesn’t necessary mean packet loss.

  8. 😉 i was fighting like a ninja with ROUTE REDISTRIBUTION and PATH SELECTION the concept it seems to be simple, but in practice is tricky.
    This is a real great site for GNS labs >> cisco stuff

  9. [b]For the 3 time i uplod hope now will be all
    [/b]
    Example
    router rip
    redistribute eigrp 1 route-map eigrp_to_rip metric 2

    router eigrp 1
    redistribute rip route-map rip_to_eigrp metric 10000 100 255 1 1500

    route-map eigrp_to_rip deny 10
    match tag 120

  10. Besides routing loops (you can spot those with traceroute) you can have blackhole routing…test some things and see what happens when neighbors go down and come back online.

  11. written by Rene Molenaar, March 14, 2011
    Example: network 4.4.4.0 will be redistributed INTO RIP at router Lassie. The redistributed network 4.4.4.0 will be redistributed AGAIN into EIGRP at router Willy.

    I believe, that there is no suboptimal routing int this lab, as the example is wrong from the beginning, as EIGRP is using different AD for internal and external routes. So following is happening next:
    1) When 4.4.4.0 is being redistributed to rip at Lassie, it’s AD is 120 (RIP); then when redistributting it back to eigrp at willy, it will have AD 170 (EIGRP external).
    2) So router Willy will not use this route (AD 170), neither RIP route (AD 120), because it hears the route for 4.4.4.0 network from Router skippy with AD 90 and put’s this route to it’s routing table.

    Eigrp’s default AD’s 90 and 170 solve this problem automatically.
    I think the lab should have been made with two domains – OSPF and RIP.
    As ospf internal and external routes both have AD 110, the suboptimal routing can occur.

    If to take the same example, then if route is being redistributed from ospf domain to rip at lessie – it will get AD 120, and when redistributing back to ospf, it will get AD 110. So router will hear about this route from two sources with the same AD, but different metric. And if metric received when reredistributing from RIP is better than metric, to reach this network directly via skippy router , then router will put this suboptimal route to it’s routing table. To avoid this, you can change either AD for external ospf routes, or you can change the metric. To prove this suboptimal route at willy you could launcht trace to 4.4.4.4 and it would show that the routing is going willy -> flipper -> lassie -> skipper instead of directly going to skipper.

    And I think that folowing trace shows not the suboptimal routing, but just a equal cost load balance…

    1 192.168.34.3 52 msec
    192.168.24.2 28 msec
    192.168.34.3 36 msec
    2 192.168.12.1 68 msec
    192.168.13.1 76 msec
    192.168.12.1 52 msec

    Correct me if I’m wrong 🙂

  12. Hi Tadas,

    You are right I should have designed it differently so I changed it 😉

    EIGRP makes a difference between internal or external which makes sure that internal prefixes are always preferred.

    You could still have a problem in the RIP domain since RIP makes no difference between internal or external prefixes.

    Let’s say that you have an internal RIP prefix with a hop count of 10, and you redistribute this prefix back into RIP with a hop count of 1. You’ll get sub-optimal routing.

    To demonstrate this I changed router Skippy so the 4.4.4.0 prefix is advertised in EIGRP as an external prefix. You’ll see that either router Willy or Lassie will take an sub-optimal path towards 4.4.4.0.

    Enjoy and thanks for the comment

    ;D

  13. @ muhaned – I believe the solution to the sub-optimal routing is to adjust the administrative distance for External EIGRP routes on Router Lassie and Willy to < 120 & > 90 – I used 95. The routes maps are standard as already suggested.

    Router Willy (basicly same setup on Lassie)
    !
    router eigrp 234
    redistribute rip metric 100 100 100 100 100 route-map INTO-EIGRP
    network 192.168.34.0
    distance eigrp 90 95
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 5 route-map INTO-RIP
    network 192.168.13.0
    no auto-summary
    !
    route-map INTO-EIGRP deny 10
    match tag 2
    !
    route-map INTO-EIGRP permit 20
    set tag 1
    !
    route-map INTO-RIP deny 10
    match tag 1
    !
    route-map INTO-RIP permit 20
    set tag 2
    !

  14. I’m not sure route tagging is the issue for this lab.
    The issue seems to be when you redistribute originally from rip into eigrp you specify a bandwidth when doing so. i.e.r
    redistribute rip metric 1500 1 1 100 1500
    So from router skippy you will have two paths to reach network 1.1.1.0
    D EX 1.1.1.0 [170/1709312] via 192.168.34.3, 00:00:10, FastEthernet1/0
    [170/1709312] via 192.168.24.2, 00:00:10, FastEthernet0/0
    So when you perform a trace you will see more than two hops as its load balancing between the two
    Tracing the route to 1.1.1.1

    1 192.168.34.3 32 msec
    192.168.24.2 16 msec
    192.168.34.3 8 msec
    2 192.168.12.1 48 msec
    192.168.13.1 24 msec *

    This isnt a routing loop. This is a result of load balancing down the two links.

    If you change the metric on one of the redistributing router for ex on Lassie:
    redistribute rip metric 1 1 1 1 1
    Lassie(config-router)#

    You will now only have 1 path for the 1.1.1.0 network
    D EX 1.1.1.0 [170/1709312] via 192.168.34.3, 00:00:26, FastEthernet1/0

    Final trace is
    Tracing the route to 1.1.1.1

    1 192.168.34.3 24 msec 20 msec 8 msec
    2 192.168.13.1 40 msec * 24 msec

    So in this lab is the design that it should be using both links to reach 1.1.1.0?
    I dont see how the tagging would fix this.

  15. i just didn’t got the idea…
    the basic principle for redistribution between RIP and EIGRP say that something like that

    “domain-loop” shouldn’t happen, because both routers “R2 & R3” know that there is a route

    for the subnet 4.4.4.4 learned through EIGRP with AD = 90, so when they see that there is

    another route coming from the RIP network with AD=120, they are not going to make

    redistribution to avoid such loop.

    my result was as i said, there was no loop even without route tag configured, so where is the problem?

    Lassie(config-router)#do sh ip rou
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:26, FastEthernet0/0
    R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:26, FastEthernet0/0
    2.0.0.0/32 is subnetted, 1 subnets
    C 2.2.2.2 is directly connected, Loopback0
    3.0.0.0/32 is subnetted, 1 subnets
    D 3.3.3.3 [90/158720] via 192.168.24.4, 00:35:36, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    D 4.4.4.0 [90/156160] via 192.168.24.4, 00:36:22, FastEthernet1/0
    C 192.168.24.0/24 is directly connected, FastEthernet1/0
    D 192.168.34.0/24 [90/30720] via 192.168.24.4, 00:46:10, FastEthernet1/0

    ************************************************************************************

    Willy(config-router)#do sh ip rou
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:20, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.13.1, 00:00:20, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, FastEthernet0/0
    2.0.0.0/32 is subnetted, 1 subnets
    D 2.2.2.2 [90/158720] via 192.168.34.4, 00:35:58, FastEthernet1/0
    3.0.0.0/32 is subnetted, 1 subnets
    C 3.3.3.3 is directly connected, Loopback0
    4.0.0.0/24 is subnetted, 1 subnets
    D 4.4.4.0 [90/156160] via 192.168.34.4, 00:36:59, FastEthernet1/0
    D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:46:40, FastEthernet1/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    could that be the IOS version?

    Cisco IOS Software, 3600 Software (C3640-JK9S-M), Version 12.4(16), RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2007 by Cisco Systems, Inc.

  16. Hello Ibrahim,

    The loopback interface on router Skippy is not [b]advertised[/b] in EIGRP but [b]redistributed[/b]. The AD of this prefix will be 170 (external) not 90 (internal).

    What happens is that router Lassie and Willy will have 4.4.4.0 /24 with AD 170 in their routing table. Both are configured to redistribute 4.4.4.0 /24 from EIGRP into RIP.

    One of the routers will receive the 4.4.4.0 /24 network through RIP with an AD of 120.

    AD 120 is lower (and thus better) than AD 170 so the EIGRP external prefix will be removed from the routing table and the RIP prefix will be installed.

    Result: sub-optimal routing (do a traceroute to find this).

  17. Hi All,
    1st of all I thought that no matter what, there will be suboptimal routing, looking from either direction.
    then I thought there has to be a way out.
    & here it is acc to me.

    Lassie#sh run | s rip|eigrp|map
    router eigrp 234
    redistribute rip metric 100000 10 255 1 1500 route-map r2e
    network 192.168.24.0
    distribute-list route-map tag170 in
    no auto-summary
    router rip
    version 2
    redistribute eigrp 234 metric 5 route-map e2r
    network 192.168.12.0
    distance 180
    no auto-summary
    route-map r2e deny 5
    match tag 5
    route-map r2e permit 10
    set tag 170
    route-map e2r deny 5
    match tag 170
    route-map e2r permit 10
    set tag 5
    route-map tag170 deny 5
    match tag 170
    route-map tag170 permit 10
    Lassie#

    (Likewise for Willy)

    I have tested it by rebooting the routers and the path remains optimal.

    Lassie#tr 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.24.4 36 msec * 68 msec
    Lassie#
    Lassie#tr 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

    1 192.168.12.1 16 msec * 28 msec
    Lassie#

  18. contd…

    Lassie#tr 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

    1 192.168.12.1 16 msec * 28 msec
    Lassie#

    Rene, Thanx 4 such good, challenging labs.

    Regards
    Shoeb

    1. Hi Shoeb,

      That looks good to me…redistributing and using route-maps to influence the AD and metric is a good method of dealing with this.

      Rene

  19. I’m stuck with this. I did create route-maps on Willy and Lassie as follows

    Willy#show route-map
    route-map EIGRP_TO_RIP, permit, sequence 10
    Match clauses:
    Set clauses:
    tag 77
    Policy routing matches: 0 packets, 0 bytes
    route-map EIGRP_TO_RIP, deny, sequence 20
    Match clauses:
    tag 88
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    route-map RIP_TO_EIGRP, deny, sequence 10
    Match clauses:
    tag 77
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    route-map RIP_TO_EIGRP, permit, sequence 20
    Match clauses:
    Set clauses:
    tag 88
    Policy routing matches: 0 packets, 0 bytes

    Lassie

    route-map EIGRP_TO_RIP, permit, sequence 10
    Match clauses:
    Set clauses:
    tag 77
    Policy routing matches: 0 packets, 0 bytes
    route-map EIGRP_TO_RIP, deny, sequence 20
    Match clauses:
    tag 88
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    route-map RIP_TO_EIGRP, deny, sequence 10
    Match clauses:
    tag 77
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    route-map RIP_TO_EIGRP, permit, sequence 20
    Match clauses:
    Set clauses:
    tag 88
    Policy routing matches: 0 packets, 0 bytes

    but although now the ASBRs send direct to Skippy for the 4.4.4.4 route, Flipper’s routing table looks like this

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    C 192.168.13.0/24 is directly connected, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    R 4.4.4.0 [120/10] via 192.168.12.2, 00:00:00, FastEthernet0/0
    R 192.168.24.0/24 [120/10] via 192.168.12.2, 00:00:00, FastEthernet0/0
    R 192.168.34.0/24 [120/10] via 192.168.12.2, 00:00:00, FastEthernet0/0

    surely Flipper should have two paths to 4.4.4.4. What happened to via 192.168.13.0?

  20. Hopefully this is not a duplicate response…This is an excellent lab for thinking about how networks work. One of the things to think about here is that 4.4.4.4 is not a connected location or interface on Router Skippy. It’s not "connected" to Lassie and Willie.

    The lab was made to have 4.4.4.4 as an EXTERNAL network. Think about that, or even draw it out on paper, not as a loopback, but as a network.

    That said, while you need the route-map statement, that doesn’t fully address the Administrative Distance question dealing with EXTERNAL routes.

    Hint hint….

    Research the AD’s of EIGRP vs RIP. The solution has been danced around in some of the comments/questions here.

    1. Stemikar,

      Your route maps look way too complicated. You don’t need to get that complex in order for them to work. Remember, when using route maps, we only need to match one tag. Not two. Then the second rule is to set the tag on any packet that is coming from one side of the ASBR to another.

    2. RDM,

      Wouldn’t setting the metric to a high hop count take care of the AD issues while redistributing? Since RIP doesn’t see the difference between internal and external hop counts, it may prefer an external route to an internal one if the hop count isn’t high enough right?

      1. Well, I think that is conceptually true, but what is the AD of RIP and of EIGRP? Or external EIGRP? I think that that is the key. Skippy’s L0 is, I believe, injected NOT as a connected link, but shows up in the routing table as an external route.

  21. Tell me if it is correct or not….

    Willy-

    router eigrp 1
    redistribute rip metric 1 1 1 1 1 route-map rip2eigrp
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 1 metric 2 route-map eigrp2rip
    network 192.168.13.0
    no auto-summary
    !
    route-map rip2eigrp deny 10
    match tag 10
    !
    route-map rip2eigrp permit 20
    set tag 11

    —————————

    Lassie-

    router eigrp 1
    redistribute rip metric 1 1 1 1 1 route-map rip2eigrp
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 1 metric 2 route-map eigrp2rip
    network 192.168.12.0
    no auto-summary
    !
    route-map eigrp2rip deny 10
    match tag 11
    !
    route-map eigrp2rip permit 20
    set tag 10
    ————————–

    Skippy#traceroute 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

    1 192.168.34.1 24 msec 24 msec 16 msec
    2 192.168.13.1 40 msec * 52 msec
    ————————–

    Flipper#tr 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.12.2 12 msec 24 msec 24 msec
    2 192.168.24.2 48 msec * 36 msec

  22. Just need clarification…

    Is there anything that I have to reset for this to work because I keep seeing the RIP route to 4.4.4.0 on router Lassie. Router Willy seems to be correct

    router eigrp 234
    redistribute rip metric 1 1 1 1 1 route-map rip_to_eigrp
    network 192.168.24.0
    no auto-summary

    router rip
    version 2
    redistribute eigrp 234 metric 2 route-map eigrp_to_rip
    network 192.168.12.0
    no auto-summary

    route-map eigrp_to_rip deny 10
    match tag 88
    !
    route-map rip_to_eigrp deny 10
    match tag 77
    !
    route-map rip_to_eigrp permit 20
    set tag 88
    !
    route-map eigrp_to-rip permit 20
    set tag 77

  23. I don’t understand this lab. Route tagging will not prevail the redistribution router to take a suboptimal route, route tags are for the internal router. The only way to make the redistribution router (R2 and R3) take the path directly through Skippy is by playing on the AD with the command “distance eigrp xx”.

    So here R2 and R3 cannot be affected by the route tag and neither R4 since the loopback is directly connected.

    From the ROUTE Official Certification Guide page 355 :

    Interestingly, this design does prevent the long routes, as shown earlier in Figure 10-6, but it does leave the possibility of a long route on a redistributing router. For example, if using
    all default AD settings, RD2 still learns an OSPF (default AD 110) route for 172.20.0.0 from RD1, so it may choose as best route the OSPF route through RD1 as the best route.
    Setting the AD for OSPF external routes to something larger than EIGRP’s external AD of 170 would prevent this particular problem as well.

    The same applies to both filtering with Route tag or filtering based on the prefix.

    If it works on GNS3, then it’s a bug.

    1. Fiddling with AD is by far the most elegant way of solving this, but I thought of a way using route tagging. First, tag 4.4.4.0 when redistributing it into RIP. Then, use an inbound distribute list to outright deny any tagged advertisements in RIP. I thought that would do the trick.

      However, my plan was thwarted because my routers wouldn’t let me specify a route-map in the distribute-list command. Supposedly it’s possible with some IOS versions, but not mine. I could apply route-maps to the RIP-facing interfaces using PBR, but at times there’s only so far I’m willing to go to implement such a contrived solution.

      1. You could do that but if the primary link fail, you will not have a backup route. That’s why it’s impossible to me but maybe the purpose of this lab is just to know how to do this with tag, regardless of the backup route.

    2. Hello!
      This lab from Implementing Cisco IP Routing book.
      In chapter 4 is very depth explained. But in the book example OSPF redistributed into EIGRP and vice versa.

  24. Guys,this was my solution,and it works well

    access-list 10 permit 1.1.1.0 0.0.0.255
    access-list 30 permit 4.4.4.0 0.0.0.255
    !
    route-map RIP_EIGRP deny 5
    match tag 234
    !
    route-map RIP_EIGRP permit 10
    match ip address 10
    set tag 120
    !
    route-map RIP_EIGRP permit 20
    !
    route-map EIGRP_RIP deny 5
    match tag 120
    !
    route-map EIGRP_RIP permit 10
    match ip address 30
    set tag 234
    !
    route-map EIGRP_RIP permit 20

  25. I noticed the same traceroute (From Flipper router towards 4.4.4.4) with or without enabling route tagging with redistribution. Following is my configuration:
    Laslie
    ——-
    router eigrp 234
    redistribute rip metric 1 1 1 1 1
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 3
    network 192.168.12.0
    no auto-summary

    Willey
    ——–
    router eigrp 234
    redistribute rip metric 1 1 1 1 1
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 3
    network 192.168.13.0
    no auto-summary

    Skippy
    ———
    4.4.4.4 is redistributed into eigrp
    router eigrp 234
    redistribute connected route-map loopback
    network 192.168.24.4 0.0.0.0
    network 192.168.34.4 0.0.0.0
    no auto-summary
    access-list 1 permit 4.0.0.0 0.255.255.255
    route-map loopback permit 10
    match ip address 1

    Following is the trace route from Flipper to Skippy (4.4.4.4) It is the same with or without applying route tags> I will add route tag config at the end:
    Flipper#traceroute 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.13.3 32 msec
    192.168.12.2 24 msec
    192.168.13.3 20 msec
    2 192.168.24.4 32 msec
    192.168.34.4 32 msec
    192.168.24.4 28 msec
    [b]Flipper#show ip route
    R 4.4.4.0 [120/3] via 192.168.13.3, 00:00:20, FastEthernet1/0
    [120/3] via 192.168.12.2, 00:00:19, FastEthernet0/0
    R 192.168.24.0/24 [120/3] via 192.168.13.3, 00:00:20, FastEthernet1/0
    [120/3] via 192.168.12.2, 00:00:19, FastEthernet0/0
    R 192.168.34.0/24 [120/3] via 192.168.13.3, 00:00:21, FastEthernet1/0
    [120/3] via 192.168.12.2, 00:00:19, FastEthernet0/0[/b]

    Skippy#show ip route
    [b]D EX 192.168.12.0/24
    [170/2560002816] via 192.168.34.3, 00:01:47, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:01:47, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    D EX 1.1.1.0 [170/2560002816] via 192.168.34.3, 00:01:47, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:01:47, FastEthernet0/0
    D EX 192.168.13.0/24
    [170/2560002816] via 192.168.34.3, 00:01:47, FastEthernet1/0
    [170/2560002816] via 192.168.24.2, 00:01:47, FastEthernet0/0[/b]

    The only difference i saw after route tagging was that the load balancing across both links were gone. But the trace route was exactly th same:

    1. Following is the route tagging I used on both Lassie and Willy Routers:

      ip access-list standard EIGRP_ROUTES
      permit 4.0.0.0 0.255.255.255
      permit 192.168.24.0 0.0.0.255
      permit 192.168.34.0 0.0.0.255

      ip access-list standard RIP_ROUTES
      permit 1.0.0.0 0.255.255.255
      permit 192.168.12.0 0.0.0.255
      permit 192.168.13.0 0.0.0.255

      [color=maroon]route-map RIP_INTO_EIGRP deny 5
      match tag 90
      !
      route-map RIP_INTO_EIGRP permit 10
      match ip address RIP_ROUTES
      set tag 120[/color]
      !
      [color=red]route-map EIGRP_INTO_RIP deny 5
      match tag 120
      !
      route-map EIGRP_INTO_RIP permit 10
      match ip address EIGRP_ROUTES
      set tag 90[/color]

      1. I also Dont see what is written in the question
        [b]"You notice that router Willy or Lassie are sending traffic to 4.4.4.4 towards router Flipper, make sure you get rid of this sub-optimal routing."[/b]

        Following are the trace routes with just mutual redistribution and no route tagging:
        Lassie#trace 4.4.4.4

        Type escape sequence to abort.
        Tracing the route to 4.4.4.4

        1 192.168.24.4 24 msec 20 msec 16 msec

        Lassie#show ip route
        C 192.168.12.0/24 is directly connected, FastEthernet0/0
        1.0.0.0/24 is subnetted, 1 subnets
        R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:15, FastEthernet0/0
        R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:15, FastEthernet0/0
        [b]4.0.0.0/24 is subnetted, 1 subnets
        D EX 4.4.4.0 [170/156160] via 192.168.24.4, 00:05:59, FastEthernet1/0[/b]
        C 192.168.24.0/24 is directly connected, FastEthernet1/0
        D 192.168.34.0/24 [90/30720] via 192.168.24.4, 00:05:59, FastEthernet1/0

        Willy#trace 4.4.4.4

        Type escape sequence to abort.
        Tracing the route to 4.4.4.4

        1 192.168.34.4 24 msec 24 msec 16 msec
        Willy#show ip route
        R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:10, FastEthernet0/0
        1.0.0.0/24 is subnetted, 1 subnets
        R 1.1.1.0 [120/1] via 192.168.13.1, 00:00:10, FastEthernet0/0
        C 192.168.13.0/24 is directly connected, FastEthernet0/0
        4.0.0.0/24 is subnetted, 1 subnets
        [b]D EX 4.4.4.0 [170/156160] via 192.168.34.4, 00:06:03, FastEthernet1/0[/b]
        D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:06:03, FastEthernet1/0
        C 192.168.34.0/24 is directly connected, FastEthernet1/0

        [color=blue]AM I DOING SOMETHING WRONG HERE ???
        What does that trace route actually showing as i m confused its the same with or without route tagging. Also Both Lassie Willy are tracing 4.4.4.4 network directly without going through flipper??[/color]

  26. can someone help me? whats wrong here:
    redistribute rip metric 1 1 1 1 1 route-map rip2eigrp
    redistribute eigrp 234 metric 2 route-map eigrp2rip
    !
    route-map rip2eigrp deny 10
    match tag 33
    !
    route-map rip2eigrp permit 15
    set tag 44
    !
    route-map eigrp2rip deny 10
    match tag 44
    !
    route-map eigrp2rip permit 15
    set tag 33
    !
    I put this in both border routers but Willy keep using RIP route to 4.4.4.4

  27. Hi Rene, this is my configuration. Could you please tell me whats my issue because im not finding the problem:

    R2:
    router eigrp 234
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 10 route-map EIGRP_INTO_RIP
    network 192.168.12.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map EIGRP_INTO_RIP permit 10
    set tag 50
    !
    route-map EIGRP_INTO_RIP deny 20
    match tag 100

    R3:
    router eigrp 234
    redistribute rip route-map RIP_INTO_EIGRP
    network 192.168.34.0
    default-metric 1 1 1 1 1
    no auto-summary
    !
    router rip
    version 2
    network 192.168.13.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map RIP_INTO_EIGRP permit 10
    set tag 100
    !
    route-map RIP_INTO_EIGRP deny 20
    match tag 50

    Thanks in advance and excellent web page.

    1. this would work perfectly if we had only rip and eigrp , but in this lab we redistributing connected routes also

  28. Hi everyone.

    I have read some of the posts that have tagged the routes and denied when redistributing.

    From what I understand, this is not resolving the issue because when I simulated this lab in GNS3, the best next-hop to 4.4.4.0 from Willy was through Flipper – which is incorrect.

    I found the only way to resolve the issue is to get RIP not to advertise the 4.4.4.0 route to Willy, because Willy already knows how to reach to 4.4.4.0 via the 170 EIGRP external route. If you don’t do this, the RIP AD of 120 becomes the best route and the directly connected route becomes the backup.

    I hope what I said is correct. I have tested the lab in GNS3 and both Lassie and Willy have the next-hop pointing to EIGRP 170 route and I can ping everything ok.

    Below are the traceroute between Skippy and Flipper, note because of the redundant links with the same metric and AD, the route will be hopped between Lassie and Willy.

    Skippy#traceroute 1.1.1.1

    Tracing the route to 1.1.1.1

    1 192.168.34.3 20 msec
    192.168.24.2 28 msec
    192.168.34.3 24 msec
    2 192.168.12.1 52 msec
    192.168.13.1 56 msec *

    Flipper#traceroute 4.4.4.4

    Tracing the route to 4.4.4.4

    1 192.168.13.3 48 msec
    192.168.12.2 32 msec
    192.168.13.3 20 msec
    2 192.168.24.4 48 msec
    192.168.34.4 44 msec *

    Note: I have also shut one of the redundant links to ensure the routing works on one link. In GNS3, I had to [b]clear ip route *[/b] for the table to refresh.

  29. We need to stop the installation of 4.4.4.0/24 in RIP database based on tags in Router Willy. I can stop at the time of redistribution but I can’t stop the installation of this Route into RIP database. Please provide us the idea how it can be done ?

  30. like i said above, you could block the RIP route from Willy being advertised? Setup a distribute list and block 4.4.4.0 going out via RIP

  31. [quote=Anonymous]like i said above, you could block the RIP route from Flipper being advertised? Setup a distribute list and block 4.4.4.0 going out via RIP[/quote]

  32. like i said above, you could block the RIP route from Flipper being advertised? Setup a distribute list and block 4.4.4.0 going out via RIP

  33. Another option is to set the AD of the external route (4.4.4.0) from Skippy to be lower than 120 (say 110) and this will fix the issue, this way you will maintain redundancy in the even the link between Skippy and Willy is broken.

  34. Hello there,

    I have performed two-way redistribution between RIP and EIGRP on router Lassie and Willy, however I’m did not detected a sub-optimal routing. Could you please help identifying what I did wrong?

    —————————————–

    Willy:

    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:01, FastEthernet0/0
    1.0.0.0/32 is subnetted, 1 subnets
    R 1.1.1.1 [120/1] via 192.168.13.1, 00:00:01, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, FastEthernet0/0
    4.0.0.0/32 is subnetted, 1 subnets
    D 4.4.4.4 [90/156160] via 192.168.34.4, 00:00:17, FastEthernet1/0
    D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:10:00, FastEthernet1/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    ———————————————

    Willy#traceroute 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.34.4 96 msec * 52 msec
    Willy#

    ———————————————–

    Willy# show running-config | s eigrp
    router eigrp 234
    redistribute rip metric 100 100 100 100 100
    network 192.168.34.0
    no auto-summary
    redistribute eigrp 234 metric 1
    ————————————————

    Willy# show running-config | s rip
    redistribute rip metric 100 100 100 100 100
    router rip
    version 2
    redistribute eigrp 234 metric 1
    network 192.168.13.0
    no auto-summary

    ———————————————-

    I got same result for Lassie

    Thanks in advance,

  35. After applying the route-map on both Leslie and willy. Still the traffic from

    Willy is going via Flipper. I can see Tag : 77 route on Willy. It is redistributing the route.
    Renne could you please help me on this

    COmplete configs of both the routers
    R2 :

    router eigrp 234
    redistribute rip metric 1 1 1 1 1 route-map RIP2EIGRP
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 2 route-map EIGRP2RIP
    network 192.168.12.0
    no auto-summary

    route-map EIGRP2RIP deny 10
    match tag 88
    !
    route-map EIGRP2RIP permit 20
    set tag 77
    !
    route-map RIP2EIGRP deny 10
    match tag 77
    !
    route-map RIP2EIGRP permit 20
    set tag 88

    Lassie#sh ip route

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:24, FastEthernet0/0
    R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:24, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D EX 4.4.4.0 [170/156160] via 192.168.24.4, 00:36:09, FastEthernet1/0
    C 192.168.24.0/24 is directly connected, FastEthernet1/0
    D 192.168.34.0/24 [90/30720] via 192.168.24.4, 00:36:09, FastEthernet1/0

    Lassie#traceroute 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.24.4 284 msec * 32 msec

    ==================================================================================

    R3 :

    router eigrp 234
    redistribute rip metric 1 1 1 1 1 route-map RIP2EIGRP
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 2 route-map EIGRP2RIP
    network 192.168.13.0
    no auto-summary

    route-map EIGRP2RIP deny 10
    match tag 88
    !
    route-map EIGRP2RIP permit 20
    set tag 77
    !
    route-map RIP2EIGRP deny 10
    match tag 77
    !
    route-map RIP2EIGRP permit 20
    set tag 88
    !

    Willy#sh ip route

    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:22, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.13.1, 00:00:22, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    R 4.4.4.0 [120/3] via 192.168.13.1, 00:00:22, FastEthernet0/0
    D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:37:57, FastEthernet1/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    Willy#sh ip route 4.4.4.4
    Routing entry for 4.4.4.0/24
    Known via “rip”, distance 120, metric 3
    Tag 77
    Redistributing via eigrp 234, rip
    Last update from 192.168.13.1 on FastEthernet0/0, 00:00:18 ago
    Routing Descriptor Blocks:
    * 192.168.13.1, from 192.168.13.1, 00:00:18 ago, via FastEthernet0/0
    Route metric is 3, traffic share count is 1
    Route tag 77

    Willy#traceroute 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.13.1 16 msec 36 msec 48 msec
    2 192.168.12.2 48 msec 48 msec 92 msec
    3 192.168.24.4 92 msec * 104 msec

  36. I don’t know if I already resolved this lab or not. I already resolved the sub-optimal routing by changing the AD. But I don’t know if I resolve the routing loop or if there is a routing loop happening in the topology. My question is how will I know if there is loop on the topology? I tried to traceroute 4.4.4.4 from Router Skippy and here is the results:

    Skippy# traceroute 4.4.4.4

    1 192.168.34.3 20 msec
    192.168.24.2 28 msec
    192.168.34.3 24 msec
    2 192.168.12.1 52 msec
    192.168.13.1 56 msec *

    Is this a loop? or it is just normal because both links has the same metrics. I can lower down the metric of the other link and it will give me one route only to reach 4.4.4.4. Now If that is the case, did I already resolve the routing loop? or I didn’t resolve anything because there is no routing loop at the first place? Or there is a loop but I cannot detect it because the packet is loss due to its TTL?

    please help..

  37. Hello there!
    If we are doing mutual redistribution on both routers: Lassie and Willy, we need to perform tagging and filtering on both routers, please correct me if i wrong?
    Here is my config for both of them:
    Lassie:

    router eigrp 234
    redistribute rip metric 10000 200 255 1 1500 route-map RIP2EIGRP
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 3 route-map EIGRP2RIP
    network 192.168.12.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map EIGRP2RIP permit 10
    set tag 88
    !
    route-map EIGRP2RIP deny 20
    match tag 77
    !
    route-map RIP2EIGRP permit 10
    set tag 99
    !
    route-map RIP2EIGRP deny 20
    match tag 66

    ===========================================================================

    Willy:

    router eigrp 234
    redistribute rip metric 10000 200 255 1 1500 route-map RIP2EIGRP
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 3 route-map EIGRP2RIP
    network 192.168.13.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map RIP2EIGRP deny 10
    match tag 88
    !
    route-map RIP2EIGRP permit 20
    set tag 77
    !
    route-map EIGRP2RIP permit 10
    set tag 66
    !
    route-map EIGRP2RIP deny 20
    match tag 99

  38. Tagging is quite important here but to set the path that you want the routes to go simply change your redistribution metric. I decided to make the routers use the route through Willy(192.168.13.0/24) by increasing the metric that is redistributed on Lassie. Here is what I did on Lassie:

    router eigrp 234
    redistribute rip metric 100 15000 255 1 1500 route-map NORIP
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 10 route-map NOLOOP
    network 192.168.12.0
    no auto-summary

    Here is what I did on Willy:

    router eigrp 234
    redistribute rip metric 1000 5000 255 1 1500 route-map NORIP
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 6 route-map NOLOOP
    network 192.168.13.0
    no auto-summary

    Flipper#show ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    C 192.168.13.0/24 is directly connected, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    R 4.4.4.0 [120/6] via 192.168.13.3, 00:00:10, FastEthernet1/0
    R 192.168.24.0/24 [120/6] via 192.168.13.3, 00:00:10, FastEthernet1/0
    R 192.168.34.0/24 [120/6] via 192.168.13.3, 00:00:10, FastEthernet1/0
    Flipper#
    Here is my traceroute from Flipper:
    Flipper#traceroute 4.4.4.4

    Type escape sequence to abort.
    Tracing the route to 4.4.4.4

    1 192.168.13.3 16 msec 20 msec 20 msec
    2 192.168.34.4 40 msec * 48 msec
    Flipper#
    Notice the single hop through Willy to Skippy.
    Here is Skippy showing the return path:
    Skippy#traceroute 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

    1 192.168.34.3 24 msec 24 msec 20 msec
    2 192.168.13.1 44 msec * 36 msec
    Skippy#
    This shows the exact reverse path. Remember when checking routes use traceroute and check both
    directions. Otherwise you may overlook a problem. There are many ways to control the redistribution and this is only one way. Remember with redistribution you can control the metric at each redistribution point. Use this ability to your advantage.

  39. Hi,

    not sure if there is a glitch with GNS3. Can someone please test if you guys are having the same issue. Here is what I went through.

    ———————-
    Lassie(config-route-map)#do sh run | b r e
    router eigrp 234
    redistribute rip metric 1544 10 1 255 1500 route-map R2E
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 10 route-map E2R
    network 192.168.12.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map E2R deny 10
    match tag 120
    !
    route-map E2R permit 20
    set tag 170
    !
    route-map R2E deny 10
    match tag 170
    !
    route-map R2E permit 20
    set tag 120
    ———————————————-

    Willy(config-router)#do sh run | b r e
    router eigrp 234
    redistribute rip metric 1544 10 1 255 1500 route-map R2E
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 10 route-map E2R
    network 192.168.13.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map E2R deny 10
    match tag 120
    !
    route-map E2R permit 20
    set tag 170
    !
    route-map R2E deny 10
    match tag 170
    !
    route-map R2E permit 20
    set tag 120
    ==========================

    –At this point Will was getting RIP route for 4.4.4.0/24

    R 4.4.4.0 [120/11] via 192.168.13.1, 00:00:04, FastEthernet0/0

    –And Lassie was getting EIGRP External route

    D EX 4.4.4.0 [170/156160] via 192.168.24.4, 00:01:55, FastEthernet1/0

    ========================================

    –I later changed the distance of EIGRP External routes to 119 on both LAssie and Willy. This seems to have fixed the RIP route on Willy and both get D EX routes for 4.4.4.0/24

    –I then took off the Distanc command from both routers and also cleared EIGRP neigbors, #clear ip ro * on all routers, but still have D EX route on both of them for 4.4.4.0/24

    *Rene – can you please confirm if this is a glitch

    1. At a quick glance, this is not a glitch. Setting tags prevents routes from being redistributed, but does not filter them from being installed in the routing table. Use admin distance to solve your suboptimal routing problems and use route-tagging as a means of filtering at ASBRs.

  40. Hi all
    With the connected route for 4.4.4.0/24 being redistributed on Skippy, there will occur suboptimal routing on either Lassie or Willy.

    Actually, using tags wouldn’t solve the issue.

    It can be solved by changing the EIGRP AD for 4.4.4.0/24 on Willy for example.

    Let’s assume we did Redistribution into RIP first on Lassie. The latter will advertise the now RIP route to Flipper, and Flipper in turn will advertise it to Willy.

    Willy will have two routes for 4.4.4.0/24, one learned through RIP with AD 120, and another learned through EIGRP with AD 170. So, it will put the RIP route into its routing table.

    If now we change the AD of the route learned through EIGRP from 170 to 100 for example, the router will get rid of the RIP route and instead put into its routing table the router learned through EIGRP. So Willy will send the traffic toward 4.4.4.0/24 to Skippy directely, just as Lassie will do.

    there is another option:
    Tag the 4.4.4.0/24 route when redistritued on Skippy.
    Filtering it when redistribution into RIP on Lassie and Willy, matching of course the tag set on Skippy.
    Add a static route for 4.4.4.0/24 on Flipper, as it will not receive any advertisement for this route from any Router.

  41. GOT IT :

    READ RENE BOOK as guide,

    1 TIPS: There wont be any routing loops if you give different metrics, so ‘one’ path will be chosen
    2 TIPS(IMP): there was only one mistake that i did, that was

    i redistributed with different metrics in such a way that, the path were going round,
    ie when pinging from skippy to flipper, it chose lassie then came back via willy,
    this was okay, but when i shut down one of the routers, complete routing would stop,

    what this means that skippy chooses lassie as best route, but flipper chose willy as best even though it was down(not sure if its a rip problem) , as it was its own best route
    change this so that only one of the side would be great for routing for both sides.

    technicalities you figure it out, but my show run are :

    ——————————————————————————————————–
    Lassie
    ——————————————————————————————————–

    router eigrp 234
    redistribute rip metric 100000 100 255 1 1 route-map EIRIP
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 9 route-map RIPEI
    network 192.168.12.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map EIRIP deny 10
    match tag 10
    !
    route-map EIRIP permit 20
    set tag 10
    !
    route-map RIPEI deny 10
    match tag 20
    !
    route-map RIPEI permit 20
    set tag 20
    !
    !

    ——————————————————————————————————–
    Willy
    ——————————————————————————————————–

    router eigrp 234
    redistribute rip metric 10000 100 255 1 1 route-map EIRIP
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 10 route-map RIPEI
    network 192.168.13.0
    no auto-summary
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map EIRIP deny 10
    match tag 10
    !
    route-map EIRIP permit 20
    set tag 10
    !
    route-map RIPEI deny 10
    match tag 20
    !
    route-map RIPEI permit 20
    set tag 20

  42. I went to R4 and used the network command under EIGRP instead of redistributing the loopbacl

    Cheating I know 🙂

    Thanks Rene

  43. Hello ALL!!!
    I would like to wish you an happy new year 2015!!!

    For that lab, this is how I have solve the redistribution sub_optimal route:

    Lassie# sh run

    !
    router eigrp 234
    redistribute rip metric 1500 100 255 1 1500 route-map TAG
    network 192.168.24.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 5 route-map TAG
    network 192.168.12.0
    no auto-summary

    !
    access-list 9 permit 192.168.13.0 0.0.0.255
    access-list 9 permit 192.168.34.0 0.0.0.255
    !

    route-map TAG deny 9
    match ip address 9
    !
    route-map TAG deny 10
    match tag 1
    !
    route-map TAG permit 20
    set tag 1

    xxxxxxxxxxxxxxxxxxxxxxxxx

    Willy#sh run

    router eigrp 234
    redistribute rip metric 1500 100 255 1 1500 route-map TAG
    network 192.168.34.0
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 234 metric 5 route-map TAG
    network 192.168.13.0
    no auto-summary
    !

    access-list 9 permit 192.168.12.0 0.0.0.255
    access-list 9 permit 192.168.24.0 0.0.0.255

    !
    route-map TAG deny 9
    match ip address 9
    !
    route-map TAG deny 10
    match tag 1
    !
    route-map TAG permit 20
    set tag 1
    !

    it result to these ip route table on Skippy and Flipper:

    Skippy#sh ip route

    D EX 192.168.12.0/24 [170/1734656] via 192.168.24.2, 00:00:31, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    D EX 1.1.1.0 [170/1734656] via 192.168.34.3, 00:00:31, FastEthernet1/0
    [170/1734656] via 192.168.24.2, 00:00:31, FastEthernet0/0
    D EX 192.168.13.0/24 [170/1734656] via 192.168.34.3, 00:01:16, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    C 4.4.4.0 is directly connected, Loopback0
    C 192.168.24.0/24 is directly connected, FastEthernet0/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    Flipper#sh ip route

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Loopback0
    C 192.168.13.0/24 is directly connected, FastEthernet1/0
    4.0.0.0/24 is subnetted, 1 subnets
    R 4.4.4.0 [120/5] via 192.168.13.3, 00:00:15, FastEthernet1/0
    R 192.168.24.0/24 [120/5] via 192.168.12.2, 00:00:22, FastEthernet0/0
    R 192.168.34.0/24 [120/5] via 192.168.13.3, 00:00:15, FastEthernet1/0

    Someone to approve this ?

  44. here is my config

    Lassie(config-router)#do sh run | sec router
    router eigrp 234
    redistribute rip metric 1 1 1 1 1 route-map EIGRP-TO-RIP
    network 192.168.24.0
    no auto-summary
    router rip
    version 2
    redistribute eigrp 234 metric 1 route-map RIP-TO-EIGRP
    network 192.168.12.0
    no auto-summary

    Lassie(config-router)#do sh run | sec route-map
    redistribute rip metric 1 1 1 1 1 route-map EIGRP-TO-RIP
    redistribute eigrp 234 metric 1 route-map RIP-TO-EIGRP
    route-map RIP-TO-EIGRP deny 10
    match tag 90
    route-map RIP-TO-EIGRP permit 20
    set tag 120
    route-map EIGRP-TO-RIP deny 10
    match tag 120
    route-map EIGRP-TO-RIP permit 20
    set tag 90

    Lassie(config)#do sh ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:21, FastEthernet0/0
    R 192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:21, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D EX 4.4.4.0 [170/156160] via 192.168.24.4, 00:04:59, FastEthernet1/0
    C 192.168.24.0/24 is directly connected, FastEthernet1/0
    D 192.168.34.0/24 [90/30720] via 192.168.24.4, 00:04:59, FastEthernet1/0

    Willy(config-router)#do sh run | sec router
    router eigrp 234
    redistribute rip metric 1 1 1 1 1 route-map EIGRP-TO-RIP
    network 192.168.34.0
    no auto-summary
    router rip
    version 2
    redistribute eigrp 234 metric 1 route-map RIP-TO-EIGRP
    network 192.168.13.0
    no auto-summary

    Willy(config)#do sh run | sec route-map
    redistribute rip metric 1 1 1 1 1 route-map EIGRP-TO-RIP
    redistribute eigrp 234 metric 1 route-map RIP-TO-EIGRP
    route-map RIP-TO-EIGRP deny 10
    match tag 90
    route-map RIP-TO-EIGRP permit 20
    set tag 120
    route-map EIGRP-TO-RIP deny 10
    match tag 120
    route-map EIGRP-TO-RIP permit 20
    set tag 90

    Willy(config)#do sh ip route
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    R 192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:16, FastEthernet0/0
    1.0.0.0/24 is subnetted, 1 subnets
    R 1.1.1.0 [120/1] via 192.168.13.1, 00:00:16, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, FastEthernet0/0
    4.0.0.0/24 is subnetted, 1 subnets
    D EX 4.4.4.0 [170/156160] via 192.168.34.4, 00:07:39, FastEthernet1/0
    D 192.168.24.0/24 [90/30720] via 192.168.34.4, 00:07:39, FastEthernet1/0
    C 192.168.34.0/24 is directly connected, FastEthernet1/0

    please look at my config is this right?

    first i got the problem that router willy learn the 4.4.4.0 from router flipper due to lower AD but after clear the routing table it works perfect.

    Sorry for bad English …..

    1. Usman, that still won’t work. Clear the routing table and you will see what happens.

  45. You can use an access-list to match the 4.4.4.0/24 network with a distance command in the RIP process.

  46. Using tags will stop prefixes being redistributed into the protocol it originated from.

    This issue is caused by one router preferring the sub-optimal path due to the lower AD of RIP (120) compared to EIGRP External (170).

    A simple solution in addition to tagging is to add the distance command under the rip routing process for Lassie and Willie is to raise the admin distance of the 4.4.4.0 prefix sourced from Flipper above the EIGRP External AD of 170,

    I’ve used the lines

    Lassie(config)#access-list 1 permit host 4.4.4.0
    Lassie(config)#router rip
    Lassie(config-router)#distance 171 192.168.12.1 0.0.0.0 1

    Willie(config)#access-list 1 permit host 4.4.4.0
    Willie(config)#router rip
    Willie(config-router)#distance 171 192.168.13.1 0.0.0.0 1

  47. Obviously, route tagging isn’t enough here to prevent suboptimal routing. It will prevent routing loops, as it will not advetise prefixes back into the domain from whitch they are souced, but Lassie or Willy will stil have these prefixes in their routing table. There are several solutions – for example, we can change the AD for external EIGRP routes to something that is lower then RIP AD (for example 115), or to do something like @Diesel did. My solution was this:

    !
    route-map EIGRP-TO-RIP deny 10
    match tag 120
    route-map EIGRP-TO-RIP permit 20
    set tag 90
    !
    route-map RIP-TO-EIGRP deny 10
    match tag 90
    route-map RIP-TO-EIGRP permit 20
    set tag 120
    !
    ip prefix-list LISTA seq 5 deny 4.4.4.0/24
    ip prefix-list LISTA seq 10 permit 0.0.0.0/0 le 32
    !
    router rip
    redistribute eigrp 234 metric 5 route-map EIGRP-TO-RIP
    distribute-list prefix LISTA in
    router eigrp 234
    redistribute rip metric 100000 10 255 1 1500 route-map RIP-TO-EIGRP
    !

    I choose tag numbers that are the same as the AD of the sourcing protocol, that¨s my way to distinguish them. Is this ok?

Comments are closed.