BGP Neighbor Troubleshooting

Scenario:

As the network engineer for a large corporation you are responsible for the configuration of BGP. One of your colleagues tried to install some new routers and configure BGP between them but he got stuck and is asking for your help. The BGP neighbor adjacencies are not even working so it’s up to you to fix these…

Goal:

  • All IP addresses have been preconfigured for you.
  • Do not use show run! (this will spoil the fun đŸ™‚ use the appropiate ‘show’ and ‘debug’ commands. This will teach you the skills needed to become a true troubleshooting master.
  • Fix the BGP neighbor adjacency between AS1 and AS2. You are not allowed to change the neighbor commands.
  • Fix the BGP neighbor adjacency between AS1 and AS3. You are not allowed to change the neighbor commands.
  • Fix the BGP neighbor adjacency within AS3. You are not allowed to change the neighbor commands.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the troubleshooting issues for CCNP.

Would you like to be a master of troubleshooting too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of troubleshooting.

You will learn all the secrets about BGP troubleshooting and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP TSHOOT

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

BGP Neighbor Troubleshooting

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

René - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

15 Comments

    1. First question I have as I am in the middle of this lab, is the bgp peering between Amsterdam and New York. I am under the impression that for eBGP to function, there is no need to create a neighborship via loopbacks, that that typically has to do with iBGP. So since I cannot change the existing neighbor commands, I just added a neighbor command that used the interfaces. Is that "legal" as a solution? It certainly DID create an eBGP neighbor.

      Thanks

  1. [quote=rdm1860]First question I have as I am in the middle of this lab, is the bgp peering between Amsterdam and New York. I am under the impression that for eBGP to function, there is no need to create a neighborship via loopbacks, that that typically has to do with iBGP. So since I cannot change the existing neighbor commands, I just added a neighbor command that used the interfaces. Is that “legal” as a solution? It certainly DID create an eBGP neighbor.

    Thanks[/quote]

    I think you can use ebgp-multihop command. After adding Static route to reach Loopback

    1. I didn’t get to see your response until AFTER I just finished the lab! This took me some time, because even though I "know" BGP, it is impossible to remember everything. Thus, I spent some time reading on Cisco website, and learned a few good commands. One that was helpful here was show ip int | i line|list. That won’t be useable on the TSHOOT test, but it is a valid show command without looking at the running configuration.

      Thanks.

    2. Normally for IBGP we will configure a neighbor peering by using the loopback interfaces so in case of a link failure our IGP can find another route to the loopback interfaces.

      Using EBGP we can choose if we want to use the directly connected links or not just like IBGP. The difference is that you need to remember to use the "ebg-multihop" command.

  2. Thank you, Rene. I’ve completed the lab but I would like to see your solution. Any chance of posting?

  3. Hi Rene,
    I was able to do this lab by configuring the bgp neighbor commands, can you show us how you solved it without the neighbor statement? Thank you!

  4. Hi Rene,

    My solution for this lab is:

    [i]Fix the BGP neighbor adjacency between AS1 and AS2. You are not allowed to change the neighbor commands.[/i]

    [b]Amsterdam[/b]
    interface FastEthernet0/0
    no sh
    [b]Tokyo[/b]
    router bgp 2
    bgp confederation identifier 22

    [i]Fix the BGP neighbor adjacency between AS1 and AS3. You are not allowed to change the neighbor commands.[/i]

    [b]Amsterdam[/b]
    ip route 3.3.3.0 255.255.255.0 192.168.13.3
    router bgp 1
    neighbor 3.3.3.3 disable-connected-check OR neighbor 3.3.3.3 ebgp-multihop 2
    neighbor 3.3.3.3 update-source Loopback0

    [b]NewYork[/b]
    ip route 1.1.1.0 255.255.255.0 192.168.13.1
    router bgp 3
    neighbor 1.1.1.1 disable-connected-check OR neighbor 1.1.1.1 ebgp-multihop 2
    neighbor 1.1.1.1 update-source Loopback0

    [i]Fix the BGP neighbor adjacency within AS3. You are not allowed to change the neighbor commands.[/i]

    [b]NewYork[/b]
    ip route 4.4.4.0 255.255.255.0 192.168.34.4
    router bgp 3
    neighbor 4.4.4.4 update-source Loopback0

    [b]Miami[/b]
    ip route 3.3.3.0 255.255.255.0 192.168.34.3
    router bgp 3
    neighbor 3.3.3.3 update-source Loopback0
    interface FastEthernet0/0
    no ip access-group FILTER in

    Please let me know if this is right.

    Thanks.

  5. For Tokyo, I used local-as 22 to advertise both 2 and 22 to Amsterdam. Local-as is a fairly standard migration method for an AS that needs to identify itself with multiple AS numbers, say, after an acquisition of another AS.

  6. When you said “not allowed to change neighbor commands” I read that as saying not to use or include any at all. :p

Comments are closed.