EIGRP Neighbor Troubleshooting

Scenario:

Diamond corporation has hired you as an EIGRP expert to solve some of their routing problems. Recently the network was attacked and the hacker responsible changed the configurations of your routers so all EIGRP neighbor adjacencies are lost. It’s up to you to troubleshoot these issues and make sure all EIGRP neighbor adjacencies are restored.

Goal:

  • All IP addresses have been preconfigured for you.
  • EIGRP is preconfigured with the AS numbers as specified in the topology picture.
  • Do not use show run! (this will spoil the fun πŸ™‚ use the appropiate ‘show’ and ‘debug’ commands. This will teach you the skills needed to become a true troubleshooting master.
  • Your goal is simple: Make sure all EIGRP neighbor adjacencies are working!

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the troubleshooting issues for CCNP.

Would you like to be a master of troubleshooting too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of troubleshooting.

You will learn all the secrets about EIGRP troubleshooting and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNP TSHOOT

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

EIGRPNeighborTroubleshooting

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by RenΓ© Molenaar - CCIE #41726

You May Also Like

About the Author: Rene Molenaar

RenΓ© - CCIE #41726 is the creator of GNS3Vault.com where he shares CCNA, CCNP and CCIE R&S labs. He also blogs about networking on http://networklessons.com

27 Comments

    1. True but it’s a troubleshooting lab after all πŸ˜‰ You’ll be able to find out what AS number each router is using for EIGRP πŸ™‚

  1. Hello Rene,

    Thanks for very good EIGRP neighbor troubleshooting Lab.
    I am trying to troubleshooting lab and when I open any router logging message continues displays that k value mismatch, and It is giving me hard time to get console port to configure and verify show commands. This is kind of silly question but Is there any tricks or Short cut keys to get console port. Would you please guide me. Highly appreciate your help.

    Thanks!

    1. Hello toralkbrawla,
      I too was frustrated by the k-value messages, so on that same router I enabled a login password on vty and an enable password. From a neighboring router, that had ip connectivity, I telnet-ed into the one with the k-value messages and was able to proceed!

      HTH

      1. Hello Dardoufa,

        Thanks for your reply. I will try this.
        Somehow I get console port and I did no logging synchronous command for console line. Then I can able to solve troubleshoot neighbor issues. πŸ™‚

        1. The other solution is "no logging console 7". Which stops all logging on the console. If you have enabled "logging buffered" you still get the messages in the buffer log.

          HTH

    2. The notifications on your console are done by syslog, you can disable them πŸ™‚ By default they don’t show up on the VTY lines (telnet or ssh).

  2. Thanks Rene for the Lab.. very good! Just starting to realise how much Lab practice I need for the TSHOOT Exam.

  3. 1. Wrong IP address is configured on F0/0 on Nick router
    2. Worng AS number configured on Joey router
    3. Metric weights are configured differently on Mike router
    4. Extended access list configured on Jack router on the interface F0/0 connected to Jack router
    5. Passive interface F0/0 is configured on Jack router
    6. we do not know anything about the DLCIs configured , so just turn on the frame-relay inverse-arp

    1. Well I got first five with no issues. I did find a solution for #6 but mine is wrong even though it did bring up the adjacency. I looked at the frame relay switch setup and found out the DLCI (probably not allowed to do that) and then configured this.

      int s0/0
      frame-relay map ip 192.168.26.2 602
      Router eigrp 12345
      neighbor 192.168.26.2 Serial0/0

      int s2/0
      frame-relay map ip 192.168.26.6 206
      Router eigrp 12345
      neighbor 192.168.26.6 Serial2/0

      It worked but your solution is easier, and correct πŸ™‚

    2. Me too! My solution below as I look at the DLCI but think I’m not allow to do that.

      Are we allow to do "[b]Show run int S0/0[/b]"? Any command to see
      "[b]no frame-relay inverse-arp[/b]"

      interface Serial0/0
      ip address 192.168.26.6 255.255.255.0
      encapsulation frame-relay
      serial restart-delay 0
      frame-relay map ip 192.168.26.2 602 broadcast
      no frame-relay inverse-arp

      interface Serial2/0
      ip address 192.168.26.2 255.255.255.0
      encapsulation frame-relay
      serial restart-delay 0
      frame-relay map ip 192.168.26.6 206 broadcast
      no frame-relay inverse-arp
      end

      Thank you! πŸ™‚

    3. Hi all,
      I was able to get the DLCI number from sh frame-relay pvc
      on each router:

      Janice#sh frame-relay pvc

      PVC Statistics for interface Serial0/0 (Frame Relay DTE)

      Active Inactive Deleted Static
      Local 0 0 0 0
      Switched 0 0 0 0
      Unused 0 1 0 0

      DLCI = 602, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial0/0
      ….

      Then did the mapping for IPs.

      Pretty good lab. Thanks!

  4. Error 404 configuration file missing. would you mind uploading it again. thanks

  5. Hi all

    When I press the start button, there is an error message coming up “issues have been detected while starting nodes, check details” .
    The details are : “Mike :error from server 127.0.0.1 :7200:208,unable to find object’Mike’
    Nike:error from server 127.0.0.1 :7200:208,unable to find object’Nike
    Jack:error from server 127.0.0.1 :7200:208,unable to find object’Jack’
    ………

    Can anyone please tell me how to fix this and do the lab?
    Many thanks

  6. Thx for the lab Rene, was really a good lab. finished it without any big problems or being stuck on something. Thanks rene and keep up the good work πŸ™‚

  7. *Mar 1 00:22:43.719: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is down: retry limit exceeded
    *Mar 1 00:22:48.755: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is up: new adjacency
    *Mar 1 00:24:08.267: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is down: retry limit exceeded
    *Mar 1 00:24:09.307: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is up: new adjacency
    *Mar 1 00:25:28.823: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is down: retry limit exceeded
    *Mar 1 00:25:30.983: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 12345: Neighbor 192.168.45.5 (FastEthernet2/0) is up: new adjacency

    hey rene plz can u tell me about this error how to solve this……..?

    1. It looks like the unicast update messages are not making it across the link, the but multicast hellos are… look for some kind of data plane filter, for starters.

Comments are closed.