EIGRP Split Horizon

Scenario:

Jack and Joe both have important information to share with each other but they don’t have a direct connection between them. Tori agreed to help out and so they setup a Frame-Relay network to share information. EIGRP (Enhanced Interior Gateway Routing Protocol) is used as the routing protocol to dynamically learn new networks. Configuring EIGRP should be straight forward but Joe and Jack are complaining that they are unable to reach other’s networks…time for you to fix it!

Goal:

  • All IP addresses have been preconfigured for you.
  • Every router has a loopback0 interface:
    Tori: 1.1.1.1 /24
    Joe: 2.2.2.2 /24
    Jack: 3.3.3.3 /24
  • You are not allowed to make any changes to the frame-relay configurations.
  • Configure EIGRP AS 123 on all routers, advertise all networks.
  • Ensure router Joe and Jack can see each other’s loopback interfaces. Test this by sending a ping that is sourced from the loopback0 interfaces and destined for the other loopback0 interface.

It took me 1000s of hours reading books and doing labs, making mistakes over and over again until I mastered all the protocols for CCNA.

Would you like to be a master of networking too? In a short time without having to read 900 page books or google the answers to your questions and browsing through forums?

I collected all my knowledge and created a single ebook for you that has everything you need to know to become a master of CCNA.

You will learn all the secrets about EIGRP, distance vector routing protocols, split horizon and more.

Does this sound interesting to you? Take a look here and let me show you how to Master CCNA!

IOS:

c3640-jk9s-mz.124-16.bin

Topology:

EIGRP Split Horizon

Video Solution:

Configuration Files

You need to register to download the GNS3 topology file. (Registration is free!)

Once you are logged in you will find the configuration files right here.

Opt In Image
Do you want your CCNA or CCNP Certificate?

The How to Master series helps you to understand complex topics like spanning-tree, VLANs, trunks, OSPF, EIGRP, BGP and more.

Written by René Molenaar - CCIE #41726

Comments

  1. Profile photo of Mahir Ali Ahmed says

    Hi Guys,

    I achieved the goal by just disabling the split horizon on Tori, is that correct or not. Because you said not make any changes in Frame Relay Configuration so that’s why I didn’t put any frame map command.

    Regards

    Report user
  2. Profile photo of Olivier says

    There is no need to modify or add any frame-relay statements.
    You have to specify the AS# where you disable split horizon on.
    (config-if)#no ip split-horizon eigrp 123
    I believe just entering “no ip split-horizon” will only apply to RIP routing.

    Report user
  3. Profile photo of Rene Molenaar says

    Split Horizon is the answer to this solution. We have multipoint frame-relay here and prefixes learned from the spokes are not advertised.

    Disable split horizon on router Tori is what you need to do, make sure you pick the “no ip split-horizon eigrp 123″ command otherwise you disable it for RIP.

    Fixing the problem with frame-relay statements is possible but not the solution since the goal states “You are not allowed to make any changes to the frame-relay configurations.”.

    Good luck!

    Rene

  4. Profile photo of Melody says

    Hi everyone,
    I can ping Jack and Joe from Tori. but can’t ping from Jack to Joe or vise versa.
    here is my configuration:
    Tori:
    ” no ip spilt-horizon eigrp 123

    router eigrp 123
    network 192.168.123.0
    network 1.0.0.0 ”

    Joe:
    router eigrp 123
    network 192.168.123.0
    network 2.0.0.0

    Jack:
    router eigrp 123
    network 192.168.123.0
    network 3.0.0.0

    do I miss something and therefore can’t ping between Jack and Joe?

    Thanks!!!
    router eigrp 123
    network 192.168.123.0
    network .0.0.0

    Report user
  5. Profile photo of william says

    Hello,
    I can do this part:
    Ensure router Joe and Jack can see each other’s loopback interfaces. Test this by sending a ping that is sourced from the loopback0 interfaces and destined for the other loopback0 interface.
    But if a send a ping without specifying the source, then the ping fails. Any one can explain this for me?

    —output–
    JACK#ping 2.2.2.2 so 3.3.3.3

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    Packet sent with a source address of 3.3.3.3
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/52 ms
    JACK#ping 2.2.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)
    JACK#

    Report user
  6. Profile photo of strasser says

    @william2

    This stumped me too. I found out the following:

    Standard ping uses the outside IP for sending IP. “Ping 2.2.2.2″ will use 192.168.123.3 as source (Jack outside IP). The return packet from Joe will be sent to 192.168.123.0 network, which is local. The packet will be sent to Layer 2 for processing. Layer 2 (Frame Relay) does not have a mapping for 192.168.123.3 and inverse ARP is disabled.

    Result: packet fails.

    This is why adding frame relay maps between Joe and Jack allow the ping to succeed.

    Report user
  7. Profile photo of Rene Molenaar says

    The explanation of strasser is the perfect answer to this lab. That’s why the ping from the loopback interface works and from the physical interface it doesn’t.

    If you want proof you can debug your frame-relay packets and you’ll see it has encapsulation errors because there’s no mapping for the physical interface IP address.

  8. Profile photo of Rene Molenaar says

    Frame relay has two methods of doing the Layer 2 (DLCI) to Layer 3 (IP) mapping:

    – Inverse ARP
    – The Frame-relay MAP command.

    Inverse ARP will work if you have your IP addresses on the physical interface. You can check the mapping by using the ‘show frame-relay map’ command. Check your router to see if it has a mapping…

    If you are using sub-interfaces you need to do the mapping yourself…there is no way for your router to tell to which sub-interface the DLCI belongs.

  9. Profile photo of Kenneth Goh says

    [color=red][/color]I did a [color=purple]no ip split-horizon eigrp 123[/color], why is it still showing [color=red][color=blue]Split horizon is enabled[/color][/color]?

    interface Serial0/0.123 multipoint
    ip address 192.168.123.1 255.255.255.0
    no ip split-horizon eigrp 123

    TORI#show ip int Serial0/0.123
    Serial0/0.123 is up, line protocol is up
    Internet address is 192.168.123.1/24
    Broadcast address is 255.255.255.255
    Address determined by non-volatile memory
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.10
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    [color=red]Split horizon is enabled[/color]

    Report user
  10. Profile photo of Kenneth Goh says

    Hi Rene,

    Is there any show command to show that split horizon is disable for EIGRP? Sorry correct if I am wrong, from your video demonstration you did a

    TORI#show ip int Serial0/0.123

    and it shows that Split horizon is enabled before you proceed with ‘[color=red]no ip split-horizon eigrp 123[/color]‘ input

    interface Serial0/0.123 multipoint
    ip address 192.168.123.1 255.255.255.0
    no ip split-horizon eigrp 123

    But why do we do a show ip int Serial0/0.123 when this (Split horizon is enabled) apply to RIP?

    Thanks,

    Report user
    • Profile photo of Rene Molenaar says

      You are right, this is a mistake I made…if you look at the interface we are looking at RIP split horizon, not for EIGRP. I’m not sure which show command we can use to check if EIGRP split horizon is enabled or disabled…hmm…

  11. Profile photo of mayank bhatia says

    @rene

    just one question

    when i start eigrp on router TORI and JOE. it automatically forming neighbor with each other .by sending hello on 224.0.0.10 address which is multicast address

    how can a frame-relay network allow passing multicast packets through it . it should be sudo broadcast right!! or typing manual neighbor will sent unicast messages to each neighbor.

    please can some one explain it..

    Report user
  12. Profile photo of mayank bhatia says

    @rene

    just one question

    when i start eigrp on router TORI and JOE. it automatically forming neighbor with each other .by sending hello on 224.0.0.10 address which is multicast address

    how can a frame-relay network allow passing multicast packets through it . it should be sudo broadcast right!! or typing manual neighbor will sent unicast messages to each neighbor.

    please can some one explain it..

    Report user
  13. Profile photo of Michael Reedy says

    Question. Why is each interface configured for multipoint? vs. the EIGRP over frame-relay lab with multipoint where only the hub is multipoint? I don’t see this configuration in your mastering CCNP route book or any lab. Please explain. The only answer I come up with is that the Curly/Larry have configs on subinterfaces.

    Report user

Leave a reply:

Your email address will not be published. Required fields are marked *

If you have any technical questions, please use the Forum instead of posting a comment.